Problème de date et d'heure pour /sys et /proc

Le
giggz
Bonsoir la liste,

je viens de me rendre compte d'un problème sur mon laptop en sid : en
regardant sur ma racine je vois :
drwxr-xr-x 11 root root 0 2007-09-27 01:48 sys/
dr-xr-xr-x 115 root root 0 2007-09-27 01:48 proc/
alors qu'il est 2h plus tôt
la commande date me renvoie bien la bonne date
Ces répertoires étant liés au noyauje me demandais si c'était normal
?!? à mon avis nonmais bond'où cela peut il venir ?!? une histoire
d'UTC, de mauvaise gestion de l'heure venant du biossi vous avez des
idées

Merci de vos réponses
Guillaume


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy Roussin
Le #9607661
Bonjour,

Peut-etre qu'au moment ou ces répertoires sont créés (au demarrage par
le noyau) les histoires de gestion d'heure en fonction du lieu ne sont
pas encore mis en places ... et donc tu te récupères l'heure du bios.

Guy

giggz a écrit :
Bonsoir la liste,

je viens de me rendre compte d'un problème sur mon laptop en sid : en
regardant sur ma racine je vois :
drwxr-xr-x 11 root root 0 2007-09-27 01:48 sys/
dr-xr-xr-x 115 root root 0 2007-09-27 01:48 proc/
alors qu'il est 2h plus tôt...
la commande date me renvoie bien la bonne date...
Ces répertoires étant liés au noyau...je me demandais si c'étai t normal
?!? à mon avis non...mais bon...d'où cela peut il venir ?!? une his toire
d'UTC, de mauvaise gestion de l'heure venant du bios...si vous avez des
idées...

Merci de vos réponses
Guillaume




Gabrielle Chatelet
Le #9607641
On Thursday 27 September 2007 08:43, Guy Roussin wrote:
Bonjour,

Peut-etre qu'au moment ou ces répertoires sont créés (au demarrage par
le noyau) les histoires de gestion d'heure en fonction du lieu ne sont
pas encore mis en places ... et donc tu te récupères l'heure du bios.

Guy

giggz a écrit :
> Bonsoir la liste,
>
> je viens de me rendre compte d'un problème sur mon laptop en sid : en
> regardant sur ma racine je vois :
> drwxr-xr-x 11 root root 0 2007-09-27 01:48 sys/
> dr-xr-xr-x 115 root root 0 2007-09-27 01:48 proc/
> alors qu'il est 2h plus tôt...
> la commande date me renvoie bien la bonne date...
> Ces répertoires étant liés au noyau...je me demandais si c'étai t normal
> ?!? à mon avis non...mais bon...d'où cela peut il venir ?!? une his toire
> d'UTC, de mauvaise gestion de l'heure venant du bios...si vous avez des
> idées...
>
> Merci de vos réponses
> Guillaume




Essaies tzconfig
Sébastien NOBILI
Le #9607631
Le jeudi 27 septembre 07 à 8:56, Gabrielle Chatelet a écrit :
| > giggz a écrit :
| > > je viens de me rendre compte d'un problème sur mon laptop en sid : en
| > > regardant sur ma racine je vois :
| > > drwxr-xr-x 11 root root 0 2007-09-27 01:48 sys/
| > > dr-xr-xr-x 115 root root 0 2007-09-27 01:48 proc/
| > > alors qu'il est 2h plus tôt...
| > > la commande date me renvoie bien la bonne date...
|
| Essaies tzconfig

Chez moi la date et l'heure sur les répertoires /sys et /proc semble
correspondre à la date et l'heure du démarrage de la machine.

Seb


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
GiGGz
Le #9607621
Sébastien NOBILI a écrit :
Le jeudi 27 septembre 07 à 8:56, Gabrielle Chatelet a écrit :
| > giggz a écrit :
| > > je viens de me rendre compte d'un problème sur mon laptop en sid : en
| > > regardant sur ma racine je vois :
| > > drwxr-xr-x 11 root root 0 2007-09-27 01:48 sys/
| > > dr-xr-xr-x 115 root root 0 2007-09-27 01:48 proc/
| > > alors qu'il est 2h plus tôt...
| > > la commande date me renvoie bien la bonne date...
|
| Essaies tzconfig

Chez moi la date et l'heure sur les répertoires /sys et /proc semble
correspondre à la date et l'heure du démarrage de la machine.

Seb




Merci de vos réponses,

je vais m'y remettre ce soir.
J'aurai tendance à penser comme guy. mais bon on ne sais jamais.

le tzconfig est normalement bien configuré...je vais regarder. Etant en
SID on ne sait jamais...un bug passager d'une version a pu faire des
bêtises. je n'ai jamais eu de problème d'horloge. Tjs à la bonne heure.
Le dual boot windows-linux se fait bien. pas de pb de ce côté là.

pour seb : quelle est l'heure de ton bios ? UTC ou localtime ?

Merci,
Guillaume


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sébastien NOBILI
Le #9607601
Le jeudi 27 septembre 07 à 10:03, GiGGz a écrit :
| le tzconfig est normalement bien configuré...je vais regarder. Etant en
| SID on ne sait jamais...un bug passager d'une version a pu faire des
| bêtises. je n'ai jamais eu de problème d'horloge. Tjs à la bonne heure.
| Le dual boot windows-linux se fait bien. pas de pb de ce côté là.
|
| pour seb : quelle est l'heure de ton bios ? UTC ou localtime ?

J'ai éradiqué tout Windows de ma machine, mon BIOS est donc réglé en
UTC.

| Merci,
| Guillaume

Pas de quoi
Seb


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
GiGGz
Le #9607591
Sébastien NOBILI a écrit :
Le jeudi 27 septembre 07 à 10:03, GiGGz a écrit :
| le tzconfig est normalement bien configuré...je vais regarder. Etant en
| SID on ne sait jamais...un bug passager d'une version a pu faire des
| bêtises. je n'ai jamais eu de problème d'horloge. Tjs à la bonne heure.
| Le dual boot windows-linux se fait bien. pas de pb de ce côté là.
|
| pour seb : quelle est l'heure de ton bios ? UTC ou localtime ?

J'ai éradiqué tout Windows de ma machine, mon BIOS est donc réglé en
UTC.




zut mon dernier espoir disparait ;)
tu tournes en sid aussi ? à jour ? c'est histoire d'être sur d'avoir les
mêmes versions de packages...

| Merci,
| Guillaume

Pas de quoi
Seb






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
GiGGz
Le #9607581
GiGGz a écrit :
Sébastien NOBILI a écrit :
Le jeudi 27 septembre 07 à 10:03, GiGGz a écrit :
| le tzconfig est normalement bien configuré...je vais regarder. Etant
en | SID on ne sait jamais...un bug passager d'une version a pu faire
des | bêtises. je n'ai jamais eu de problème d'horloge. Tjs à la bonne
heure. | Le dual boot windows-linux se fait bien. pas de pb de ce côté
là.
| | pour seb : quelle est l'heure de ton bios ? UTC ou localtime ?

J'ai éradiqué tout Windows de ma machine, mon BIOS est donc réglé en
UTC.




zut mon dernier espoir disparait ;)
tu tournes en sid aussi ? à jour ? c'est histoire d'être sur d'avoir les
mêmes versions de packages...

| Merci,
| Guillaume

Pas de quoi
Seb









Je viens de me rendre compte qu'il y a vraiment un problème...hier soir
je n'y ai pas fait attention (fatigue tout ça tout ça), mais l'heure
indiquée sur /proc et /sys n'est pas l'heure UTC. C'est l'heure local +
2heures...dc comme si mon bios était configuré en heure local et ma
debian en UTC. Ce qui est étrange c'est que "date" et toutes les
horloges possibles et imaginables de ma debiazn me renvoie la bonne
heure...rhaaaaaaaa je suis bon pour me taper ts les fichiers de config
de tzconfig...


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #9607541
[snip]

Bon petit changement :
Dans le BIOS je suis en localtime...windows oblige...grrrr.

la commande date me donne bien l'heure locale.
la commande date -u me donne bien l'heure universelle.
la commande hwclock me donne bien l'heure locale.

Si je fais dpkg-reconfigure tzdata en choisissant comme pays europe puis
paris les infos que me donne tzdata sont bonnes à la fin.

Dans /etc/default/rcS j'ai bien UTC=no

pourtant ll /proc ou ll /sys me renvoient tjs l'heure locale +2

Ai je oublié des fichiers ?
La commande tzconfig a apparemment disparu...dommage...

Des idées ?
Guillaume


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #9607531
giggz a écrit :
[snip]

Bon petit changement :
Dans le BIOS je suis en localtime...windows oblige...grrrr.

la commande date me donne bien l'heure locale.
la commande date -u me donne bien l'heure universelle.
la commande hwclock me donne bien l'heure locale.

Si je fais dpkg-reconfigure tzdata en choisissant comme pays europe puis
paris les infos que me donne tzdata sont bonnes à la fin.

Dans /etc/default/rcS j'ai bien UTC=no

pourtant ll /proc ou ll /sys me renvoient tjs l'heure locale +2

Ai je oublié des fichiers ?
La commande tzconfig a apparemment disparu...dommage...

Des idées ?
Guillaume





Bon j'ai remarqué un truc :
en tapant mount j'ai :
/dev/hda1 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode55)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type tmpfs (rw,mode55)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,modeb0)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
/dev/hda6 on /home type ext3 (rw)
/dev/hda4 on /donnees type ext3 (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)

j'ai vérifié les montages le tmpfs, proc et sysfs me donne l'heure
locale + 2heures. toutes les autres sont montés à la bonne heure, ie
localtime...

Quel est le script qui s'occupe de monter tmpfs,proc et sysfs

Merci
Guillaume




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sébastien NOBILI
Le #9607491
Le jeudi 27 septembre 07 à 10:23, GiGGz a écrit :
| Sébastien NOBILI a écrit :
| >J'ai éradiqué tout Windows de ma machine, mon BIOS est donc réglé en
| >UTC.
| >
|
| zut mon dernier espoir disparait ;)
| tu tournes en sid aussi ? à jour ? c'est histoire d'être sur d'avoir les
| mêmes versions de packages...

Non, c'est une machine à usage professionnel, donc pas de risque, c'est
du Etch.

Seb


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme