Problème de dates

Le
jean berti
Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4357971
Bonjour.
En ligne1 (impératif) :
=SOMMEPROD((MOIS($A$1:$A$100)=LIGNE())*$B$1:$B$100)
à recopier vers le bas.
Cordialement.
Daniel
"jean berti"
Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide



jean berti
Le #4357951
Bonjour Daniel

Ta formule me donne le montant du mois.
Ce que je cherche c'est la valeur du 31/01/2007- la valeur du 01/01/2007 et
ce pour tous les mois de 2007

Merci
"Daniel" %
Bonjour.
En ligne1 (impératif) :
=SOMMEPROD((MOIS($A$1:$A$100)=LIGNE())*$B$1:$B$100)
à recopier vers le bas.
Cordialement.
Daniel
"jean berti"
Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide







LSteph
Le #4357931
Bonsoir,

Pour avoir cette différence en face de chaque premier du mois:

Exemple en c à recopier vers bas
=SI(JOUR(A2)=1;SOMMEPROD(($A$2:$A$511=FIN.MOIS(A2;0))*($B$2:$B$511))-B2;"")

Sinon pour avoir une petite synthèse indépendament ailleurs
supposons G par rapport à des date de 01 du mois entrées en H

=INDEX($B$2:$B$511;EQUIV(FIN.MOIS(H2;0);$A$2:$A$511;0);1)
-INDEX($B$2:$B$511;EQUIV(H2;$A$2:$A$511;0))

Cordialement.

lSteph



Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide




jean berti
Le #4357911
Bonsoir Steph

=SI(JOUR(A2)=1;SOMMEPROD(($A$2:$A$511=FIN.MOIS(A2;0))*($B$2:$B$511))-B2;"")
= #NOM?
J'ais mis l'ultilitaire d'analyse.
Je ne cherche pas à avoir cette différence en face de chaque premier du mois
C'est pour mettre dans un tableau Récap.
Quand à l'autre formule elle me donne 29?
Merci

"LSteph"
Bonsoir,

Pour avoir cette différence en face de chaque premier du mois:

Exemple en c à recopier vers bas
=SI(JOUR(A2)=1;SOMMEPROD(($A$2:$A$511=FIN.MOIS(A2;0))*($B$2:$B$511))-B2;"")

Sinon pour avoir une petite synthèse indépendament ailleurs
supposons G par rapport à des date de 01 du mois entrées en H

=INDEX($B$2:$B$511;EQUIV(FIN.MOIS(H2;0);$A$2:$A$511;0);1)
-INDEX($B$2:$B$511;EQUIV(H2;$A$2:$A$511;0))

Cordialement.

lSteph



Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide




Daniel
Le #4357841
En ligne 1 :
=RECHERCHEV(FIN.MOIS(DATE(2007;LIGNE();1);0);$A:$B;2;0)-RECHERCHEV(DATE(2007;LIGNE();1);$A:$B;2;0)
avec la macro complémentaire "utilitaire d'analyse".
Daniel
"jean berti" %
Bonjour Daniel

Ta formule me donne le montant du mois.
Ce que je cherche c'est la valeur du 31/01/2007- la valeur du 01/01/2007
et ce pour tous les mois de 2007

Merci
"Daniel" %
Bonjour.
En ligne1 (impératif) :
=SOMMEPROD((MOIS($A$1:$A$100)=LIGNE())*$B$1:$B$100)
à recopier vers le bas.
Cordialement.
Daniel
"jean berti"
Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide











LSteph
Le #4357821
..Oui j'ai toujours l'utilitaire c'est pratique, j'aurais dû préciser
Les deux formules renvoient le même résultat
ainsi tu as deux façons possible après c'est à toi d'adapter à ton tableau
la seconde formule devrait répondre à ton besoin
si elle renvoie 29 c'est que cela doit correspondre
à ce qu'il y a en B cf. à ce que tu as demandé par rapport à A.
Sinon , si tu le souhaites, précise mieux ta demande ou les dispositions
particulières à ton tableau.

Cordialement.

lSteph
Bonsoir Steph

=SI(JOUR(A2)=1;SOMMEPROD(($A$2:$A$511=FIN.MOIS(A2;0))*($B$2:$B$511))-B2;"")
= #NOM?
J'ais mis l'ultilitaire d'analyse.
Je ne cherche pas à avoir cette différence en face de chaque premier du mois
C'est pour mettre dans un tableau Récap.
Quand à l'autre formule elle me donne 29?
Merci

"LSteph"
Bonsoir,

Pour avoir cette différence en face de chaque premier du mois:

Exemple en c à recopier vers bas
=SI(JOUR(A2)=1;SOMMEPROD(($A$2:$A$511=FIN.MOIS(A2;0))*($B$2:$B$511))-B2;"")

Sinon pour avoir une petite synthèse indépendament ailleurs
supposons G par rapport à des date de 01 du mois entrées en H

=INDEX($B$2:$B$511;EQUIV(FIN.MOIS(H2;0);$A$2:$A$511;0);1)
-INDEX($B$2:$B$511;EQUIV(H2;$A$2:$A$511;0))

Cordialement.

lSteph



Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide








jean berti
Le #4357801
Re Daniel

Ta formule fonctionne bien mais il manque la valeur de B1
je crois que tu prends pour janvier 31/01/2007 moins 01/01/2007 ; le
résultat est bon
Pour février c'est 28/02/2007 moins 31/01/2007 et je pense que ta formule
démarre au 01/02/2007
Peut tu me le confirmer?
J'ai rajouté + B1 et tout baigne
Merci beaucoup Daniel
Jean Berti

"Daniel"
En ligne 1 :
=RECHERCHEV(FIN.MOIS(DATE(2007;LIGNE();1);0);$A:$B;2;0)-RECHERCHEV(DATE(2007;LIGNE();1);$A:$B;2;0)
avec la macro complémentaire "utilitaire d'analyse".
Daniel
"jean berti" %
Bonjour Daniel

Ta formule me donne le montant du mois.
Ce que je cherche c'est la valeur du 31/01/2007- la valeur du 01/01/2007
et ce pour tous les mois de 2007

Merci
"Daniel" %
Bonjour.
En ligne1 (impératif) :
=SOMMEPROD((MOIS($A$1:$A$100)=LIGNE())*$B$1:$B$100)
à recopier vers le bas.
Cordialement.
Daniel
"jean berti"
Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide















jean berti
Le #4357791
Merci Steph

Avec ton aide et celle de Daniel
J'y suis arrivé.
Merci
cordialement
J.berti


"LSteph"
..Oui j'ai toujours l'utilitaire c'est pratique, j'aurais dû préciser
Les deux formules renvoient le même résultat
ainsi tu as deux façons possible après c'est à toi d'adapter à ton
tableau
la seconde formule devrait répondre à ton besoin
si elle renvoie 29 c'est que cela doit correspondre
à ce qu'il y a en B cf. à ce que tu as demandé par rapport à A.
Sinon , si tu le souhaites, précise mieux ta demande ou les dispositions
particulières à ton tableau.

Cordialement.

lSteph
Bonsoir Steph

=SI(JOUR(A2)=1;SOMMEPROD(($A$2:$A$511=FIN.MOIS(A2;0))*($B$2:$B$511))-B2;"")
= #NOM?
J'ais mis l'ultilitaire d'analyse.
Je ne cherche pas à avoir cette différence en face de chaque premier du
mois
C'est pour mettre dans un tableau Récap.
Quand à l'autre formule elle me donne 29?
Merci

"LSteph"
Bonsoir,

Pour avoir cette différence en face de chaque premier du mois:

Exemple en c à recopier vers bas
=SI(JOUR(A2)=1;SOMMEPROD(($A$2:$A$511=FIN.MOIS(A2;0))*($B$2:$B$511))-B2;"")

Sinon pour avoir une petite synthèse indépendament ailleurs
supposons G par rapport à des date de 01 du mois entrées en H

=INDEX($B$2:$B$511;EQUIV(FIN.MOIS(H2;0);$A$2:$A$511;0);1)
-INDEX($B$2:$B$511;EQUIV(H2;$A$2:$A$511;0))

Cordialement.

lSteph



Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide









Daniel
Le #4357781
Oui, j'ai compté du 01/02/2007 au 28/02/2007.
Daniel
"jean berti" %
Re Daniel

Ta formule fonctionne bien mais il manque la valeur de B1
je crois que tu prends pour janvier 31/01/2007 moins 01/01/2007 ; le
résultat est bon
Pour février c'est 28/02/2007 moins 31/01/2007 et je pense que ta formule
démarre au 01/02/2007
Peut tu me le confirmer?
J'ai rajouté + B1 et tout baigne
Merci beaucoup Daniel
Jean Berti

"Daniel"
En ligne 1 :
=RECHERCHEV(FIN.MOIS(DATE(2007;LIGNE();1);0);$A:$B;2;0)-RECHERCHEV(DATE(2007;LIGNE();1);$A:$B;2;0)
avec la macro complémentaire "utilitaire d'analyse".
Daniel
"jean berti" %
Bonjour Daniel

Ta formule me donne le montant du mois.
Ce que je cherche c'est la valeur du 31/01/2007- la valeur du 01/01/2007
et ce pour tous les mois de 2007

Merci
"Daniel" %
Bonjour.
En ligne1 (impératif) :
=SOMMEPROD((MOIS($A$1:$A$100)=LIGNE())*$B$1:$B$100)
à recopier vers le bas.
Cordialement.
Daniel
"jean berti"
Bonjour à tous

En colonne A des dates 01/01/2007 au 31/12/2007
En B des sommes
J'aimerai pouvoir faire la différence entre la somme du 31/01/2007 et
01/01/2007 et cela sur chaque mois de l'année.
Merci de votre aide



















Publicité
Poster une réponse
Anonyme