Problème deluninstall.vbs "résolu mais..."

Le
Robert H
Bonjour,

Lorsque je lance deluninstall.vbs avec Firefox 3,6,3 ouvert, j'ai le
mesage habituel "Veuillez patienter un instant" et puis rien ne se
passe. Je précise que Firefox est mon navigateur par défaut.

Par contre deluninstall.vbs marche parfaitement lorsque c'est IE8 qui
est mon navigateur par défaut.

Le maître (JCB) ou quelqu'un d'autre pourrait m'expliquer le pourquoi
du comment?

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
testeur
Le #21618171
C'est très simple, dans le script , JCB lance explicitement Internet explorer pour visualiser la
liste en HTML.

Olivier
Robert H
Le #21624221
Le Fri, 23 Apr 2010 18:54:56 +0200, écrivait:

C'est très simple, dans le script , JCB lance explicitement Internet explorer pour visualiser la
liste en HTML.

Olivier



OK! J'ai vu en lisant le script. Dorénavant je mettrai IE8 comme
navigateur pardéfaut lorsque j'utiliserai deluninstall
Merci
Sibusate
Le #21626561
OK! J'ai vu en lisant le script. Dorénavant je mettrai IE8 comme
navigateur pardéfaut lorsque j'utiliserai deluninstall



Bonsoir Robert,
Ton explication ne me parait pas la bonne : sur un PC Windows XP Pro +
SP3, j'ai Firefox par défaut (j'ai vérifié). Je viens de faire l'essai
et Deluninstall.vbs n'a eu aucune difficulté à ouvrir IE8 et
parfaitement fait le ménage de dossiers de désinstallation des KB.
Malheureusement je n'ai pas d'explication au sujet de ces différences de
comportement...
François
Jean-Claude BELLAMY
Le #21634841
"Sibusate" discussion :
OK! J'ai vu en lisant le script. Dorénavant je mettrai IE8 comme
navigateur pardéfaut lorsque j'utiliserai deluninstall



Bonsoir Robert,
Ton explication ne me parait pas la bonne : sur un PC Windows XP Pro +
SP3, j'ai Firefox par défaut (j'ai vérifié). Je viens de faire l'essai et
Deluninstall.vbs n'a eu aucune difficulté à ouvrir IE8 et parfaitement
fait le ménage de dossiers de désinstallation des KB.



Je confirme !

Mon script crée dynamiquement un fichier HTML ("deluninstall.html"), qu'il
ouvre ensuite avec IE en créant une instance de l'objet
"InternetExplorer.Application".

Cette ouverture est EXPLICITE, ce qui veut dire qu'on se contrefiche
totalement que IE soit ou non le navigateur par défaut.
JAMAIS je n'aurais osé concevoir un script qui exigerait d'avoir IE comme
navigateur par défaut!!!
La seule contrainte est que IE soit disponible sur la machine, ce qui est
toujours le cas à partir de W2k ou Win98.



--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr
Robert H
Le #22097061
Le Mon, 26 Apr 2010 21:01:25 +0200, écrivait:


"Sibusate" discussion :
OK! J'ai vu en lisant le script. Dorénavant je mettrai IE8 comme
navigateur pardéfaut lorsque j'utiliserai deluninstall



Bonsoir Robert,
Ton explication ne me parait pas la bonne : sur un PC Windows XP Pro +
SP3, j'ai Firefox par défaut (j'ai vérifié). Je viens de faire l'essai et
Deluninstall.vbs n'a eu aucune difficulté à ouvrir IE8 et parfaitement
fait le ménage de dossiers de désinstallation des KB.



Je confirme !

Mon script crée dynamiquement un fichier HTML ("deluninstall.html"), qu'il
ouvre ensuite avec IE en créant une instance de l'objet
"InternetExplorer.Application".

Cette ouverture est EXPLICITE, ce qui veut dire qu'on se contrefiche
totalement que IE soit ou non le navigateur par défaut.
JAMAIS je n'aurais osé concevoir un script qui exigerait d'avoir IE comme
navigateur par défaut!!!
La seule contrainte est que IE soit disponible sur la machine, ce qui est
toujours le cas à partir de W2k ou Win98.



Exusez-moi de répondre tardivement! Le problème que j'ai avec IE8
c'est que si je clique sur un lien dans un autre programme
(thunderbird, FreeAgent, etc.) je n'ai aucune réponse de IE8.
IL faut que je lance IE8 et ensuite cliquer sur le lien pour que ça
marche. Bizarre!
J'ai ce problème quand IE8 est le navigateur par défaut.

Si vous avez une solution, je vous remercie de m'en aviser.
Merci

P.S. Je n'ai pas ce problème avec Firefox quand il est le nvigateur
par défaut.
Publicité
Poster une réponse
Anonyme