Problème de dépendance apache

Le
Nahliel Steinberg
Bonjour,
J'ai installé un serveur apache et j'ai maintenant besoin d'installer le module php5-ldap.

Apt m'injure en me disant ceci :

Les paquets suivants contiennent des dépendances non satisfaites :
php5-ldap: Dépend: php5-common (= 5.2.6.dfsg.1-1+lenny13) mais 5.2.17-0.dotdeb.0 devra être installé
E: Paquets défectueux

Mon php5-common est bien installé, et il est bien en version 5.2.17.

Avez-vous une idée, j'ai fait un recherche dans google avec le message d'injure d'apt mais je ne trouve rien.

Mon php.info me renvoi bien la version PHP Version 5.2.17-0.dotdeb.0


--
Nahliel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20111020095626.GA6894@srvdebian.info-cr.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #23886241
On Thu, 20 Oct 2011 11:56:26 +0200
Nahliel Steinberg
J'ai installé un serveur apache et j'ai maintenant besoin d'installe r le
module php5-ldap.



C'est pas ce que t'as fais de mieux (il y a mieux, plus rapide, plus secure
et avec une empreinte RAM bcp moins grasse).

Apt m'injure en me disant ceci :

Les paquets suivants contiennent des dépendances non satisfaites  :
php5-ldap: Dépend: php5-common (= 5.2.6.dfsg.1-1+lenny13) mais
5.2.17-0.dotdeb.0 devra être installé
E: Paquets défectueux

Mon php5-common est bien installé, et il est bien en version 5.2.17. ...



Non il ne t'injuries pas, il t'indique que comme tu joues à intég rer
des sources non-Debian tu as cassé ta distro; puisqu'il veut:
php5-common = 5.2.6.dfsg.1-1+lenny13 et que tu ne lui proposes que:
php5-common >> 5.2.6.dfsg.1-1+lenny13 (puisque = 5.2.17-0.dotdeb.0).

Ca vient du fait que php5-ldap doit appartenir à la branche Debian, al ors que
le reste de php doit appartenir à dotweb.

--
A person who has both feet planted firmly in the air can be safely called
a liberal.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Nahliel Steinberg
Le #23886531
Ca vient du fait que php5-ldap doit appartenir à la branche Debian, alors que
le reste de php doit appartenir à dotweb.



Merci pour ta réponse, j'ai télécharger le paquet manuellement et j'ai installé avec le -install-nodepends

Le support y est par contre je suis ennuyé de ce que tu me dis.





--
Nahliel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #23886561
On Thu, 20 Oct 2011 13:52:23 +0200
Nahliel Steinberg
>Ca vient du fait que php5-ldap doit appartenir à la branche Debian, alors que
>le reste de php doit appartenir à dotweb.

Merci pour ta réponse, j'ai télécharger le paquet manuelle ment et j'ai
installé avec le -install-nodepends

Le support y est par contre je suis ennuyé de ce que tu me dis.



Si tu te cantonnes à dotweb, ça n'est pas trop grâve parce q u'il contient
peu de packages, et comme tu l'as décris, la solution reste simple.

--
You learn to write as if to someone else because NEXT YEAR YOU WILL BE
"SOMEONE ELSE."

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme