Problème de droit et de montage avec sshfs !

Le
Mourad Jaber
Bonjour,

J'ai un souci nouveau (mais il ne me semble pas y avoir eu de mise à jour !) avec sshfs

C'est un plugin fuse que j'utilise depuis de nombreuse année et je n'avais pas eu ce
problème jusqu'à présent !

Quand j'essai de monter un "partage" ssh j'obtiens le message suivant :
$ sshfs 192.168.33.15: ./tiny-blob
mourad@192.168.33.15's password:
fusermount: failed to access mountpoint /home/mourad/tiny-blob: Permission denied

Pourtant quand je me connecte à la machine en ssh avec le même compte et mot de passe,
tout se passe bien !

Cela met le mount de montage en vrac (permissions ??????????? ? ? ?
? ? tiny-blob), je ne peux pas le démonter sauf à coup de "umount -l" en tand
que root !

Est-ce que quelqu'un aurait une idée sur ce point très gênant ?

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4E1C14E2.6010807@nativobject.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois Mescam
Le #23555381
J'ai aussi un pb un peu moins grave. Depuis que fuse-utils est remplacé
par fuse je ne peux plus démonter mes montages sshfs que je faisais
avant sans pb même sans être root

$ fusermount -u <point de montage>
/bin/umount : option non reconnue « --fake »
Usage: umount -h | -V
umount -a [-d] [-f] [-r] [-n] [-v] [-t vfstypes] [-O opts]
umount [-d] [-f] [-r] [-n] [-v] special | node...
$ sudo fusermount -u <point de montage>
[sudo] password for <user>:
fusermount: failed to unmount <point de montage>: Invalid argument

Je suis en testing mise à jour régulièrement.

Les versions des paquets sont :

sshfs 2.2-1
fuse 2.8.5-3
fuse-utils 2.8.5-3
ifuse 1.0.0-1
libfuse2 2.8.5-3

Remarque je ne peux enlever fuse-utils car sshfs en dépend, peu-être
est-ce la le noeud du pb.


On 12/07/2011 11:33, Mourad Jaber wrote:
Bonjour,

J'ai un souci nouveau (mais il ne me semble pas y avoir eu de mise à
jour !) avec sshfs...

C'est un plugin fuse que j'utilise depuis de nombreuse année et je
n'avais pas eu ce problème jusqu'à présent !

Quand j'essai de monter un "partage" ssh j'obtiens le message suivant :
$ sshfs 192.168.33.15: ./tiny-blob
's password:
fusermount: failed to access mountpoint /home/mourad/tiny-blob:
Permission denied

Pourtant quand je me connecte à la machine en ssh avec le même compte et
mot de passe, tout se passe bien !

Cela met le mount de montage en vrac (permissions ??????????? ? ?
? ? ? tiny-blob), je ne peux pas le démonter
sauf à coup de "umount -l" en tand que root !

Est-ce que quelqu'un aurait une idée sur ce point très gênant ?

++

Mourad





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/ivh6j3$l8a$
Mourad Jaber
Le #23555371
Autant pour moi, en faisant une mise à jour des packages (version 2.8.5-4) en unstable,
tout est rentré dans l'ordre !

Peut-être que ton problème est également lié...

Dans tous les cas, il n'y a pas de disparition du package fuse-utils mais de loop-aes-utils !

Pour moi "fusermount -u" fonctionne nickel maintenant...

mes versions de package

sshfs 2.2-1
fuse 2.8.5-4
fuse-utils 2.8.5-4
ifuse not installed (je n'ai pas de ibouse d'apple)
libfuse2 2.8.5-4

++

Mourad

Le 12/07/2011 12:10, Francois Mescam a écrit :
J'ai aussi un pb un peu moins grave. Depuis que fuse-utils est remplacé
par fuse je ne peux plus démonter mes montages sshfs que je faisais
avant sans pb même sans être root

$ fusermount -u<point de montage>
/bin/umount : option non reconnue « --fake »
Usage: umount -h | -V
umount -a [-d] [-f] [-r] [-n] [-v] [-t vfstypes] [-O opts]
umount [-d] [-f] [-r] [-n] [-v] special | node...
$ sudo fusermount -u<point de montage>
[sudo] password for<user>:
fusermount: failed to unmount<point de montage>: Invalid argument

Je suis en testing mise à jour régulièrement.

Les versions des paquets sont :

sshfs 2.2-1
fuse 2.8.5-3
fuse-utils 2.8.5-3
ifuse 1.0.0-1
libfuse2 2.8.5-3

Remarque je ne peux enlever fuse-utils car sshfs en dépend, peu-être
est-ce la le noeud du pb.


On 12/07/2011 11:33, Mourad Jaber wrote:
Bonjour,

J'ai un souci nouveau (mais il ne me semble pas y avoir eu de mise à
jour !) avec sshfs...

C'est un plugin fuse que j'utilise depuis de nombreuse année et je
n'avais pas eu ce problème jusqu'à présent !

Quand j'essai de monter un "partage" ssh j'obtiens le message suivant :
$ sshfs 192.168.33.15: ./tiny-blob
's password:
fusermount: failed to access mountpoint /home/mourad/tiny-blob:
Permission denied

Pourtant quand je me connecte à la machine en ssh avec le même compte et
mot de passe, tout se passe bien !

Cela met le mount de montage en vrac (permissions ??????????? ? ?
? ? ? tiny-blob), je ne peux pas le démonter
sauf à coup de "umount -l" en tand que root !

Est-ce que quelqu'un aurait une idée sur ce point très gênant ?

++

Mourad







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #23555581
On Tue, 12 Jul 2011 12:26:24 +0200, Mourad Jaber


Autant pour moi, en faisant une mise à jour des packages (version 2. 8.5-4)
en unstable, tout est rentré dans l'ordre !



Oui, et ça règle également le PB de montage non-opérati onnel et démontage
user impossible avec encfs.

--
Why use Windows, since there is a door?
(By , Andre Fachat)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Francois Mescam
Le #23557931
On 12/07/2011 13:41, Jean-Yves F. Barbier wrote:
On Tue, 12 Jul 2011 12:26:24 +0200, Mourad Jaber


Autant pour moi, en faisant une mise à jour des packages (version 2.8.5-4)
en unstable, tout est rentré dans l'ordre !



Oui, et ça règle également le PB de montage non-opérationnel et démontage
user impossible avec encfs.



Cela a exactement le même effet pour moi.

Merci pour votre aide.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/ividkc$fa2$
Nicolas Bercher
Le #23562491
On 12/07/2011 11:33, Mourad Jaber wrote:
Cela met le mount de montage en vrac (permissions ??????????? ? ?
? ? ? tiny-blob), je ne peux pas le démonter
sauf à coup de "umount -l" en tand que root !


Ceci est lié à un problème de droits, peut être sur le point de montage ou si le user qui
a monté est différent du user qui accède et que les droits ne sont pas appropriés
(constaté avec des montages archfs).

Nicolas

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #23562551
On Thu, 14 Jul 2011 09:21:21 +0200, Nicolas Bercher

On 12/07/2011 11:33, Mourad Jaber wrote:
> Cela met le mount de montage en vrac (permissions ??????????? ? ?
> ? ? ? tiny-blob), je ne peux pas le démont er
> sauf à coup de "umount -l" en tand que root !
Ceci est lié à un problème de droits, peut être sur l e point de montage ou
si le user qui a monté est différent du user qui accède et que les droits ne
sont pas appropriés (constaté avec des montages archfs).



Non, apparemment c'est le même PB que je rencontrais avec encfs (qui d onnait
le même "résultat" sur le dir monté); la mise à jour d' il y a 48H (fuse) a
réglé le PB:)

--
"Besides, I think [Slackware] sounds better than 'Microsoft,' don't you?"
(By Patrick Volkerding)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Sébastien Kroll-Rabotin
Le #23563621
--Sig_/OuwxMvITo=/elCGAC9fSA1t
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Non, apparemment c'est le même PB que je rencontrais avec encfs (qui
donnait le même "résultat" sur le dir monté); la mise à   jour d'il y a
48H (fuse) a réglé le PB:)



Oui, c’était un problème du paquetage « mount  » qui est entré dans
testing avec une erreur de dépendance, il a donc migré alors qu ’il
exigeait une version de « fuse » plus récente que celle de testing.

Tous les montages via Fuse étaient potentiellement touchés.

--
(o< -!
// Happy debian user !
V_/_ http://www.debian.org/

--Sig_/OuwxMvITo=/elCGAC9fSA1t
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk4e+KEACgkQ3qwCc2aFrOZiSACgqFzmgo+iriK3289g2M91Rte2
2+MAn31l7KkAuX3rpvRAB3HUZ2zImHVe
=dTeI
-----END PGP SIGNATURE-----

--Sig_/OuwxMvITo=/elCGAC9fSA1t--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Sébastien Kroll-Rabotin
Le #23563651
--Sig_/X=t3sGnJLru=Iaa5Vchv5H Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Oups, c’est l’inverse, Fuse contenanit l’erreur et a migré
alors qu’il nécessitait une version de mount plus récente.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bugb8735

--Sig_/X=t3sGnJLru=Iaa5Vchv5H Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk4e+cQACgkQ3qwCc2aFrOacnwCgxGE5jvKw6fCey8URFsEQIp58
YpoAn2VAJmOHI/rWTxgMHkc8WTMvPEDh
=XASy
-----END PGP SIGNATURE-----

--Sig_/X=t3sGnJLru=Iaa5Vchv5H=--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme