Problème Executer en tant que

Le
Eric Giffard
Bonjour à tous
Je reposte car sans réponse. Si quelqu'un peut essayer avec son Vista,
ça serai sympa !
J'ai testé sur 5 installations différentes (3 en machines réelles, 2 en
virtuelles (Virtual PC)).

Je constate que sur les Vista Ultimate que j'ai installé, l'"éxecuter
en tant que" ne fonctionne pas correctement:
Si j'ouvre une session administrative, un clic droit,"Executer en tant
que Administrateur" sur un raccourci ou une console, ne me demande rien
(pas de nom ou de mot de passe comme sous XP) et j'ai bien les
privilèges Administratifs (normal je dirais).

Si j'ouvre une session NON administrative, un clic droit,"Executer en
tant que Administrateur" sur un raccourci ou une console, ne me demande
rien non plus et je n'ai pas les privilèges (normal aussi)
Mais comment je peu faire pour avoir cette boîte et choisir
l'utilisateur (qu'il soit admin ou non) ?

J'ai essayé avec l'UAC et sans c'est pareil.
Les comptes utilisateurs testés sont de domaine ou locaux aux stations.

Est ce que quelqu'un a eu ce soucis ou peut tester ?

Merci pour vos lumières

--


A bientôt
Eric Giffard

PS: Pour répondre sur mon adresse, enlevez le mot de trop !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Samir Rennou
Le #119226
Bonjour,

"Eric Giffard" news:
Bonjour à tous
Je reposte car sans réponse. Si quelqu'un peut essayer avec son Vista, ça
serai sympa !
J'ai testé sur 5 installations différentes (3 en machines réelles, 2 en
virtuelles (Virtual PC)).

Je constate que sur les Vista Ultimate que j'ai installé, l'"éxecuter en
tant que" ne fonctionne pas correctement:
Si j'ouvre une session administrative, un clic droit,"Executer en tant que
Administrateur" sur un raccourci ou une console, ne me demande rien (pas
de nom ou de mot de passe comme sous XP) et j'ai bien les privilèges
Administratifs (normal je dirais).

Si j'ouvre une session NON administrative, un clic droit,"Executer en tant
que Administrateur" sur un raccourci ou une console, ne me demande rien
non plus et je n'ai pas les privilèges (normal aussi)
Mais comment je peu faire pour avoir cette boîte et choisir l'utilisateur
(qu'il soit admin ou non) ?

J'ai essayé avec l'UAC et sans c'est pareil.
Les comptes utilisateurs testés sont de domaine ou locaux aux stations.


UAC actuvé, la fonction "Exécuter en tant que Administrateur" fonctionne
très bien que se soit avec un compte Admin ou Utilisateur

Par défaut (= c'est à dire sans avoir bidouillé !) les paramétres de compte
associé à UAC sont les suivant:
- Les comptes administrateurs, il demande le consentement sur chaque action
administrative.
- Pour les comptes utilisateurs, il demande les informations
d'identification.

Regarde dans le registre, verifies que tu possèdes bien ces valeurs:

[HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionPoliciesSystem]
"EnableLUA"=dword:00000001
"ConsentPromptBehaviorAdmin"=dword:00000001 (Il te demandera les
informations d'identification)
"ConsentPromptBehaviorUser"=dword:00000001 " " " "
" " " "

** Tu peux faire la même chose avec SECPOL.MSC.

Si par contre tu désactives volontairement UAC, j'ai remarqué aussi que la
fonction du menu contextuel "Exécuter en tant que Administrateur" devient
totalement inoperante, et y a plus de fenêtre d'identification comme c'était
le cas sous Windows 2000 /XP.
En même temps je trouve pas vraiment ça surprenant, puisque elle a été
remodelé spécialement pour fonctionner avec UAC.

--
@+Sam

Eric Giffard
Le #119224
"Samir Rennou" news:
Bonjour,

"Eric Giffard" news:
Bonjour à tous
Je reposte car sans réponse. Si quelqu'un peut essayer avec son Vista, ça
serai sympa !
J'ai testé sur 5 installations différentes (3 en machines réelles, 2 en
virtuelles (Virtual PC)).

Je constate que sur les Vista Ultimate que j'ai installé, l'"éxecuter en
tant que" ne fonctionne pas correctement:
Si j'ouvre une session administrative, un clic droit,"Executer en tant
que Administrateur" sur un raccourci ou une console, ne me demande rien
(pas de nom ou de mot de passe comme sous XP) et j'ai bien les privilèges
Administratifs (normal je dirais).

Si j'ouvre une session NON administrative, un clic droit,"Executer en
tant que Administrateur" sur un raccourci ou une console, ne me demande
rien non plus et je n'ai pas les privilèges (normal aussi)
Mais comment je peu faire pour avoir cette boîte et choisir l'utilisateur
(qu'il soit admin ou non) ?

J'ai essayé avec l'UAC et sans c'est pareil.
Les comptes utilisateurs testés sont de domaine ou locaux aux stations.


UAC actuvé, la fonction "Exécuter en tant que Administrateur" fonctionne
très bien que se soit avec un compte Admin ou Utilisateur

Par défaut (= c'est à dire sans avoir bidouillé !) les paramétres de
compte associé à UAC sont les suivant:
- Les comptes administrateurs, il demande le consentement sur chaque
action administrative.
- Pour les comptes utilisateurs, il demande les informations
d'identification.

Regarde dans le registre, verifies que tu possèdes bien ces valeurs:

[HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionPoliciesSystem]
"EnableLUA"=dword:00000001
"ConsentPromptBehaviorAdmin"=dword:00000001 (Il te demandera les
informations d'identification)
"ConsentPromptBehaviorUser"=dword:00000001 " " "
" " " " "

** Tu peux faire la même chose avec SECPOL.MSC.

Si par contre tu désactives volontairement UAC, j'ai remarqué aussi que la
fonction du menu contextuel "Exécuter en tant que Administrateur" devient
totalement inoperante, et y a plus de fenêtre d'identification comme
c'était le cas sous Windows 2000 /XP.
En même temps je trouve pas vraiment ça surprenant, puisque elle a été
remodelé spécialement pour fonctionner avec UAC.

--
@+Sam


Merci, je vais regarder tout ça !
je vous tiens au courant...

A bientôt

Eric Giffard
MCSE Windows 2003
MCT Windows 2000/2003/XP

Enlever les ~ pour une réponse
eric.giffard@~laposte.net (perso)
eric.g@~nextmedia.fr (boulot)


Eric Giffard
Le #119086
"Eric Giffard" a écrit dans le message de news:
Bonjour à tous
Je reposte car sans réponse. Si quelqu'un peut essayer avec son Vista, ça
serai sympa !
J'ai testé sur 5 installations différentes (3 en machines réelles, 2 en
virtuelles (Virtual PC)).
Je constate que sur les Vista Ultimate que j'ai installé, l'"éxecuter en
tant que" ne fonctionne pas correctement:
Si j'ouvre une session administrative, un clic droit,"Executer en tant que
Administrateur" sur un raccourci ou une console, ne me demande rien (pas
de nom ou de mot de passe comme sous XP) et j'ai bien les privilèges
Administratifs (normal je dirais).
Si j'ouvre une session NON administrative, un clic droit,"Executer en tant
que Administrateur" sur un raccourci ou une console, ne me demande rien
non plus et je n'ai pas les privilèges (normal aussi)
Mais comment je peu faire pour avoir cette boîte et choisir l'utilisateur
(qu'il soit admin ou non) ?
J'ai essayé avec l'UAC et sans c'est pareil.
Les comptes utilisateurs testés sont de domaine ou locaux aux stations.
Est ce que quelqu'un a eu ce soucis ou peut tester ?
Merci pour vos lumières...
A bientôt
Eric Giffard

PS: Pour répondre sur mon adresse, enlevez le mot de trop !



Pour informations, ce que j'ai testé ce matin :

j'ai réussi a faire certaines choses, mais pas tout :
- UAC Activée
Dans la clé
HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionPoliciesSystem
- Valeur ConsentPromptBehaviorAdmin était à 2, je l'ai mis à 1
- Valeur ConsentPromptBehaviorUser était à 1, pas de changement
Avec tout cela aucun changement de comportement (après multiples reboots).

- Passage Valeur ConsentPromptBehaviorAdmin à 2
Dans ce cas il me demande un "consentement", mais ne demande aucun compte
spécifique.

- Puis j'ai changé la valeur FilterAdministratorToken (mis à 1)
Donc, même les admin sont sujet aux approbations:
Là j'ai bien la boîte de dialogue avec un executer en tant que, mais ....
Il ne veut qu'un administrateur !

Moi je veux pouvoir saisir ce que je veux, y compris dans le sens
Administrateur vers non-administrateur (test d'une installation par
exemple).

J'ai avancé un peu ... mais reculé pas mal !!!

A bientôt

Eric Giffard
MCSE Windows 2003
MCT Windows 2000/2003/XP

Enlever les ~ pour une réponse
eric.giffard@~laposte.net (perso)
eric.g@~nextmedia.fr (boulot)

Publicité
Poster une réponse
Anonyme