probleme de formule

Le
bastientot
Bonjour all,

voila je n'arrive pas a faire ma formule

=NB.SI(INDIRECTE("'[" & B1 & "]" & B2 & "!"&$B$5:$AC$21);"*ERR*")

donc en B1 j'ai le nom d'un classeur "toto.xls"
en B2 j'ai le nom de la feuille "fevrier"

dans la plage b5 ==> ac21 j'ai des "ERR" et je cherche a avoir le
nombre de ces ERR mais je ne vois pas mon erreur.

merci de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #18861061
Un petit exemple :

Exemple :

En A1 : le nom du Classeur : Denis2003
En A2 : le nom de l'onglet : Denis
Pour avoir en B1 la liaison "=[Denis2003.xls]Denis!RefCase"...
=INDIRECT("["&A1&".xls]"&A2&"!RefCase")
le classeur doit être ouvert.





Bonjour all,

voila je n'arrive pas a faire ma formule

=NB.SI(INDIRECTE("'[" & B1 & "]" & B2 & "!"&$B$5:$AC$21);"*ERR*")

donc en B1 j'ai le nom d'un classeur "toto.xls"
en B2 j'ai le nom de la feuille "fevrier"

dans la plage b5 ==> ac21 j'ai des "ERR" et je cherche a avoir le
nombre de ces ERR mais je ne vois pas mon erreur.

merci de votre aide.
Jacky
Le #18861641
Bonsoir,
Ceci peut-être:

=NB.SI(INDIRECT("'[" & B1 & "]" & B2 & "'!$B$5:$AC$21");"*ERR*")

--
Salutations
JJ



Bonjour all,

voila je n'arrive pas a faire ma formule

=NB.SI(INDIRECTE("'[" & B1 & "]" & B2 & "!"&$B$5:$AC$21);"*ERR*")

donc en B1 j'ai le nom d'un classeur "toto.xls"
en B2 j'ai le nom de la feuille "fevrier"

dans la plage b5 ==> ac21 j'ai des "ERR" et je cherche a avoir le
nombre de ces ERR mais je ne vois pas mon erreur.

merci de votre aide.


MichDenis
Le #18861901
Est-ce possible que j'aie omis les guillemets simple ? ;-))
=INDIRECT("'["&A1&".xls]"&A2&"'!RefCase")



"MichDenis"
Un petit exemple :

Exemple :

En A1 : le nom du Classeur : Denis2003
En A2 : le nom de l'onglet : Denis
Pour avoir en B1 la liaison "=[Denis2003.xls]Denis!RefCase"...
=INDIRECT("["&A1&".xls]"&A2&"!RefCase")
le classeur doit être ouvert.





Bonjour all,

voila je n'arrive pas a faire ma formule

=NB.SI(INDIRECTE("'[" & B1 & "]" & B2 & "!"&$B$5:$AC$21);"*ERR*")

donc en B1 j'ai le nom d'un classeur "toto.xls"
en B2 j'ai le nom de la feuille "fevrier"

dans la plage b5 ==> ac21 j'ai des "ERR" et je cherche a avoir le
nombre de ces ERR mais je ne vois pas mon erreur.

merci de votre aide.
bastientot
Le #18865571
BOnjour,

merci tous ça fonctionne impec

bonne journée.


On 9 mar, 17:50, "MichDenis"
Est-ce possible que j'aie omis les guillemets simple ? ;-))
=INDIRECT("'["&A1&".xls]"&A2&"'!RefCase")

"MichDenis"
Un petit exemple :

Exemple :

En A1 : le nom du Classeur : Denis2003
En A2 : le nom de l'onglet : Denis
Pour avoir en B1 la liaison "=[Denis2003.xls]Denis!RefCase"...
=INDIRECT("["&A1&".xls]"&A2&"!RefCase")
le classeur doit être ouvert.


Bonjour all,

voila je n'arrive pas a faire ma formule

=NB.SI(INDIRECTE("'[" & B1 & "]" & B2 & "!"&$B$5:$AC$21);"*ERR*")

donc en B1 j'ai le nom d'un classeur "toto.xls"
        en B2 j'ai le nom de la feuille "fevrier"

dans la plage b5 ==> ac21 j'ai des "ERR" et je cherche a avoir le
nombre de ces ERR mais je ne vois pas mon erreur.

merci de votre aide.


Publicité
Poster une réponse
Anonyme