problème fsck après clonage

Le
Raphaël RIGNIER
Bonjour, la liste!

J'ai utilisé un ghost 8 pour cloner un disque dual boot Windows
XP/Debian etch.
/dev/hda1 = XP
/dev/hda2 = swap
/dev/hda3 = Debian

Les machines sont identiques et les disques aussi.

Pour Windows ça s'est bien passé mais pour Linux, Debian m'indique des
erreurs disque au boot et m'oblige à fair un fsck manuel en single mode.
Si j'ai le malheur de faire un fsck.ext3 -y /dev/hda3, la partition
entière semble corrompue et les données disparaissent derrière!

Sur une autre machine clonée, j'a booté via RIP Linux et j'arrive a
monter /dev/hda3 avec toutes les données correctes dessus.
Par contre si je fait fsck /dev/hda3, il me trouve les même erreurs et
si je valide les changements je me retrouve avec le même problème.

Y'a t-il un moyen de dire a Debian que le disque est clean et que fsck
retrouve ses bille sans tout corrompre?

D'avance, Merci!

Raphaël


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy Roussin
Le #9758581
Bonjour,

Verifie avec un fdisk que les partitions ne se chevauchent pas :
genre le swap qui deborde sur ta debian ...

Si tu utilise grub ou autre, essayes de le reinstaller avec
un cd de boot et les commandes setup et root de grub ...

Guy


Raphaël RIGNIER a écrit :
Bonjour, la liste!

J'ai utilisé un ghost 8 pour cloner un disque dual boot Windows
XP/Debian etch.
/dev/hda1 = XP
/dev/hda2 = swap
/dev/hda3 = Debian

Les machines sont identiques et les disques aussi.

Pour Windows ça s'est bien passé mais pour Linux, Debian m'indique des
erreurs disque au boot et m'oblige à fair un fsck manuel en single mo de.
Si j'ai le malheur de faire un fsck.ext3 -y /dev/hda3, la partition
entière semble corrompue et les données disparaissent derrière!

Sur une autre machine clonée, j'a booté via RIP Linux et j'arrive a
monter /dev/hda3 avec toutes les données correctes dessus.
Par contre si je fait fsck /dev/hda3, il me trouve les même erreurs e t
si je valide les changements je me retrouve avec le même problème.

Y'a t-il un moyen de dire a Debian que le disque est clean et que fsck
retrouve ses bille sans tout corrompre?

D'avance, Merci!

Raphaël



Raphaël RIGNIER
Le #9758251
Guy Roussin a écrit :
Bonjour,

Verifie avec un fdisk que les partitions ne se chevauchent pas :
genre le swap qui deborde sur ta debian ...


Vérifié, la table est cohérente


Si tu utilise grub ou autre, essayes de le reinstaller avec
un cd de boot et les commandes setup et root de grub ...


Via un CD de boot, c'est pareil. Je fais ce que je veux sauf un fsck qui
me casse tout.
Je soupçonne une mauvaise image de la part de ghost car avec partimage,
ça a fonctionné.

Quelqu'un connais une image PXE compatible avec le server partimage de etch?
merci!

Raphaël


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme