problème important avec X

Le
maderios
Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai en
réserve sur une autre partition, tout est normal, ce qui élimine la
possibilité d'un problème de carte graphique. Accrochez vous, ceci n'est
pas une mauvaise plaisanterie.
Le problème est le même en utilisant E17,fluxbox ou KDE.
Dès que le curseur de souris passe au dessus d'un lien, de la barre de
titre d'une fenêtre, il semble les accrocher et il les déplace. Le
copier-coller est impossible.
Les menus s'ouvrent tout seul à proximité du curseur X. Ce même curseur
"emporte" avec lui des morceaux de menu. Bref, la folie totale, du
jamais vu en 10 années d'utilisation de Linux. Je ne vois vraiment pas
comment trouver l'origine de ce comportement de X. Les logs de X sont
normaux.
Merci pour toute aide, retour d'expérience
M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #17882821
’jour,

maderios, mardi 18 novembre 2008, 15:07:26 CET

Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai
en réserve sur une autre partition, tout est normal, ce qui
élimine la possibilité d'un problème de carte graphique.
Accrochez vous, ceci n'est pas une mauvaise plaisanterie.
Le problème est le même en utilisant E17,fluxbox ou KDE.
Dès que le curseur de souris passe au dessus d'un lien, de la
barre de titre d'une fenêtre, il semble les accrocher et il
les déplace. Le copier-coller est impossible.
Les menus s'ouvrent tout seul à proximité du curseur X. Ce
même curseur "emporte" avec lui des morceaux de menu. Bref, la
folie totale, du jamais vu en 10 années d'utilisation de
Linux. Je ne vois vraiment pas comment trouver l'origine de ce
comportement de X. Les logs de X sont normaux.



Ben ça ressemble plus à un problème de souris : le bo uton est
considéré comme enfoncé inopportunément.
Voir donc du côté de tes périphériques (udev, pé riphériques
définis dans xorg.conf, gpm…).
Par défaut, X doit utiliser /dev/mice, qui correspond à
l’ensemble des souris. Tu as peut-être un périphériq ue qui
s’enregistre comme une souris et qui envoie n’importe quoi …

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
maderios
Le #17883191
Sylvain Sauvage a écrit :
’jour,

maderios, mardi 18 novembre 2008, 15:07:26 CET
Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai
en réserve sur une autre partition, tout est normal, ce qui
élimine la possibilité d'un problème de carte graphique.
Accrochez vous, ceci n'est pas une mauvaise plaisanterie.
Le problème est le même en utilisant E17,fluxbox ou KDE.
Dès que le curseur de souris passe au dessus d'un lien, de la
barre de titre d'une fenêtre, il semble les accrocher et il
les déplace. Le copier-coller est impossible.
Les menus s'ouvrent tout seul à proximité du curseur X. Ce
même curseur "emporte" avec lui des morceaux de menu. Bref, la
folie totale, du jamais vu en 10 années d'utilisation de
Linux. Je ne vois vraiment pas comment trouver l'origine de ce
comportement de X. Les logs de X sont normaux.



Ben ça ressemble plus à un problème de souris : le bouton est
considéré comme enfoncé inopportunément.
Voir donc du côté de tes périphériques (udev, périphériques
définis dans xorg.conf, gpm…).
Par défaut, X doit utiliser /dev/mice, qui correspond à
l’ensemble des souris. Tu as peut-être un périphérique qui
s’enregistre comme une souris et qui envoie n’importe quoi…



OK, merci pour la réponse
Je viens de retester avec Etch et c'est exactement la même cata.
C'est effectivement un problème de périphérique.
Je vais tout vérifier
M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Yves Rutschle
Le #17883961
On Tue, Nov 18, 2008 at 04:08:04PM +0100, maderios wrote:
> Ben ça ressemble plus à un problème de souris : le bouton est
>considéré comme enfoncé inopportunément.
OK, merci pour la réponse
Je viens de retester avec Etch et c'est exactement la même cata.
C'est effectivement un problème de périphérique.
Je vais tout vérifier



Tu as essayé une autre souris? Peut-être que ta souris a son
bouton collé et clique tout le temps.

Y.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Frédéric Massot
Le #17884411
> maderios, mardi 18 novembre 2008, 15:07:26 CET
Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai
en réserve sur une autre partition, tout est normal, ce qui
élimine la possibilité d'un problème de carte graphique.
Accrochez vous, ceci n'est pas une mauvaise plaisanterie.
Le problème est le même en utilisant E17,fluxbox ou KDE.
Dès que le curseur de souris passe au dessus d'un lien, de la
barre de titre d'une fenêtre, il semble les accrocher et il
les déplace. Le copier-coller est impossible.
Les menus s'ouvrent tout seul à proximité du curseur X. Ce
même curseur "emporte" avec lui des morceaux de menu. Bref, la
folie totale, du jamais vu en 10 années d'utilisation de
Linux. Je ne vois vraiment pas comment trouver l'origine de ce
comportement de X. Les logs de X sont normaux.





Tu peux nous fournir ton xorg.conf ?

J'ai eu un problème de souris en voulant ajouter une section pour la
souris dans le fichier xorg.conf. Il vaut mieux laisser
l'auto-découverte des périphériques d'entrée, nouveauté de Xorg 7.3 je
crois.

--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
maderios
Le #17884591
Frédéric Massot a écrit :
maderios, mardi 18 novembre 2008, 15:07:26 CET
Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai
en réserve sur une autre partition, tout est normal, ce qui
élimine la possibilité d'un problème de carte graphique.
Accrochez vous, ceci n'est pas une mauvaise plaisanterie.
Le problème est le même en utilisant E17,fluxbox ou KDE.
Dès que le curseur de souris passe au dessus d'un lien, de la
barre de titre d'une fenêtre, il semble les accrocher et il
les déplace. Le copier-coller est impossible.
Les menus s'ouvrent tout seul à proximité du curseur X. Ce
même curseur "emporte" avec lui des morceaux de menu. Bref, la
folie totale, du jamais vu en 10 années d'utilisation de
Linux. Je ne vois vraiment pas comment trouver l'origine de ce
comportement de X. Les logs de X sont normaux.





Tu peux nous fournir ton xorg.conf ?

J'ai eu un problème de souris en voulant ajouter une section pour la
souris dans le fichier xorg.conf. Il vaut mieux laisser
l'auto-découverte des périphériques d'entrée,


auto-découverte, quelle est l'option ?

nouveauté de Xorg 7.3 je
crois.



Sur Lenny, je n'ai pas modifié xorg.conf depuis au moins 4 mois et tout
marchait bien jusqu'à présent. Le dysfonctionnement apparait de façon
aléatoire.
De plus, sur Etch, c'est exactement le même problème (dernière modif du
xorg.conf il y a 10 mois).
Je pense plutôt à une souris défectueuse.


Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "v4l" #test marco
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
# Option "Device" "/dev/input/mouse1"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

#marco wacom
Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Mode" "Absolute"
Option "Device" "/dev/input/wacom" # USB ONLY
# Option "KeepShape" "on"
Option "Type" "stylus"
Option "USB" "on" # USB ONLY
Option "Tilt" "on"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom" # USB ONLY
# Option "KeepShape" "on" # probleme zone travail
décentrée vers la gauche
Option "Type" "eraser"
Option "USB" "on" # USB ONLY
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection


# This section is for Intuos3, Cintiq 21UX, or Graphire4 only
Section "InputDevice"
Driver "wacom"
Identifier "pad"
Option "Device" "/dev/input/wacom" # USB ONLY
Option "Type" "pad"
Option "USB" "on" # USB ONLY
EndSection

Section "Device"
Identifier "Matrox Graphics, Inc. MGA G550 AGP"
Driver "mga"
BusID "PCI:3:0:0"
Option "hwcursor" "off"
#Option "AGPMode" "4" #marco test
#ralentit taskbar Option "AccelMethod" "EXA"
EndSection

Section "Monitor"
Identifier "Mitsubishi 930SB"
Option "DPMS"
HorizSync 30-110
VertRefresh 50-160

#avec videogen
Modeline "1920x1440" 316.48 1920 1984 2152 2456 1440 1442 1448 1516 #
316 MHz, 128.9 kHz, 85.0 Hz
Modeline "1280x1024" 150.27 1280 1320 1488 1640 1024 1026 1030 1078 #
150 MHz, 91.6 kHz, 85.0 Hz
#old#Modeline "1920x1440" 223.40 1920 1984 2152 2456 1440 1442 1446 1516
# 223 MHz, 91.0 kHz, 60.0 Hz

EndSection

Section "Screen"
Identifier "Default Screen"
Device "Matrox Graphics, Inc. MGA G550 AGP"
Monitor "Mitsubishi 930SB"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device "Matrox Graphics, Inc. MGA G550 AGP"
Monitor "Mitsubishi 930SB"
SubSection "Display"
Depth 24
Modes "1920x1440" "1280x1024" "1024x768"
"800x600" "640x480
EndSubSection
EndSection
#
Section "Screen"
Identifier "Screen3"
Device "Matrox Graphics, Inc. MGA G550 AGP"
Monitor "Mitsubishi 930SB"
SubSection "Display"
Depth 24
Modes "1920x1200" "1280x1024" "1024x768"
"800x600" "640x480
EndSubSection
EndSection
#marco wacom
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# Screen 0 "Screen0" 0 0
# InputDevice "Mouse0" "CorePointer"
# InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Keyboard"
InputDevice "stylus" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents" # For non-LCD
tablets only
InputDevice "pad"
EndSection

#Section "Extensions" #test marco
#Option "Composite" "Enable"
#Option "XFree86-DRI" "Enable"
#EndSection

#Section "ServerFlags" #test marco
#Option "IgnoreABI" "True"
#Option "AIGLX" "True" #FALSE - DISABLES THE ABILITY TO HAVE DESKTOP EFFECTS
#EndSection

#marco_origin
#Section "ServerLayout"
# Identifier "Default Layout"
# Screen "Default Screen"
# InputDevice "Generic Keyboard"
# InputDevice "Configured Mouse"
#EndSection

Section "DRI"
#Group 0 #test marco
Mode 0666
EndSection

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
maderios
Le #17884581
Frédéric Massot a écrit :
maderios, mardi 18 novembre 2008, 15:07:26 CET
Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai
en réserve sur une autre partition, tout est normal, ce qui
élimine la possibilité d'un problème de carte graphique.
Accrochez vous, ceci n'est pas une mauvaise plaisanterie.
Le problème est le même en utilisant E17,fluxbox ou KDE.
Dès que le curseur de souris passe au dessus d'un lien, de la
barre de titre d'une fenêtre, il semble les accrocher et il
les déplace. Le copier-coller est impossible.
Les menus s'ouvrent tout seul à proximité du curseur X. Ce
même curseur "emporte" avec lui des morceaux de menu. Bref, la
folie totale, du jamais vu en 10 années d'utilisation de
Linux. Je ne vois vraiment pas comment trouver l'origine de ce
comportement de X. Les logs de X sont normaux.





Tu peux nous fournir ton xorg.conf ?

J'ai eu un problème de souris en voulant ajouter une section pour la
souris dans le fichier xorg.conf. Il vaut mieux laisser
l'auto-découverte des périphériques d'entrée, nouveauté de Xorg 7.3 je
crois.




Le problème vient de se reproduire.
J'ai débranché puis rebranché la souris de la prise USB, ce qui a pour
effet de supprimer le problème.
M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Alain Vaugham
Le #17884571
--nextPart2367839.EqpPnFXXNm
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le mardi 18 novembre 2008 15:07, maderios a écrit :
| Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai en
| réserve sur une autre partition, tout est normal, ce qui élimin e la
| possibilité d'un problème de carte graphique. Accrochez vous, c eci n'est
| pas une mauvaise plaisanterie.
| Le problème est le même en utilisant E17,fluxbox ou KDE.
| Dès que le curseur de souris passe au dessus d'un lien, de la barre de
| titre d'une fenêtre, il semble les accrocher et il les déplace. Le
| copier-coller est impossible.
| Les menus s'ouvrent tout seul à proximité du curseur X. Ce mà ªme curseur
| "emporte" avec lui des morceaux de menu. Bref, la folie totale, du
| jamais vu en 10 années d'utilisation de Linux. Je ne vois vraiment p as
| comment trouver l'origine de ce comportement de X. Les logs de X sont
| normaux.
| Merci pour toute aide, retour d'expérience
| M
|

J'ai souvent rencontré ce phénomène, quelque soit l'OS : Sar ge, Mandriva,
*buntu et même NT4.

C'était lié à l'installation fraîche d'un KVM 4 voies e t d'une souris à
transmission radio alors que le clavier et la souris utilisés n'avaien t
jamais posé problème avant d'être mis sur le KVM.

J'ai déplacé le câble du KVM qui passait à proximità © d'un néon en sous-sol,
j'ai permuté des souris filaires et des souris radio _de la même
référence_, j'ai changé de marque de KVM. Pareil pour le cla vier,
permutation et échange dans la même référence. Les sort ies claviers et
souris des machines sont des sorties TTL traditionelles, pas d'usb.

Au final, je ne sais pas ce qui a résolu ce problème mais cela à
complètement disparu.

Maintenant, très rarement, j'ai un clavier-souris qui plante sur une s eule
voie du KVM mais plus le curseur fou qui s'accroche à n'importe quoi.
Je ne peux le résoudre qu'en mettant hors tension le boîtier KVM et la
machine plantée.


--
Cordialement,

Alain Vaugham
--------------------------------------------------------
[PUB] Signature numérique GPG de ce courrier: 0xD26D18BC

--nextPart2367839.EqpPnFXXNm
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBJIv+ZlMPLZNJtGLwRArXAAJ40+0NEzjx/lBXg0PRc66PwolZgCACeNf3+
zLz8waHAkia9IqjhdRYb5Hg =Vrzp
-----END PGP SIGNATURE-----

--nextPart2367839.EqpPnFXXNm--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
maderios
Le #17884971
Alain Vaugham a écrit :
Le mardi 18 novembre 2008 15:07, maderios a écrit :
| Ceci se passe uniquement avec Lenny. Concernant Etch, que j'ai en
| réserve sur une autre partition, tout est normal, ce qui élimine la
| possibilité d'un problème de carte graphique. Accrochez vous, ceci n'est
| pas une mauvaise plaisanterie.
| Le problème est le même en utilisant E17,fluxbox ou KDE.
| Dès que le curseur de souris passe au dessus d'un lien, de la barre de
| titre d'une fenêtre, il semble les accrocher et il les déplace. Le
| copier-coller est impossible.
| Les menus s'ouvrent tout seul à proximité du curseur X. Ce même curseur
| "emporte" avec lui des morceaux de menu. Bref, la folie totale, du
| jamais vu en 10 années d'utilisation de Linux. Je ne vois vraiment pas
| comment trouver l'origine de ce comportement de X. Les logs de X sont
| normaux.
| Merci pour toute aide, retour d'expérience
| M
|

J'ai souvent rencontré ce phénomène, quelque soit l'OS : Sarge, Mandriva,
*buntu et même NT4.

C'était lié à l'installation fraîche d'un KVM 4 voies et d'une souris à
transmission radio alors que le clavier et la souris utilisés n'avaient
jamais posé problème avant d'être mis sur le KVM.

J'ai déplacé le câble du KVM qui passait à proximité d'un néon en sous-sol,
j'ai permuté des souris filaires et des souris radio _de la même
référence_, j'ai changé de marque de KVM. Pareil pour le clavier,
permutation et échange dans la même référence. Les sorties claviers et
souris des machines sont des sorties TTL traditionelles, pas d'usb.

Au final, je ne sais pas ce qui a résolu ce problème mais cela à
complètement disparu.

Maintenant, très rarement, j'ai un clavier-souris qui plante sur une seule
voie du KVM mais plus le curseur fou qui s'accroche à n'importe quoi.
Je ne peux le résoudre qu'en mettant hors tension le boîtier KVM et la
machine plantée.





Je viens de brancher ma souris sur le portable de ma femme.
Résultat : les fenêtres deviennent folles, sélections intempestives, etc...
Ce qui est étonnant, c'est que le curseur de la souris arrive à
surligner ou à cliquer tout seul en passant à 10 ou 15 cm des textes ou
des liens

Branchement de la souris du portable sur ma machine : ça marche nickel....
Donc c'est bien la souris qui est en cause.
Et ouf
Merci à tous pour vos réponses
M

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme