problème d'impression avec CUPS

Le
Jerome Blondel
Bonjour

J'ai un problème d'impression avec CUPS depuis un upgrade récent (cup=
sys
1.2.7-4,
j'utilise XFCE4). Seul root peut encore imprimer. Il semble qu'il y ait u=
n
problème d'authentification avec les users non-privilégiés. Le mess=
age
de debug
dans /var/log/cups/error_log est :

cupsdAuthorize: No authentication data provided.

Mais j'ignore s'il est normal car je n'étais pas en mode débug avant.=
Quand
c'est root qui imprime, il met

cupsdAuthorize: username="root"

Ce qui paraît être le cas normal. J'ai essayé de me mettre dans les=
Allowed
Users de l'interface d'admin, ça ne change rien.

Je ne sais pas par où commencer. De plus, j'ai un nouveau problème,
c'est que
quand j'imprime dans une console avec lp en root; il me dit

lp: Quota limit reached.

J'aurais besoin d'un peu d'aide.

Jérôme Blondel







___________________________________________________________________________
Yahoo! Mail réinvente le mail ! Découvrez le nouveau Yahoo! Mail et son interface révolutionnaire.
http://fr.mail.yahoo.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #9540531
Jerome Blondel a écrit :
Bonjour



salut

J'ai un problème d'impression avec CUPS depuis un upgrade récent (c upsys
1.2.7-4,
j'utilise XFCE4). Seul root peut encore imprimer. Il semble qu'il y ait un
problème d'authentification avec les users non-privilégiés. Le me ssage
de debug
dans /var/log/cups/error_log est :

cupsdAuthorize: No authentication data provided.

Mais j'ignore s'il est normal car je n'étais pas en mode débug avan t. Quand
c'est root qui imprime, il met



ça apparaît aussi dans mes logs

cupsdAuthorize: username="root"

Ce qui paraît être le cas normal. J'ai essayé de me mettre dans l es Allowed
Users de l'interface d'admin, ça ne change rien.



Je ne sais pas par où commencer. De plus, j'ai un nouveau problème,
c'est que
quand j'imprime dans une console avec lp en root; il me dit

lp: Quota limit reached.

J'aurais besoin d'un peu d'aide.



avant de commencer à bidouiller les quotas et autres joyeusetés, ça
ne serait pas mal de faire fonctionner CUPS correctement.

essaye de:
désinstaller
faire un mv /etc/cups /etc/cusp.OLD
réinstaller
faire fonctionner avec n'importe quel utilisateur

après tu pourras en rajouter une couche

Ha, un truc: le miens n'aimait pas qu'il n'y ai pas de clé ni de
certificat dans /etc/cups/ssl
--
No matter how subtle the wizard, a knife in the shoulder blades will
seriously cramp his style.
Jerome Blondel
Le #9540461
Jean-Yves F. Barbier a écrit :
Jerome Blondel a écrit :

Bonjour




salut


J'ai un problème d'impression avec CUPS depuis un upgrade récent ( cupsys
1.2.7-4,
j'utilise XFCE4). Seul root peut encore imprimer.


essaye de:
désinstaller
faire un mv /etc/cups /etc/cusp.OLD
réinstaller
faire fonctionner avec n'importe quel utilisateur

après tu pourras en rajouter une couche

Ha, un truc: le miens n'aimait pas qu'il n'y ai pas de clé ni de
certificat dans /etc/cups/ssl



J'ai réinstallé cups avec un /etc/cups vide, et il semblerait qu'il
manque le cupsd.conf dans le nouveau package, ce qui fait planter dpkg
lors de la configuration...

En effet /etc/cups/ssl est vide.

J'ai repris l'ancien cupsd.conf pour essayer et cela me donne un nouveau
problème :

lp: Unsupported format 'application/octet-stream'!

Normalement il y a un choix à faire lors de la configuration, qui sembl e
avoir un rapport avec ceci, mais ça ne change rien.

Je vais arrêter pour ce soir.







___________________________________________________________________________
Yahoo! Mail réinvente le mail ! Découvrez le nouveau Yahoo! Mail et son interface révolutionnaire.
http://fr.mail.yahoo.com
Jerome Blondel
Le #9540341
Problème résolu. Merci.

Jerome Blondel a écrit :
Jean-Yves F. Barbier a écrit :
Jerome Blondel a écrit :

Bonjour




salut


J'ai un problème d'impression avec CUPS depuis un upgrade récent
(cupsys
1.2.7-4,
j'utilise XFCE4). Seul root peut encore imprimer.


essaye de:
désinstaller
faire un mv /etc/cups /etc/cusp.OLD
réinstaller
faire fonctionner avec n'importe quel utilisateur

après tu pourras en rajouter une couche

Ha, un truc: le miens n'aimait pas qu'il n'y ai pas de clé ni de
certificat dans /etc/cups/ssl



J'ai réinstallé cups avec un /etc/cups vide, et il semblerait qu'il
manque le cupsd.conf dans le nouveau package, ce qui fait planter dpkg
lors de la configuration...

En effet /etc/cups/ssl est vide.

J'ai repris l'ancien cupsd.conf pour essayer et cela me donne un nouvea u
problème :

lp: Unsupported format 'application/octet-stream'!


Il manquant le /etc/cups/mime.convs et /etc/cups/mime.types







___________________________________________________________________________
Yahoo! Mail réinvente le mail ! Découvrez le nouveau Yahoo! Mail et son interface révolutionnaire.
http://fr.mail.yahoo.com
Publicité
Poster une réponse
Anonyme