Problème d'interface internet

Le
LM---
Bonjour à toutes et à tous,

Je livre à votre sagacité la description de mon désagréable problème qui
concerne l'absence de fiabilité de mon branchement internet
Sur un ordi Debian Lenny avec KDE 3.5.10 ; et en outre, une carte
"Ethernet Pro 100 Intel Corp." (toujours, autant que je sache, du début
à la fin "eth0") ET une carte combi USB/FireWire "Genesis Logic Inc."
(toujours, autant que je sache, du début à la fin "usb0").

_Le_ _problème_ :

La sélection de l'interface eth0, effectivement câblée sur mon
modem-routeur, ne se fait pas. Le système choisit "automatiquement"
usb0, qui n'est pas câblé, à moins que je n'intervienne manuellement.


_Description_ _des_ _faits_ :

Pendant l'amorçage, tout semble bien se passer : je lis ce que j'ai
toujours lu (notamment sous Etch), le passage suivant :
DHCPOFFER from xxx.xxx.x.xxx
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from xxx.xxx.x.xxx
bound to xxx(adresse IP de la "bonne" interface, eth0)xxx - renewal in
.. seconds
done

Et puis, par je ne sais quelle opération, une fois que l'amorçage est
terminé et que vient le temps de s'identifier, tout s'embrouille et
cafouille

# Sous KDE :
1) KNetworkConf (dans le Centre de config de KDE - Paramètres réseau)
liste certes eth0 (et lui seul), mais ne lui attribue pas d'adresse IP
(alors que DHCP est le mode de détection d'IP préselectionné) ; rien ne
change avant qu'on ne relance la détection via un désactiver-réactiver
l'interface ;
2) L'applet knetworkmanager, que j'ai installé pour faciliter sous Etch
la connexion-déconnexion au réseau, est tout aussi "troublé" ; au
démarrage de KDE, il rame et ne peut/veut se connecter à aucune
interface, pour, après une vingtaine de secondes, choisir la mauvaise :
"usb0".

# Si (décidant de ne pas m'identifier via KDM) je passe sous la console
tty1 --> identification --> passage en root par "su" et que je passe
l'instruction "ifconfig -a" , j'obtiens dans la première vingtaine de
secondes ceci :

eth0 Link encap:Ethernet HWaddr 00:02:b3:eb:d8:02
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:15 errors:0 dropped:0 overruns:0 frame:0
TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:1913 (1.8 KiB) TX bytes:8587 (8.3 KiB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:3500 (3.4 KiB) TX bytes:3500 (3.4 KiB)

usb0 Link encap:Ethernet HWaddr 5e:cd:b5:00:88:c4
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:4 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

puis ultérieurement cela :

eth0 Link encap:Ethernet HWaddr 00:02:b3:eb:d8:02
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17 errors:0 dropped:0 overruns:0 frame:0
TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:2033 (1.9 KiB) TX bytes:8587 (8.3 KiB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:3500 (3.4 KiB) TX bytes:3500 (3.4 KiB)

usb0 Link encap:Ethernet HWaddr 5e:cd:b5:00:88:c4
inet adr:169.254.91.233 Bcast:169.254.255.255 Masque:255.255.0.0
adr inet6: fe80::5ccd:b5ff:fe00:88c4/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:16 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Ce qui confirme ce que je vois sous KDE :
quelque chose (quoi ?) fait choisir au système (à quel élément, routine,
programme ?) la mauvaise interface usb0.

Comment résoudre ce problème ? Voilà toute l'énigme qui se présente à moi !

Mon autre problème est que je ne sais pas trop où effectuer quels tests
pour savoir quel réglage je dois modifier où avec quel programme,
routine, module ou autre, avant même de penser à remplir un
formulaire de bogue pour un paquet

Si vous avez des pistes, je vous en serai très redevable (Si vous
avez besoin des résultats d'autres manips / commandes, faites-moi signe).

Merci d'avance

ludo

PS Voici déjà le contenu du premier fichier /etc/network/interfaces
(celui généré à l'installation)

DEBUT
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

auto eth0

FIN

J'en ai eu cinq versions et aucune n'a marché comme je l'espérais

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
~TraydenT~
Le #20103071
Le 09/09/2009 15:05, LM--- a écrit :
Bonjour à toutes et à tous,


Bonjour,
[…]
Ce qui confirme ce que je vois sous KDE :
quelque chose (quoi ?) fait choisir au système (à quel élément,
routine, programme ?) la mauvaise interface usb0.


Je suppose que c'est le démon NetworkManager qui gère ça aussi sous KDE.
Il gère les connexions non renseignées dans le /etc/network/interfaces.
Comment résoudre ce problème ? Voilà toute l'énigme qui se présente à
moi !


(Réponse après PS)

Merci d'avance


En espérant être sur la bonne voie

ludo

PS Voici déjà le contenu du premier fichier /etc/network/interfaces
(celui généré à l'installation)

DEBUT---
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

auto eth0

FIN---

J'en ai eu cinq versions et aucune n'a marché comme je l'espérais ...


As-tu essayé de retirer/commenter les lignes concernant la config de
l'interface eth0 ? Cette config est pour de la config statique sans
interface graphique (typiquement pour un serveur).

--
~TraydenT~

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Grégory Bulot
Le #20103141
LM--- +0200
Bonjour à toutes et à tous,




Bonjour,

- mii-tool ?
- si tu fait un dhclient3 (ou dhclient si pas le choix), y'a du mieux ?
- si tu est sous lenny, pc de bureau, pourquoi ne pas utiliser wicd,
voir mieux désinstaller network-manager (et wicd si tu l'a essayé)
- ifconfig usb0 down ; ifconfig eth0 down ; ifconfig eth0 up ;
ifconfig

- quel sont les modules firewire et celui de ta carte ethernet ? (lsmod
peux éventuellement aider)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Yves F. Barbier
Le #20103591
LM--- a écrit :
Bonjour à toutes et à tous,

Je livre à votre sagacité la description de mon désagréable problème qui
concerne l'absence de fiabilité de mon branchement internet...
Sur un ordi Debian Lenny avec KDE 3.5.10 ; et en outre, une carte
"Ethernet Pro 100 Intel Corp." (toujours, autant que je sache, du début
à la fin "eth0") ET une carte combi USB/FireWire "Genesis Logic Inc."
(toujours, autant que je sache, du début à la fin "usb0").

_Le_ _problème_ :

La sélection de l'interface eth0, effectivement câblée sur mon
modem-routeur, ne se fait pas. Le système choisit "automatiquement"
usb0, qui n'est pas câblé, à moins que je n'intervienne manuellement.



Ton truc me rappelle un PB similaire il-y-a qq années, en fait dans mon
cas c'était plus facilement reconnaissable parce que j'avais eth0 & eth1.
Maintenant que tout a évolué, une interface Ethernet n'est plus
nécessairement nommée 'ethN'.

L'une des 2 (eth0) était générée par le module 'eth1394' qui permet IP
over 1394 (mais, comme le dit la doc, n'émule pas Ethernet), ce qui
fait que c'est la carte SCSI qui préemptait sur DHCP puisque son module
était chargé avant le module de la carte Ethernet.

Si c'est cela, ça peut de régler de plusieurs manières, par ordre de préf perso:
* recompiler un kernel sans le module 'eth1394',
* débarquer le module 'eth1394' par un script exécuté avant le dhcp-client,
ou si impossible, exécuté en dernier et relançant le dhcp-client après coup,
* bidouiller avec HAL pour qu'il inverse l'ordre des modules.

Perso, je n'aime pas le dernier parce que ça touche à une couche plus profonde
(et donc IMHO plus réservé pour faire correctement reconnaître un device
apparaissant comme inconnu par exemple.)

'gade si ce module est présent, si vi, vire-le et relance le client pour voir ce
qui se passe.

JY
--
platonic friendship, n.:
What develops when two people get tired of making love to each other.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Grégory Bulot
Le #20103731
"Jean-Yves F. Barbier" 16:31:25 +0200


Si c'est cela, ça peut de régler de plusieurs manières, pa r ordre de
préf perso:
* recompiler un kernel sans le module 'eth1394',
* débarquer le module 'eth1394' par un script exécuté avan t le
dhcp-client, ou si impossible, exécuté en dernier et relanà §ant le
dhcp-client après coup,



/etc/modprobe.d/blacklist mettre eth1394 pourrait suffire ?



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Yves F. Barbier
Le #20104251
Grégory Bulot a écrit :
"Jean-Yves F. Barbier" 16:31:25 +0200


Si c'est cela, ça peut de régler de plusieurs manières, par ordre de
préf perso:
* recompiler un kernel sans le module 'eth1394',
* débarquer le module 'eth1394' par un script exécuté avant le
dhcp-client, ou si impossible, exécuté en dernier et relançant le
dhcp-client après coup,



/etc/modprobe.d/blacklist mettre eth1394 pourrait suffire ?



il faut tester, à l'époque il me semble avoir tout essayé
mais certains modules reviennent malgré un blacklist.

comme je n'aime pas les solutions compliquées, un script
est la façon la plus rapide de se débarrasser du PB jusqu'à
avoir du temps à perdre pour l'analyser.

--
So... if you could choose any nose in the whole wide world,
which one would you pick?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Grégory Bulot
Le #20105751
"Jean-Yves F. Barbier" 17:50:00 +0200


il faut tester, à l'époque il me semble avoir tout essayé
mais certains modules reviennent malgré un blacklist.



oui, je confirme, mais y'a l'autre effet pervers : un module chargé au
boot bloque certains périphériques "un peu trop compatible MsWind ows"

j'ai eu le cas en début d'année avec du wifi (cas un peu particul ier
certes)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Yves F. Barbier
Le #20105741
Grégory Bulot a écrit :
"Jean-Yves F. Barbier" 17:50:00 +0200


il faut tester, à l'époque il me semble avoir tout essayé
mais certains modules reviennent malgré un blacklist.



oui, je confirme, mais y'a l'autre effet pervers : un module chargé au
boot bloque certains périphériques "un peu trop compatible MsWindows"

j'ai eu le cas en début d'année avec du wifi (cas un peu particulier
certes)



d'où le point premier de ma réponse: recompiler un kernel sans les modules
incriminés.

--
Q. How do you keep an Aggie busy at a terminal?
A. While he's not looking, switch it to "local".

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Leopold BAILLY
Le #20106371
LM---
Bonjour à toutes et à tous,



[...]

_Description_ _des_ _faits_ :

Pendant l'amorçage, tout semble bien se passer : je lis ce que j'ai
toujours lu (notamment sous Etch), le passage suivant :
DHCPOFFER from xxx.xxx.x.xxx
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from xxx.xxx.x.xxx
bound to xxx(adresse IP de la "bonne" interface, eth0)xxx - renewal in
..... seconds
done



Jusque là tout est normal.

Et puis, par je ne sais quelle opération, une fois que l'amorçage est
terminé et que vient le temps de s'identifier, tout s'embrouille et
cafouille...



[...]

# Si (décidant de ne pas m'identifier via KDM) je passe sous la
console tty1 --> identification --> passage en root par "su" et que je
passe l'instruction "ifconfig -a" , j'obtiens dans la première
vingtaine de secondes ceci :

eth0 Link encap:Ethernet HWaddr 00:02:b3:eb:d8:02
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:15 errors:0 dropped:0 overruns:0 frame:0
TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:1913 (1.8 KiB) TX bytes:8587 (8.3 KiB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:3500 (3.4 KiB) TX bytes:3500 (3.4 KiB)

usb0 Link encap:Ethernet HWaddr 5e:cd:b5:00:88:c4
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:4 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

puis ultérieurement cela :

eth0 Link encap:Ethernet HWaddr 00:02:b3:eb:d8:02
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:17 errors:0 dropped:0 overruns:0 frame:0
TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:2033 (1.9 KiB) TX bytes:8587 (8.3 KiB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:3500 (3.4 KiB) TX bytes:3500 (3.4 KiB)

usb0 Link encap:Ethernet HWaddr 5e:cd:b5:00:88:c4
inet adr:169.254.91.233 Bcast:169.254.255.255 Masque:255.255.0.0
adr inet6: fe80::5ccd:b5ff:fe00:88c4/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:16 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Ce qui confirme ce que je vois sous KDE :
quelque chose (quoi ?) fait choisir au système (à quel élément,
routine, programme ?) la mauvaise interface usb0.



Je dirais plutôt quelque chose déconfigure eth0 et essaie de
configurer usb0, mais ça échoue, d'où l'adresse IP en 169.* (je crois
que c'est avahi qui fait ça).


Comment résoudre ce problème ? Voilà toute l'énigme qui se présente à moi !



Il faut déjà découvrir d'où sort cette interface usb0 : tu devrais
avoir ça dans tes logs au moment du chargement d'un certain module du
noyau.

Ensuite, il faut découvrir qu'est-ce qui force la reconfiguration.

Si à la fin, sans rentrer dans kde, tu fais :
~$ sudo invoke-rc.d networking restart
est-ce que tout rentre dans l'ordre ?

Regarde bien dans tes logs, il doit bien y avoir des messages concernant
eth0 et usb0, ça devrait aider à comprendre.

[...]

DEBUT---
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

auto eth0

FIN---



--
Léo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Grégory Bulot
Le #20108051
"Jean-Yves F. Barbier" 20:44:10 +0200


d'où le point premier de ma réponse: recompiler un kernel sans les
modules incriminés.



disons que le blacklist dans /etc/modprobe.d/blacklist est la méthode
"de non recompil pour les fainéants" :-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
fra-duf-no-spam
Le #20109961
Le 14497ième jour après Epoch,
Grégory Bulot écrivait:

"Jean-Yves F. Barbier" 20:44:10 +0200


d'où le point premier de ma réponse: recompiler un kernel sans les
modules incriminés.



disons que le blacklist dans /etc/modprobe.d/blacklist est la méthode
"de non recompil pour les fainéants" :-)



Ou pour ceux qui veulent un système stable, propre, cohérent, s écurisé,
etc...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme