Problème interfaces réseau

Le
Pascal
Salut,

Je suis en train de dupliquer notre serveur de messageries qui est un
peu vieux.
Il tourne sous gentoo, et a 2 cartes réseaux.
La nouvelle station à 1 carte réseau pour le moment.
Lors du boot, le nouveau détecte bien eth0:via_rhine , mais fini par la
mettre en eth2 (ifconfig -a).
Il ne veut absolument pas utilisé eth0 !
On dirait qu'il a garder la configuration des 2 cartes réseaux 3Com de
l'ancioen serveur qui était présente dedans, et met donc la nouvelle en
eth2 !

Comment empêcher cela !?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Hambourg
Le #22095521
Salut,

Pascal a écrit :

Je suis en train de dupliquer notre serveur de messageries qui est un
peu vieux.
Il tourne sous gentoo, et a 2 cartes réseaux.
La nouvelle station à 1 carte réseau pour le moment.
Lors du boot, le nouveau détecte bien eth0:via_rhine , mais fini par la
mettre en eth2 (ifconfig -a).
Il ne veut absolument pas utilisé eth0 !
On dirait qu'il a garder la configuration des 2 cartes réseaux 3Com de
l'ancioen serveur qui était présente dedans, et met donc la nouvelle en
eth2 !



C'est probablement à cause de règles de nommage d'udev qui ont été
créées automatiquement et associent les noms eth0 et eth1 aux adresses
MAC des anciennes interfaces.

Comment empêcher cela !?



Supprimer ou modifier les règles de nommage des interfaces réseau
d'udev. Chercher dans /etc/udev.
Pascal
Le #22096241
Le 10/05/2010 13:39, Pascal Hambourg a écrit :
Salut,

Pascal a écrit :

Je suis en train de dupliquer notre serveur de messageries qui est un
peu vieux.
Il tourne sous gentoo, et a 2 cartes réseaux.
La nouvelle station à 1 carte réseau pour le moment.
Lors du boot, le nouveau détecte bien eth0:via_rhine , mais fini par la
mettre en eth2 (ifconfig -a).
Il ne veut absolument pas utilisé eth0 !
On dirait qu'il a garder la configuration des 2 cartes réseaux 3Com de
l'ancioen serveur qui était présente dedans, et met donc la nouvelle en
eth2 !



C'est probablement à cause de règles de nommage d'udev qui ont été
créées automatiquement et associent les noms eth0 et eth1 aux adresses
MAC des anciennes interfaces.

Comment empêcher cela !?



Supprimer ou modifier les règles de nommage des interfaces réseau
d'udev. Chercher dans /etc/udev.



Ok, tout est dans le fichier :
/etc/udev/rules.d/70-persistent-net.rules

Un fois modifié, tout rentre dans l'ordre.

Merci de ton aide.
Erwan David
Le #22096571
Pascal
Le 10/05/2010 13:39, Pascal Hambourg a écrit :
Salut,

Pascal a écrit :

Je suis en train de dupliquer notre serveur de messageries qui est un
peu vieux.
Il tourne sous gentoo, et a 2 cartes réseaux.
La nouvelle station à 1 carte réseau pour le moment.
Lors du boot, le nouveau détecte bien eth0:via_rhine , mais fini par la
mettre en eth2 (ifconfig -a).
Il ne veut absolument pas utilisé eth0 !
On dirait qu'il a garder la configuration des 2 cartes réseaux 3Com de
l'ancioen serveur qui était présente dedans, et met donc la nouvelle en
eth2 !



C'est probablement à cause de règles de nommage d'udev qui ont été
créées automatiquement et associent les noms eth0 et eth1 aux adresses
MAC des anciennes interfaces.

Comment empêcher cela !?



Supprimer ou modifier les règles de nommage des interfaces réseau
d'udev. Chercher dans /etc/udev.



Ok, tout est dans le fichier :
/etc/udev/rules.d/70-persistent-net.rules

Un fois modifié, tout rentre dans l'ordre.

Merci de ton aide.



Tu peux même le virer : il est recréé au besoin.

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Benoit Izac
Le #22098191
Bonjour,

le 10/05/2010 à 15:57, Erwan David a écrit dans le message

Supprimer ou modifier les règles de nommage des interfaces réseau
d'udev. Chercher dans /etc/udev.



Ok, tout est dans le fichier :
/etc/udev/rules.d/70-persistent-net.rules

Un fois modifié, tout rentre dans l'ordre.

Merci de ton aide.



Tu peux même le virer : il est recréé au besoin.



Une question qui me taraude au passage :

Il y a quelque temps, j'avais renommé eth0 en « lan » et eth1 en
« wan ». Ça marchait sans encombre puis, j'ai eu un peu peur de tomber
sur un problème et que ça plante à un moment ou à un autre. J'ai donc
remis la configuration classique.

Pourtant, je trouvais ça vraiment pratique :
iptables -i wan ...
dhcpd lan
etc.
alors qu'avec eth0 et eth1, je ne sais jamais à quoi l'interface
correspond.

Voyez-vous un inconvénient à ce type de configuration ?

--
Benoit Izac
Bastien Durel
Le #22099981
Le Mon, 10 May 2010 21:23:47 +0200, Benoit Izac a écrit :
Il y a quelque temps, j'avais renommé eth0 en « lan » et eth1 en « wan
». Ça marchait sans encombre puis, j'ai eu un peu peur de tomber sur un
problème et que ça plante à un moment ou à un autre. J'ai donc remis la
configuration classique.

Voyez-vous un inconvénient à ce type de configuration ?


Aucun. D'ailleurs je fais comme ça depuis un moment.

--
Bastien
Frédéric Perrin
Le #22100781
Benoit Izac
Il y a quelque temps, j'avais renommé eth0 en « lan » et e th1 en «
wan ». Ça marchait sans encombre puis, j'ai eu un peu peur de t omber
sur un problème et que ça plante à un moment ou à un autre. J'ai
donc remis la configuration classique.

Pourtant, je trouvais ça vraiment pratique :
iptables -i wan ...
dhcpd lan
etc.
alors qu'avec eth0 et eth1, je ne sais jamais à quoi l'interface
correspond.

Voyez-vous un inconvénient à ce type de configuration ?



J'utilise les noms `filaire' et `wifi' sur les interfaces réseau de
mon portable depuis 2 ans, je n'ai pas relevé le moindre souci. La
seule chose que j'ai vue, sur un serveur, est un script dans Debian
supposant que les interfaces réseau sur lesquelles il y a des VLANs
s'appellent ethd+.d+ (i.e. eth12.34 est eth12 placée dans le VLAN 34
; mais filaire.34 n'est pas mise dans ce VLAN).

--
Fred
Pascal Hambourg
Le #22102361
Salut,

Frédéric Perrin a écrit :

J'utilise les noms `filaire' et `wifi' sur les interfaces réseau de
mon portable depuis 2 ans, je n'ai pas relevé le moindre souci. La
seule chose que j'ai vue, sur un serveur, est un script dans Debian
supposant que les interfaces réseau sur lesquelles il y a des VLANs
s'appellent ethd+.d+ (i.e. eth12.34 est eth12 placée dans le VLAN 34
; mais filaire.34 n'est pas mise dans ce VLAN).



Pour info, ce problème particulier peut être contourné en spécifiant le
nom de l'interface sous-jacente dans une option "vlan-raw-device" (cf.
man vlan-interfaces). Mais il faut être conscient que ce type de
restriction sur le nom d'interface peut effectivement se retrouver dans
d'autres programmes ; si ma mémoire est bonne c'était le cas de pppoe
dans le temps.
Publicité
Poster une réponse
Anonyme