Problème de lancement de service

Le
Bernardo
Bonjour,

Sur une Wheezy 32 bits à jour, j'ai installé un serveur minidln=
a grâce au
paquet éponyme.
Bien que le fichier /etc/init.d/minidlna soit correctement installé,=
que les
différents liens rc*.d soient créés, ce serveur n'est pas =
lancé au démarrage
de l'ordi et je suis donc obligé de le faire manuellement.
Je cherche depuis plusieurs jours sans succès.
Des idées ?

--

Cordialement,
Bernardo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4F58E055.5030907@siorat.net
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bzzz
Le #24305071
On Thu, 08 Mar 2012 17:37:41 +0100
Bernardo
Sur une Wheezy 32 bits à jour, j'ai installé un serveur minidln a grâce au
paquet éponyme.



Le package éponyme est obsolète ];-)

Bien que le fichier /etc/init.d/minidlna soit correctement installé, que les
différents liens rc*.d soient créés, ce serveur n'est pas lancé au démarrage
de l'ordi et je suis donc obligé de le faire manuellement.
Je cherche depuis plusieurs jours sans succès.



Déjà, est-ce que le symlink dans /etc/rc2.d existe et est valide?
Ensuite, est-ce que le script dans /etc/init.d est bien exécutable?
Après, est-ce qu'il-y-a au moins une tentative de lancement par le
system au boot? (=> /var/log/messages)

Dom Diego
--
If you lose your temper at a newspaper columnist, he'll get rich,
or famous or both.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #24305451
On Thu, 08 Mar 2012 17:37:41 +0100
Bernardo
Des idées ?




J'oubliais: est-ce qu'il n'existerait pas un fichier
dans /etc/default nécessitant une modif pour que le daemon soit
lancé? (faire un less du script de lancement pour voir s'il ne
sourcerait pas ce fichier.)

Della Vega
--
Give me Librium or give me Meth.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Siorat
Le #24305561
Bzzz a écrit :
On Thu, 08 Mar 2012 17:37:41 +0100 Bernardo wrote:

Sur une Wheezy 32 bits à jour, j'ai installé un serveur mini dlna grâce
au paquet éponyme.



Le package éponyme est obsolète ];-)



? il est dans les dépôts :
packages.debian.org/search?keywords=minidlna&searchon=names&suite=a ll&section=all

Bien que le fichier /etc/init.d/minidlna soit correctement installé , que
les différents liens rc*.d soient créés, ce serveur n'e st pas lancé au
démarrage de l'ordi et je suis donc obligé de le faire manue llement. Je
cherche depuis plusieurs jours sans succès.



Déjà, est-ce que le symlink dans /etc/rc2.d existe et est val ide?



Oui.

Ensuite, est-ce que le script dans /etc/init.d est bien exécutable ?



Oui, et je le lance manuellement sans problème.

Après, est-ce qu'il-y-a au moins une tentative de lancement par le system au boot? (=>
/var/log/messages)



Ceci à chaque lancement par le système :

Mar 8 13:57:29 asus-debian kernel: [ 950.445226] minidlna[2745]: segfau lt at
0 ip b738353c sp bfaea3ec error 4 in libc-2.13.so[b7324000+156000]

Par contre, je viens de voir (j'aurai du y retourner plus tôt ...) q ue le bug
# 640146 avait évolué et que le mainteneur propose un contourne ment (que je
vais tester au prochain lancement) et un prochain update.


Dom Diego



;-)

--

Cordialement,
Bernardo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernardo
Le #24305551
Bon, le contournement proposé fonctionne, ne reste plus qu"à et tendre l'update...

Désolé pour le bruit,

Merci et bonne soirée.

Bernard Siorat nous disait il y a peu :
Bzzz a écrit :
On Thu, 08 Mar 2012 17:37:41 +0100 Bernardo wrote:

Sur une Wheezy 32 bits à jour, j'ai installé un serveur min idlna grâce
au paquet éponyme.



Le package éponyme est obsolète ];-)



? il est dans les dépôts :
packages.debian.org/search?keywords=minidlna&searchon=names&suite= all&section=all









Bien que le fichier /etc/init.d/minidlna soit correctement installé, que
les différents liens rc*.d soient créés, ce serveur n' est pas lancé au
démarrage de l'ordi et je suis donc obligé de le faire manu ellement.
Je cherche depuis plusieurs jours sans succès.



Déjà, est-ce que le symlink dans /etc/rc2.d existe et est va lide?



Oui.

Ensuite, est-ce que le script dans /etc/init.d est bien exécutabl e?



Oui, et je le lance manuellement sans problème.

Après, est-ce qu'il-y-a au moins une tentative de lancement par l e system
au boot? (=> /var/log/messages)



Ceci à chaque lancement par le système :

Mar 8 13:57:29 asus-debian kernel: [ 950.445226] minidlna[2745]: segf ault
at 0 ip b738353c sp bfaea3ec error 4 in libc-2.13.so[b7324000+156000]

Par contre, je viens de voir (j'aurai du y retourner plus tôt ...) que le
bug # 640146 avait évolué et que le mainteneur propose un con tournement
(que je vais tester au prochain lancement) et un prochain update.


Dom Diego



;-)



--

Cordialement,
Bernardo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme