probleme lenteur ImageIO.read

Le
phil89
Bonjour

J'ai une applet qui utilise un ImageIO.read pour recuperer un PNG
depuis une servlet.
Cela fonctionne MAIS dans le cas ou l'url envoyé est mauvaise, cela
met 1 Minute à me repondre qu'il n'y a pas d'image.
Cote servlet la reponse est immediate.
http://192.168.0.4/toto/servlet/chartdirector.ServletCDirec01d?code=10018=
4&Pres%20184%20-%20100%20Ton&&code=100184&width=300&height=300&fgcolo=
r=000000&bgcolor=c0c0c0&agi_datacharset=ISO-8859-9
Comment faire en sorte que la réponse soit rapide ?

Merci d'avance
Philippe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mayeul
Le #18042741
phil89 a écrit :
Bonjour

J'ai une applet qui utilise un ImageIO.read pour recuperer un PNG
depuis une servlet.
Cela fonctionne MAIS dans le cas ou l'url envoyé est mauvaise, cela
met 1 Minute à me repondre qu'il n'y a pas d'image.
Cote servlet la reponse est immediate.
http://192.168.0.4/toto/servlet/chartdirector.ServletCDirec01d?code0184&Pres%20184%20-%20100%20Ton&&code0184&width00&height00&fgcolor0000&bgcolorÀc0c0&agi_datacharset=ISO-8859-9
Comment faire en sorte que la réponse soit rapide ?

Merci d'avance
Philippe



C'est pas très clair, comme cas d'utilisation. La servlet renvoie
l'image ou l'absence d'image immédiatement, c'est bien ça ? Donc c'est
l'applet (côté client) qui met du temps à se rendre compte que "quelque
chose ne va pas".

Nous sommes très loin d'avoir suffisamment d'informations pour
déterminer ce qu'est ce "quelque chose" qui ne va pas, donc comment
accélérer sa détection.

--
Mayeul
phil89
Le #18098001
Bonjour
L'applet fait un ImageIO.read, elle met 1 minute à me repondre par une
erreur Http 505 alors que la servlet se fait immediatement.
Cela me donne l'impression que soit ImageIO.read n'apprecie pas les
parametres, ou que la servlet à mal ferme sa communication

Philippe
TestMan
Le #18227941
phil89 a écrit :
Bonjour
L'applet fait un ImageIO.read, elle met 1 minute à me repondre par une
erreur Http 505 alors que la servlet se fait immediatement.
Cela me donne l'impression que soit ImageIO.read n'apprecie pas les
parametres, ou que la servlet à mal ferme sa communication

Philippe



Vérifie ce qui se passe (qui envoie quoi, etc) avec Wireshark, et poste
un extrait de la capture au besoin.

A+
TM
Publicité
Poster une réponse
Anonyme