Problème liaison à l'ouverture d'un classeur

Le
dyj Orange
Bonjour au groupe,
Mon système: W7 à jour et Office 2013.
Je suis parti d'un classeur de 12 feuilles, une par mois pour l'année 2013
et je l'ai copié dans un autre répertoire pour l'année 2014. Les 2 classeurs
ont une structure identique, seuls les valeurs des cellules vont changer
d'une année sur l'autre.
Le classeurs 2013 marche très bien et je rencontre un problème de liaison
avec le classeur 2014.
A chaque ouverture du 2014, j'ai un avertissement comme quoi il ne peut pas
mettre à jour les liaisons. Si je clique sur "continuer", tout semble être
ok, mais !! Si je clique sur "mettre à jour" tous les liens sont marqués
"ok".
J'ai vérifié les liaisons dans le 2013 (Données, modifier les liaisons),
j'ai bien les 2 classeurs avec lequel j'ai des liens externes, plus
personal.xlsb, mes macro personnels.
Si je fais la même opération avec le 2014, j'ai bien mes 2 classeurs, mais
personal.xlsb n'y est pas.
Est ce la source de mon problème ? comment le corriger ?
Merci pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #25715112
Bonjour,

Ruban / menu : données / section : Connexion : / Commande : Modifier

Dans cette fenêtre si ton fichier de macros personnelles apparaît, c'est que
tu as des liens avec ce classeur. Le type de lien pourrait être dans les
formules
des cellules du classeur, MAIS AUSSI si tu as des boutons de commande
auxquelles
sont attachées des macros de ton classeur personnel.

Si de tels boutons existent dans ton classeur 2013, vérifie que dans ton
classeur 2014,
les macros attachées aux boutons sont liées au classeur de macros
personnelles. Pour
ce faire, tu n'as qu'à faire un clic droit sur ces boutons et choisir la
commande "affecter"
une macro".




MichD
---------------------------------------------------------------
"dyj Orange" a écrit dans le message de groupe de discussion :
l38b6h$bkb$

Bonjour au groupe,
Mon système: W7 à jour et Office 2013.
Je suis parti d'un classeur de 12 feuilles, une par mois pour l'année 2013
et je l'ai copié dans un autre répertoire pour l'année 2014. Les 2 classeurs
ont une structure identique, seuls les valeurs des cellules vont changer
d'une année sur l'autre.
Le classeurs 2013 marche très bien et je rencontre un problème de liaison
avec le classeur 2014.
A chaque ouverture du 2014, j'ai un avertissement comme quoi il ne peut pas
mettre à jour les liaisons. Si je clique sur "continuer", tout semble être
ok, mais !! Si je clique sur "mettre à jour" tous les liens sont marqués
"ok".
J'ai vérifié les liaisons dans le 2013 (Données, modifier les liaisons),
j'ai bien les 2 classeurs avec lequel j'ai des liens externes, plus
personal.xlsb, mes macro personnels.
Si je fais la même opération avec le 2014, j'ai bien mes 2 classeurs, mais
personal.xlsb n'y est pas.
Est ce la source de mon problème ? comment le corriger ?
Merci pour votre aide.
dyj Orange
Le #25715242
Tout d'abord merci de la spontanéité de ta réponse.
En suivant tes recommandations, j'ai pu m'apercevoir que mes boutons avaient
perdu leur affectation de macro. Le fautif, c'est moi .. J'ai donc réaffecté
mes macros aux boutons, je les ai vérifiés et ils marchent.
J'ai enregistré le classeur et réouverture.
Toujours le même message, en cliquant sur "mettre à jour", maintenant
personal.xlsb apparait bien dans la liste, mais avec un état "Inconnu".


"MichD" a écrit dans le message de groupe de discussion :
l38dc4$gr0$

Bonjour,

Ruban / menu : données / section : Connexion : / Commande : Modifier

Dans cette fenêtre si ton fichier de macros personnelles apparaît, c'est que
tu as des liens avec ce classeur. Le type de lien pourrait être dans les
formules
des cellules du classeur, MAIS AUSSI si tu as des boutons de commande
auxquelles
sont attachées des macros de ton classeur personnel.

Si de tels boutons existent dans ton classeur 2013, vérifie que dans ton
classeur 2014,
les macros attachées aux boutons sont liées au classeur de macros
personnelles. Pour
ce faire, tu n'as qu'à faire un clic droit sur ces boutons et choisir la
commande "affecter"
une macro".




MichD
---------------------------------------------------------------
"dyj Orange" a écrit dans le message de groupe de discussion :
l38b6h$bkb$

Bonjour au groupe,
Mon système: W7 à jour et Office 2013.
Je suis parti d'un classeur de 12 feuilles, une par mois pour l'année 2013
et je l'ai copié dans un autre répertoire pour l'année 2014. Les 2 classeurs
ont une structure identique, seuls les valeurs des cellules vont changer
d'une année sur l'autre.
Le classeurs 2013 marche très bien et je rencontre un problème de liaison
avec le classeur 2014.
A chaque ouverture du 2014, j'ai un avertissement comme quoi il ne peut pas
mettre à jour les liaisons. Si je clique sur "continuer", tout semble être
ok, mais !! Si je clique sur "mettre à jour" tous les liens sont marqués
"ok".
J'ai vérifié les liaisons dans le 2013 (Données, modifier les liaisons),
j'ai bien les 2 classeurs avec lequel j'ai des liens externes, plus
personal.xlsb, mes macro personnels.
Si je fais la même opération avec le 2014, j'ai bien mes 2 classeurs, mais
personal.xlsb n'y est pas.
Est ce la source de mon problème ? comment le corriger ?
Merci pour votre aide.
MichD
Le #25715402
As-tu des plages nommées (insertion / nom / définir) dans ton classeur?

As-tu vérifié si leur référence était correcte?


MichD
---------------------------------------------------------------
dyj Orange
Le #25715542
Un grand merci, c'est un domaine que je ne maitrisai pas. Effectivement
j'avais des noms ??? qui trainaient dans mon classeur 2013 et par copie ils
sont apparus dans le 2014. Après un grand ménage, tout est rentré dans
l'ordre.
Merci beaucoup pour ton aide.

"MichD" a écrit dans le message de groupe de discussion :
l38kbh$2ic$

As-tu des plages nommées (insertion / nom / définir) dans ton classeur?

As-tu vérifié si leur référence était correcte?


MichD
---------------------------------------------------------------
marcussaccaplus Hors ligne
Le #26361189
Le vendredi 11 Octobre 2013 à 10:00 par dyj Orange :
Bonjour au groupe,
Mon système: W7 à jour et Office 2013.
Je suis parti d'un classeur de 12 feuilles, une par mois pour l'année
2013
et je l'ai copié dans un autre répertoire pour l'année
2014. Les 2 classeurs
ont une structure identique, seuls les valeurs des cellules vont changer
d'une année sur l'autre.
Le classeurs 2013 marche très bien et je rencontre un problème de
liaison
avec le classeur 2014.
A chaque ouverture du 2014, j'ai un avertissement comme quoi il ne peut pas
mettre à jour les liaisons. Si je clique sur "continuer", tout
semble être
ok, mais !! Si je clique sur "mettre à jour" tous les liens
sont marqués
"ok".
J'ai vérifié les liaisons dans le 2013 (Données, modifier
les liaisons),
j'ai bien les 2 classeurs avec lequel j'ai des liens externes, plus
personal.xlsb, mes macro personnels.
Si je fais la même opération avec le 2014, j'ai bien mes 2
classeurs, mais
personal.xlsb n'y est pas.
Est ce la source de mon problème ? comment le corriger ?
Merci pour votre aide.


Bravo

M'a sorti d'un mauvais pas
Bien vu
marcussaccaplus Hors ligne
Le #26361190
Le vendredi 11 Octobre 2013 à 10:00 par dyj Orange :
Bonjour au groupe,
Mon système: W7 à jour et Office 2013.
Je suis parti d'un classeur de 12 feuilles, une par mois pour l'année
2013
et je l'ai copié dans un autre répertoire pour l'année
2014. Les 2 classeurs
ont une structure identique, seuls les valeurs des cellules vont changer
d'une année sur l'autre.
Le classeurs 2013 marche très bien et je rencontre un problème de
liaison
avec le classeur 2014.
A chaque ouverture du 2014, j'ai un avertissement comme quoi il ne peut pas
mettre à jour les liaisons. Si je clique sur "continuer", tout
semble être
ok, mais !! Si je clique sur "mettre à jour" tous les liens
sont marqués
"ok".
J'ai vérifié les liaisons dans le 2013 (Données, modifier
les liaisons),
j'ai bien les 2 classeurs avec lequel j'ai des liens externes, plus
personal.xlsb, mes macro personnels.
Si je fais la même opération avec le 2014, j'ai bien mes 2
classeurs, mais
personal.xlsb n'y est pas.
Est ce la source de mon problème ? comment le corriger ?
Merci pour votre aide.


Bravo

M'a sorti d'un mauvais pas
Bien vu
Publicité
Poster une réponse
Anonyme