problème linux

Le
syxoga56
Bonjour,

j'ai récemment installé ubuntu 7.04 sur un céléron.

Avant, le céléron était une station de jeu pour jouer en local sur des
win98.

je désire aujourd'hui en faire un serveur, le problème que je
rencontre et qui m'empêche d'aller plus loin est : pas de connexion
internet, je voulais installer VNC pour tout configurer à partir de
mon AMD, mais ça ne s'avère pas possible

en faisant un nano /etc/network/interfaces, j'ai :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.1

en faisant ifconfig eth0 192.168.1.6 netmask 255.255.255.0, j'ai :

SIOCSIFADDR : no such device
eth0 : ERROR chile getting interface flags : no such device
SIOCSIFNETMASK : no such device

et en faisant ifconfig eth0, j'ai :

eth0 : error fetching interface informations : device not found

j'ai aussi testé ifconfig eth1 jusqu'à eth10, sans résultat

Est-ce que quelqu'un saurait m'aider pour installer le net sur mon PC
SVP ?

Merci d'avance,

Syxo.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
pomalo
Le #1887921
bonjour
et en faisant

sudo eth0 192.168.1.6 netmask 255.255.255.0

car tu n'as pas le droit de modifier une interface réseau en tant que
simple utilisateur


Bonjour,

j'ai récemment installé ubuntu 7.04 sur un céléron.

Avant, le céléron était une station de jeu pour jouer en local sur des
win98.

je désire aujourd'hui en faire un serveur, le problème que je
rencontre et qui m'empêche d'aller plus loin est : pas de connexion
internet, je voulais installer VNC pour tout configurer à partir de
mon AMD, mais ça ne s'avère pas possible...

en faisant un nano /etc/network/interfaces, j'ai :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.1

en faisant ifconfig eth0 192.168.1.6 netmask 255.255.255.0, j'ai :

SIOCSIFADDR : no such device
eth0 : ERROR chile getting interface flags : no such device
SIOCSIFNETMASK : no such device

et en faisant ifconfig eth0, j'ai :

eth0 : error fetching interface informations : device not found

j'ai aussi testé ifconfig eth1 jusqu'à eth10, sans résultat...

Est-ce que quelqu'un saurait m'aider pour installer le net sur mon PC
SVP ?

Merci d'avance,

Syxo.



pomalo
Le #1887920
Oups!!

sudo ifconfig eth0 192.168.1.6 netmask 255.255.255.0 je voulait dire
sudo eth0 192.168.1.6 netmask 255.255.255.0



syxoga56
Le #1887919
On 14 mai, 07:42, pomalo
Oups!!

sudo ifconfig eth0 192.168.1.6 netmask 255.255.255.0 je voulait dire

sudo eth0 192.168.1.6 netmask 255.255.255.0



oui, mais quand je dis que je fais quelquechose, je le fais en
superutilisateur, sinon il peut pas ^^ logique...


pomalo
Le #1887918
pouvais pas savoir :-) vu que sur Ubuntu par défaut y a pas de compte
superutilisateur

On 14 mai, 07:42, pomalo
Oups!!

sudo ifconfig eth0 192.168.1.6 netmask 255.255.255.0 je voulait dire

sudo eth0 192.168.1.6 netmask 255.255.255.0



oui, mais quand je dis que je fais quelquechose, je le fais en
superutilisateur, sinon il peut pas ^^ logique...





syxoga56
Le #1887917
On 14 mai, 08:05, pomalo
pouvais pas savoir :-) vu que sur Ubuntu par défaut y a pas de compte
superutilisateur


On 14 mai, 07:42, pomalo
Oups!!

sudo ifconfig eth0 192.168.1.6 netmask 255.255.255.0 je voulait dire

sudo eth0 192.168.1.6 netmask 255.255.255.0



oui, mais quand je dis que je fais quelquechose, je le fais en
superutilisateur, sinon il peut pas ^^ logique...



pas de soucis :-) mais t'inquiètes pas, j'y pense à chaque fois, si
j'étais pas en sudo, j'aurais des erreurs différentes ;-) !




Nicolas George
Le #1887916
pomalo wrote in message
pouvais pas savoir :-) vu que sur Ubuntu par défaut y a pas de compte
superutilisateur


Si, tu pouvais savoir, en lisant le message d'erreur, qui explicite le
problème. Si ça avait été un problème de droits, ça aurait dit :

SIOCSIFNETMASK: Permission denied

et pas :

SIOCSIFNETMASK: No such device


À l'avenir, merci de poster à l'endroit.

Nicolas George
Le #1887915
wrote in message
SIOCSIFADDR : no such device


Tout est dit là : du point de vue de Linux, tu n'as pas de carte réseau, ou
alors elle ne s'appelle pas eth0.

syxoga56
Le #1887911
je change de carte réseau alors, mais enfin bon, j'ai tout expliqué il
me semble :

- Le réseau marchait très bien sous win98 avant que je mette mon
ubuntu à la place
- J'ai essayé avec etho, 1, 2... jusqu'à 10...

Alors je vois pas trop je teste en changeant de carte...

Merci.

Syxo.
Nicolas George
Le #1887910
wrote in message
- Le réseau marchait très bien sous win98 avant que je mette mon
ubuntu à la place


Windows et Linux n'utilisent pas du tout les mêmes drivers, donc ça ne
prouve pas grand chose.

- J'ai essayé avec etho, 1, 2... jusqu'à 10...


Ça peut très bien être autre chose. Regarde ce que dit ifconfig -a. Et si ça
ne donne rien, c'est qu'il faut charger le module correspondant.

Alors je vois pas trop je teste en changeant de carte...


Cette phrase n'est pas grammaticale.

syxoga56
Le #1887909
Windows et Linux n'utilisent pas du tout les mêmes drivers, donc ça ne
prouve pas grand chose.

je croyais que linux était mieux que windaube ^^

- J'ai essayé avec etho, 1, 2... jusqu'à 10...



Ça peut très bien être autre chose. Regarde ce que dit ifconfig -a. Et
si ça
ne donne rien, c'est qu'il faut charger le module correspondant.

ça donne quelquechose

Alors je vois pas trop je teste en changeant de carte...



Cette phrase n'est pas grammaticale.

Cette phrase est totalement grammaticale, il manque juste une virgule
après "trop", mais je vois pas ou est le problème, tu viens poster
pour quoi ? me casser les c****** ? ou me filer un coup de main ?

bref, j'ai essayé avec 4 autres cartes réseau et ça marche mieux, je
vais essayer de me démerder (j'ai horreur des gens à qui on demande un
coup de main et qui répondent par un truc genre "Cette phrase n'est
pas grammaticale.", quand tu me verras faire du SMS, on en reparlera,
merci...

Syxo.


Publicité
Poster une réponse
Anonyme