problème migration squeeze->wheezy

Le
Frédéric Marécaille
Bonjour,

Etant peu patient, je me suis rué sur la nouvelle Stable est, ai donc
décidé de mettre à jour ma Debian Squeeze.

L'update s'est bien passée par contre l'upgrade se solde par cette
erreur :

sudo apt-get upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libc6 : Dépend: libc-bin (= 2.11.3-4) mais 2.13-38 est installé
locales : Dépend: glibc-2.13-1
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Que convient il de faire? Wait wait wait??

--
Frédéric Marécaille
genpashiro@lavabit.com
genpashiro.dyndns.org
-+-+-+-+-+-+-+-+-+-+-
DEBIAN
'The Universal Operating System'
www.debian.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20130506163136.GA8272@lavabit.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
maderios
Le #25387662
On 05/06/2013 06:31 PM, Frédéric Marécaille wrote:
Bonjour,

Etant peu patient, je me suis rué sur la nouvelle Stable est, ai donc
décidé de mettre à jour ma Debian Squeeze.

L'update s'est bien passée par contre l'upgrade se solde par cette
erreur :

sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libc6 : Dépend: libc-bin (= 2.11.3-4) mais 2.13-38 est installé
locales : Dépend: glibc-2.13-1
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Que convient il de faire? Wait wait wait??



Salut
Essayer alternativement jusqu'au succès dans une console en root
apt-get -f install
et
dpkg --configure -a

--
Maderios
"Art is meant to disturb. Science reassures."
"L'art est fait pour troubler. La science rassure" (Georges Braque)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Thuban
Le #25387912
Pour une mise à jour de version, mettre d'abord à jour avec apt-get
install <paquet> :
- apt
- aptitude
- dpkg
- noyau linux
- libc6 (qui devrait arriver par le jeu des dépendances).

Ensuite, apt-get dist-upgrade, et la lecture des notes de publication
[1] permettra une migration sans heurts.

[1] : http://www.debian.org/releases/wheezy/releasenotes
--
,--. Xavier Cartron
: /` ) M2 MEFPC
| `-'
_

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Dominique Asselineau
Le #25387972
Thuban wrote on Mon, May 06, 2013 at 08:42:56PM +0200
Pour une mise à jour de version, mettre d'abord à jour avec apt-get
install <paquet> :
- apt
- aptitude
- dpkg
- noyau linux
- libc6 (qui devrait arriver par le jeu des dépendances).



On aurait juste pu supposer que l'ordre des dépendances commence
précisément par ces paquets ?

dom
((

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Thierry Chatelet
Le #25388152
The Monday 06 May 2013 18:31:36, Frédéric Marécaille wrote :
Bonjour,

Etant peu patient


<SNIP>
La patience de lire c'est pas mal:
http://www.debian.org/releases/wheezy/releasenotes.fr.html
Thierry

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Frédéric Marécaille
Le #25389952
Bon, repassé sur Squeeze, je boucle avec l'erreur de libc-bin qui
requière une version inférieure.....

Je tenterai de migrer dans quelques semaines

Le lundi 06 mai 2013 à 10:12:06, Thierry Chatelet a écrit :
The Monday 06 May 2013 18:31:36, Frédéric Marécaille wrote :
> Bonjour,
>
> Etant peu patient
<SNIP>
La patience de lire c'est pas mal:
http://www.debian.org/releases/wheezy/releasenotes.fr.html
Thierry

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/





--
Frédéric Marécaille

genpashiro.dyndns.org
-+-+-+-+-+-+-+-+-+-+-
DEBIAN
'The Universal Operating System'
www.debian.org

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme