problème multiarch Sid

Le
maderios
Bonjour
Je suis en amd64. Le multiarch fonctionne normalement avec stable et
testing mais je rencontre un truc étrange avec Sid. Quand je souhaite
installer un paquet:i386, Apt veut désinstaller le paquet équivalent
amd64, exemple, gcc, libc6, etc.
Bizarrement, j'ai pu installer linux-libc-dev:i386
Que faire, à part s'arracher les cheveux?
--
Maderios


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/53E783EE.5000609@gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
maderios
Le #26301082
On 08/10/2014 04:38 PM, maderios wrote:
Bonjour
Je suis en amd64. Le multiarch fonctionne normalement avec stable et
testing mais je rencontre un truc étrange avec Sid. Quand je souhaite
installer un paquet:i386, Apt veut désinstaller le paquet équivalent
amd64, exemple, gcc, libc6, etc.


C'est (laborieusement) débloqué à coups d'aptitude.
Rien compris...
--
Maderios


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sylvain L. Sauvage
Le #26301084
Le dimanche 10 août 2014, 18:59:43 maderios a écrit :
On 08/10/2014 04:38 PM, maderios wrote:
> Bonjour
> Je suis en amd64. Le multiarch fonctionne normalement avec
> stable et testing mais je rencontre un truc étrange avec
> Sid. Quand je souhaite installer un paquet:i386, Apt veut
> désinstaller le paquet équivalent amd64, exemple, gcc,
> libc6, etc.

C'est (laborieusement) débloqué à coups d'aptitude.
Rien compris...



Il y a eu une màj de GCC en Sid aujourd’hui. La version amd64
est arrivée avant la version i386. Il y a eu une courte pério de
pendant laquelle les versions étaient différentes et en confl it
(de canard).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
maderios
Le #26301087
On 08/10/2014 07:59 PM, Sylvain L. Sauvage wrote:
Le dimanche 10 août 2014, 18:59:43 maderios a écrit :
On 08/10/2014 04:38 PM, maderios wrote:
Bonjour
Je suis en amd64. Le multiarch fonctionne normalement avec
stable et testing mais je rencontre un truc étrange avec
Sid. Quand je souhaite installer un paquet:i386, Apt veut
désinstaller le paquet équivalent amd64, exemple, gcc,
libc6, etc.



C'est (laborieusement) débloqué à coups d'aptitude.
Rien compris...



Il y a eu une màj de GCC en Sid aujourd’hui. La version amd64
est arrivée avant la version i386. Il y a eu une courte période
pendant laquelle les versions étaient différentes et en conflit
(de canard).



Merci pour cette info. Oui, j'ai mis à jour gcc sid ce matin mais pas
d'effet immédiat puisque le nouveau gcc:i386 est certainement arrivé cet
après-midi. A tout hasard, j'ai installé libc6-i686:i386 (pour cpu intel
core 2 duo)

--
Maderios


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme