Problème #Nom ? avec Date()

Le
Pampi
Bonjour,

Je rencontre le "phénomène" suivant : j'ai installé sur 3 postes le même
programme (j'ai même fait des copier/Coller du pgm.mdb, c'est pour vous dire
s'ils sont identiques ;o)).
Sur 1 seul des 3 postes j'ai le problème suivant sur une fenêtre : une zone
de texte dont la Source contrôle est Úte() affiche #Nom ? alors qu'elle
affiche bien la date du jour sur les 2 autres postes

Avez-vous une idée du pourquoi du comment ? Problème Windows ? Paramétrage
Access ?

Pour info, le programme a été développé sous Access 2000 sur mon poste et
installé sur les 3 postes qui ont Access 2002 (même version pour les 3).

Merci par avance pour toute aide.

Bonne journée.

Pampi
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ze Titi
Le #6290151
Bonjour Pampi

C'est certainement un problème de référence manquante sur le poste
concerné par l'erreur. Va faire un tour dans l'éditeur VBA
Menu Outils | Références
Décocher les références manquantes.

Dans ton message
Bonjour,

Je rencontre le "phénomène" suivant : j'ai installé sur 3 postes le même
programme (j'ai même fait des copier/Coller du pgm.mdb, c'est pour vous dire
s'ils sont identiques ... ;o)).
Sur 1 seul des 3 postes j'ai le problème suivant sur une fenêtre : une zone
de texte dont la Source contrôle est Úte() affiche #Nom ? alors qu'elle
affiche bien la date du jour sur les 2 autres postes ...

Avez-vous une idée du pourquoi du comment ? Problème Windows ? Paramétrage
Access ?

Pour info, le programme a été développé sous Access 2000 sur mon poste et
installé sur les 3 postes qui ont Access 2002 (même version pour les 3).

Merci par avance pour toute aide.

Bonne journée.

Pampi


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info

Pampi
Le #6288791
Merci ze Titi,

Bon, ben ... ce matin il n'y avait plus le problème (après avoir éteint et
rallumé tous les postes) ... C'est 1 poste client en réseau qui accède aux
données sur un poste principal via le gestionnaire de tables liées.
Alors est-ce que c'était un problème réseau (si c'est le cas, je ne vois pas
le rapport vu que tout le reste fonctionnait ...) ? J'ai quand même vérifié
les références, aucune n'était manquante.

Pour info, je n'ai pas pu accéder à ce message pendant toute la journée de
jeudi 7, les derniers posts affichés étant datés du 5/6 !!!

Merci encore.

Bonne journée.

Pampi

Bonjour Pampi

C'est certainement un problème de référence manquante sur le poste
concerné par l'erreur. Va faire un tour dans l'éditeur VBA
Menu Outils | Références
Décocher les références manquantes.

Dans ton message
Bonjour,

Je rencontre le "phénomène" suivant : j'ai installé sur 3 postes le même
programme (j'ai même fait des copier/Coller du pgm.mdb, c'est pour vous dire
s'ils sont identiques ... ;o)).
Sur 1 seul des 3 postes j'ai le problème suivant sur une fenêtre : une zone
de texte dont la Source contrôle est Úte() affiche #Nom ? alors qu'elle
affiche bien la date du jour sur les 2 autres postes ...

Avez-vous une idée du pourquoi du comment ? Problème Windows ? Paramétrage
Access ?

Pour info, le programme a été développé sous Access 2000 sur mon poste et
installé sur les 3 postes qui ont Access 2002 (même version pour les 3).

Merci par avance pour toute aide.

Bonne journée.

Pampi


--
Cordialement,
Ze Titi

Tout pour réussir avec Access :
http://www.mpfa.info






3stone
Le #6288671
Salut,

"Pampi"
| J'ai quand même vérifié les références, aucune n'était manquante.


J'ai un doute sur cette affirmation...

Sur le poste qui exécute la base et qui donne l'erreur :
Alt + F11, Outils références - sûrement un référence notée manquante

En dernier ressort, tu peux refaire un "régistration" de la dao360.dll

regsvr32 "c:chemin...dao360.dll"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Pampi
Le #6288651
Pierre,

Merci pour ta réponse.

Un doute t'habite, ok ... ;o)

J'ai pourtant fait faire la manip par l'utilisateur qui a vérifié les
références : il m'a cité les références cochées, aucune d'entre elles n'était
marquée MANQUANTE ce matin APRES que les ordis aient redémarré et que le
problème ait été résolu.
Je ne peux donc pas garantir que c'était le cas avant le rédémarrage ni que
personne n'a touché au programme, même si a priori personne n'a de compétence
informatique (a fortiori en matière d'Access) chez ce client

Le problème étant résolu, je n'ai plus besoin d'effectuer ta manip sur la
dll dao360.dll.

Merci quand même de t'être penché sur mon problème plusieurs jours après.

Bonne journée.

Pampi



Salut,

"Pampi"
| J'ai quand même vérifié les références, aucune n'était manquante.


J'ai un doute sur cette affirmation...

Sur le poste qui exécute la base et qui donne l'erreur :
Alt + F11, Outils références - sûrement un référence notée manquante

En dernier ressort, tu peux refaire un "régistration" de la dao360.dll

regsvr32 "c:chemin...dao360.dll"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)





Publicité
Poster une réponse
Anonyme