Problème de permission sur clés USB

Le
Christophe Gallaire
Bonsoir à tous,

J'ai installé récemment Debian 8. Toutes les clés USB sont=
montées avec
pour propriétaire "root". Je ne m'explique pas pourquoi. Pour contou=
rner
le problème d'écriture, j'ai modifié le fichier
/etc/usbmount/usbmount.conf comme suit :

FS_MOUNTOPTIONS="-fstype=vfat,gid=plugdev,fmask=0002,dmask=0002=
"

Reste qu'au démontage, je dois renseigner mon mot de passe "root".

Quelqu'un a-t-il des lumières sur ce problème ?

D'avance, merci.

Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/5578A0F9.4020706@gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
mireero
Le #26356163
On 06/10/2015 10:50 PM, Christophe Gallaire wrote:
Bonsoir à tous,

J'ai installé récemment Debian 8. Toutes les clés USB sont montées avec
pour propriétaire "root". Je ne m'explique pas pourquoi. Pour contourner
le problème d'écriture, j'ai modifié le fichier
/etc/usbmount/usbmount.conf comme suit :

FS_MOUNTOPTIONS="-fstype=vfat,gid=plugdev,fmask02,dmask02"

Reste qu'au démontage, je dois renseigner mon mot de passe "root".

Quelqu'un a-t-il des lumières sur ce problème ?

D'avance, merci.

Christophe




Tu peux ajouter l'option 'user' (ou même plutôt 'users') à tes options
de montage, et uid=`id -u`.

Ceci dans la ligne de commande de "montage", ou dans usbmount.conf (je
connais pas ce fichier, en tout cas je l'ai pas ici), ou plus
classiquement dans fstab.

--
mireero

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/557920c4$0$3318$
Christophe Gallaire
Le #26356168
Le 11/06/2015 07:46, mireero a écrit :
On 06/10/2015 10:50 PM, Christophe Gallaire wrote:
Bonsoir à tous,

J'ai installé récemment Debian 8. Toutes les clés USB sont montées avec
pour propriétaire "root". Je ne m'explique pas pourquoi. Pour contourner
le problème d'écriture, j'ai modifié le fichier
/etc/usbmount/usbmount.conf comme suit :

FS_MOUNTOPTIONS="-fstype=vfat,gid=plugdev,fmask02,dmask02"

Reste qu'au démontage, je dois renseigner mon mot de passe "root".

Quelqu'un a-t-il des lumières sur ce problème ?

D'avance, merci.

Christophe




Tu peux ajouter l'option 'user' (ou même plutôt 'users') à tes options
de montage, et uid=`id -u`.

Ceci dans la ligne de commande de "montage", ou dans usbmount.conf (je
connais pas ce fichier, en tout cas je l'ai pas ici), ou plus
classiquement dans fstab.




Je vais ajouter ces deux options. Reste tout de même une question : d'où
vient ce problème de montage/démontage de clés USB que je n'ai jamais
rencontré ?

Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jean-Jacques Doti
Le #26356188
Le 11/06/2015 08:34, Christophe Gallaire a écrit :
Le 11/06/2015 07:46, mireero a écrit :
On 06/10/2015 10:50 PM, Christophe Gallaire wrote:
Bonsoir à tous,

J'ai installé récemment Debian 8. Toutes les clés USB sont montées avec
pour propriétaire "root". Je ne m'explique pas pourquoi. Pour contourner
le problème d'écriture, j'ai modifié le fichier
/etc/usbmount/usbmount.conf comme suit :

FS_MOUNTOPTIONS="-fstype=vfat,gid=plugdev,fmask02,dmask02"

Reste qu'au démontage, je dois renseigner mon mot de passe "root".

Quelqu'un a-t-il des lumières sur ce problème ?

D'avance, merci.

Christophe



Tu peux ajouter l'option 'user' (ou même plutôt 'users') à tes options
de montage, et uid=`id -u`.

Ceci dans la ligne de commande de "montage", ou dans usbmount.conf (je
connais pas ce fichier, en tout cas je l'ai pas ici), ou plus
classiquement dans fstab.



Je vais ajouter ces deux options. Reste tout de même une question : d'où
vient ce problème de montage/démontage de clés USB que je n'ai jamais
rencontré ?


Il faudrait un peu plus de détails pour savoir ce qu'il se passe…
Quoi qu'il en soit le coupable (même si c'est un bien grand mot) est le
paquet usbmount (qui fait juste son travail). Tu peux jeter un coup
d'œil à ce bug :
https://bugs.debian.org/cgi-bin/bugreport.cgi?bugg6554

En résumé :
- Regarde dans /etc/fstab s'il existe une ligne concernant /dev/sdb1 (à
monter sur /media/usb0). Si c'est le cas, on peut supprimer la ligne.
- Si tu utilises un environnement graphique comme Gnome, KDE, XFCE,
Cinnamon, … je pense que le paquet usbmount peut simplement être
supprimé. Les clés ou disques USB seront alors accessibles par
l'utilisateur de la session graphique.
- Tu peux aussi essayer d'installer le paquet pmount.

--
A+
Jean-Jacques


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Christophe Gallaire
Le #26356304
Le 11/06/2015 11:48, Jean-Jacques Doti a écrit :
Le 11/06/2015 08:34, Christophe Gallaire a écrit :
Le 11/06/2015 07:46, mireero a écrit :
On 06/10/2015 10:50 PM, Christophe Gallaire wrote:
Bonsoir à tous,

J'ai installé récemment Debian 8. Toutes les clés USB sont montées
avec
pour propriétaire "root". Je ne m'explique pas pourquoi. Pour
contourner
le problème d'écriture, j'ai modifié le fichier
/etc/usbmount/usbmount.conf comme suit :

FS_MOUNTOPTIONS="-fstype=vfat,gid=plugdev,fmask02,dmask02"

Reste qu'au démontage, je dois renseigner mon mot de passe "root".

Quelqu'un a-t-il des lumières sur ce problème ?

D'avance, merci.

Christophe



Tu peux ajouter l'option 'user' (ou même plutôt 'users') à tes options
de montage, et uid=`id -u`.

Ceci dans la ligne de commande de "montage", ou dans usbmount.conf (je
connais pas ce fichier, en tout cas je l'ai pas ici), ou plus
classiquement dans fstab.



Je vais ajouter ces deux options. Reste tout de même une question : d'où
vient ce problème de montage/démontage de clés USB que je n'ai jamais
rencontré ?


Il faudrait un peu plus de détails pour savoir ce qu'il se passe…
Quoi qu'il en soit le coupable (même si c'est un bien grand mot) est
le paquet usbmount (qui fait juste son travail). Tu peux jeter un coup
d'œil à ce bug :
https://bugs.debian.org/cgi-bin/bugreport.cgi?bugg6554

En résumé :
- Regarde dans /etc/fstab s'il existe une ligne concernant /dev/sdb1
(à monter sur /media/usb0). Si c'est le cas, on peut supprimer la ligne.
- Si tu utilises un environnement graphique comme Gnome, KDE, XFCE,
Cinnamon, … je pense que le paquet usbmount peut simplement être
supprimé. Les clés ou disques USB seront alors accessibles par
l'utilisateur de la session graphique.
- Tu peux aussi essayer d'installer le paquet pmount.




Le coupable était bien usbmount. Après suppression, tout est revenu à la
normale. La suppression de usbmount a entraîné la suppression de pmount.

@+

Merci !

Christophe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme