Problème PHP 5.5 sur Debian

Le
Julien Arlandis
Bonjour,

j'ai eu la mauvaise idée d'upgrader mon serveur Debian vers PHP 5.5 alors
que j'étais en 5.4, résultat plus rien ne marche.

Comment faire pour revenir en arrière ?

Quand je tente de supprimer ou de réinstaller mes paquets avec apt-get
j'obtiens des messages du type :

The following packages have unmet dependencies:
php5-cli : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-curl : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-gd : Depends: php5-common (= 5.4.45-0+deb7u3) but 5.5.36-1~dotdeb+7.1
is to be installed
php5-imap : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-mcrypt : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-mysql : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed


Merci pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yamo'
Le #26400543
Le 03/06/2016 à 15:43, Julien Arlandis a écrit :
Bonjour,
j'ai eu la mauvaise idée d'upgrader mon serveur Debian vers PHP 5.5 alors
que j'étais en 5.4, résultat plus rien ne marche.
Comment faire pour revenir en arrière ?
Quand je tente de supprimer ou de réinstaller mes paquets avec apt-get
j'obtiens des messages du type :
The following packages have unmet dependencies:
php5-cli : Depends: php5-common (= 5.4.45-0+deb7u3) but 5.5.36-1~dotdeb+7.1
is to be installed
php5-curl : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-gd : Depends: php5-common (= 5.4.45-0+deb7u3) but 5.5.36-1~dotdeb+7.1
is to be installed
php5-imap : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-mcrypt : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-mysql : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
Merci pour votre aide.


Il faut faire des apt-get dist-upgrade et après installer les paquets
supplémentaires.
yamo'
Le #26400542
Le 03/06/2016 à 15:43, Julien Arlandis a écrit :
Bonjour,
j'ai eu la mauvaise idée d'upgrader mon serveur Debian vers PHP 5.5 alors
que j'étais en 5.4, résultat plus rien ne marche.
Comment faire pour revenir en arrière ?
Quand je tente de supprimer ou de réinstaller mes paquets avec apt-get
j'obtiens des messages du type :
The following packages have unmet dependencies:
php5-cli : Depends: php5-common (= 5.4.45-0+deb7u3) but 5.5.36-1~dotdeb+7.1
is to be installed
php5-curl : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-gd : Depends: php5-common (= 5.4.45-0+deb7u3) but 5.5.36-1~dotdeb+7.1
is to be installed
php5-imap : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-mcrypt : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
php5-mysql : Depends: php5-common (= 5.4.45-0+deb7u3) but
5.5.36-1~dotdeb+7.1 is to be installed
Merci pour votre aide.


Il faut faire un apt-get dist-upgrade et après installer les paquets
supplémentaires.
Publicité
Poster une réponse
Anonyme