Probleme de reference non trouvee par le compilateur

Le
Christophe Kessler
Bonjour,
Je suis au bord de la depression, ma logique etant serieusement mise a
mal :
Dans un user control, je fais Reference a un 2nd control (<%@ Reference
Control="xxx.ascx" %>), dont j'utilise les methodes (definies dans le
xxx.ascx.cs ). Dans la theorie, pas de probleme. L'intellisense
fonctionne, me donnant acces a toutes les methodes de ma classe.
Dans la pratique, le compilateur me renvoit un joli message m'indiquant
que la dite classe n'existe pas :
Error 1 The type or namespace name 'ABC_xxx' could not be found (are you
missing a using directive or an assembly reference?)

Quelqu'un aurait une idee autre que celle de jeter mon pc par la fenetre ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles TOURREAU
Le #12150721
Le Wed, 17 Oct 2007 16:10:33 +0200, Christophe Kessler

Bonjour,
Je suis au bord de la depression, ma logique etant serieusement mise a
mal :
Dans un user control, je fais Reference a un 2nd control (<%@ Reference
Control="xxx.ascx" %>), dont j'utilise les methodes (definies dans le
xxx.ascx.cs ). Dans la theorie, pas de probleme. L'intellisense
fonctionne, me donnant acces a toutes les methodes de ma classe.
Dans la pratique, le compilateur me renvoit un joli message m'indiquant
que la dite classe n'existe pas :
Error 1 The type or namespace name 'ABC_xxx' could not be found (are you
missing a using directive or an assembly reference?)

Quelqu'un aurait une idee autre que celle de jeter mon pc par la fenetre
?



Avez-vous fait un " dans votre UserControl contenant la ligne :
<%@ Reference.... ?

Cordialement

--
Gilles TOURREAU


S.A.R.L. P.O.S
Le spécialiste en motoculture depuis + de 30 ans !
http://www.pos.fr
Publicité
Poster une réponse
Anonyme