probleme avec requete windev

Le
ElkaSoft
bonjour chers amis; chui confronté a un problème depuis kelkes jours
ke jarrive pas a régler ..
je bosse sur une application windev 10 generee par le RAD et pour
laquelle jai du apporter kelkes elements nouveaux dont notamment une
requête nommée : REQ_caj' ; au final jai tente de recuperer et
d'afficher le resultat de cette requete a travers une table
Table_REQ_caj lié a la requete ! dans un premier temps tt marche pour
le mieux mais a partir du second essai je n'ai systematiquement qu'une
erreur du type ci dessous :

Erreur :Identificateur 'Fiche_Simple_REQ_caj' inconnu ou inaccessible
ici : pour accéder à un élément hors portée, utilisez une déclar=
ation
EXTERNE.
Table_REQ_caj.Nouveau, Clic sur Table_REQ_caj.Nouveau, ligne 3,
colonne 7

pourtant jaibien inclus la requete REQ_caj' et ma table Table_REQ_caj
dans le projet !!!
svp pour ceux ki peuvent m'eclairer ou me donner kelkes pistes ce
serait cool ! sinon y a til d'autres moyens de recuperer et d'afficher
les resultats d'une requete windev ds une application ?
je suis disposé a vous apporter tt les eclaircissements necessaires je
suis k'un debutant sous windev
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #14507701
Le Tue, 03 Jun 2008 13:00:43 +0200, ElkaSoft
bonjour chers amis; chui confronté a un problème depuis kelkes jours
ke jarrive pas a régler ........
je bosse sur une application windev 10 generee par le RAD et pour
laquelle jai du apporter kelkes elements nouveaux dont notamment une
requête nommée : REQ_caj' ; au final jai tente de recuperer et
d'afficher le resultat de cette requete a travers une table
Table_REQ_caj lié a la requete ! dans un premier temps tt marche pour
le mieux mais a partir du second essai je n'ai systematiquement qu'une
erreur du type ci dessous :

Erreur :Identificateur 'Fiche_Simple_REQ_caj' inconnu ou inaccessible
ici : pour accéder à un élément hors portée, utilisez une déclaration
EXTERNE.
Table_REQ_caj.Nouveau, Clic sur Table_REQ_caj.Nouveau, ligne 3,
colonne 7

pourtant jaibien inclus la requete REQ_caj' et ma table Table_REQ_caj
dans le projet !!!
svp pour ceux ki peuvent m'eclairer ou me donner kelkes pistes ce
serait cool ! sinon y a til d'autres moyens de recuperer et d'afficher
les resultats d'une requete windev ds une application ?
je suis disposé a vous apporter tt les eclaircissements necessaires je
suis k'un debutant sous windev



Bonjour,

Pas assez d'informations. Si cela marche une fois mais pas une seconde ,
on peut penser que la requête se plante
et qu'il n'y a pas de test d'erreur.

Sur les newsgroups il est permis d'écrire en français complet , le SMS
n'est en aucune façon obligatoire.


JB
ElkaSoft
Le #14507691
On 3 juin, 14:15, JB
Le Tue, 03 Jun 2008 13:00:43 +0200, ElkaSoft


> bonjour chers amis; chui confronté a un problème depuis kelkes jours
> ke jarrive pas a régler ........
> je bosse sur une application windev 10 generee par le RAD et pour
> laquelle jai du apporter kelkes elements nouveaux dont notamment une
> requête nommée : REQ_caj' ; au final jai tente de recuperer et
> d'afficher le resultat de cette requete a travers une table
> Table_REQ_caj lié a la requete ! dans un premier temps tt marche pour
> le mieux mais a partir du second essai je n'ai systematiquement qu'une
> erreur du type ci dessous :

> Erreur :Identificateur 'Fiche_Simple_REQ_caj' inconnu ou inaccessible
> ici : pour accéder à un élément hors portée, utilisez une dé claration
> EXTERNE.
> Table_REQ_caj.Nouveau, Clic sur Table_REQ_caj.Nouveau, ligne 3,
> colonne 7

> pourtant jaibien inclus la requete REQ_caj' et ma table Table_REQ_caj
> dans le projet !!!
> svp pour ceux ki peuvent m'eclairer ou me donner kelkes pistes ce
> serait cool ! sinon y a til d'autres moyens de recuperer et d'afficher
> les resultats d'une requete windev ds une application ?
> je suis disposé a vous apporter tt les eclaircissements necessaires je
> suis k'un debutant sous windev

Bonjour,

Pas assez d'informations. Si cela marche une fois mais pas une seconde ,
on peut penser que la requête se plante
et qu'il n'y a pas de test d'erreur.

Sur les newsgroups il est permis d'écrire en français complet , le SMS
n'est en aucune façon obligatoire.

JB



lol

merci en tt cas pour ta contrib , tout ce que je peux dire c que
parfois il me sort une phrase dans le genre "le fichier ou la vue ou
la requete Req_caj n'est pas connu "
or en volulant crée la table liée a cette requette l'assistant me
propose bel et bien cette requet qui fait donc partie du projet
courant !
jai aussi remarqué que la table : table_req_caj liée a la requete
marche quand je teste juste la table ; mais des que je cherche a
l'appeler a travers l'un des menus de l'application par la syntaxe :
ouvre(tab_req_caj) là les erreurs commencent par se presenter ,
pourtant là aussi la table m'est ^pourtant proposée par l'assistant !
autre chose contrairement aux autres fenetres generees par le RAD ma
requete et la table qui lui est liée sont "isolées" et n'ont aucun
lien avec les elements du projet tel que le genere le RAD ! javoue que
ces pas evident d'expliquer comme cela , mais si kelkun a une p'tite
idée ce serait sympa !!! merci pr vos conseils et votre aide !
mat
Le #14507451
ElkaSoft wrote:
jai aussi remarqué que la table : table_req_caj liée a la requete
marche quand je teste juste la table ; mais des que je cherche a
l'appeler a travers l'un des menus de l'application par la syntaxe :
ouvre(tab_req_caj) là les erreurs commencent par se presenter ,




Bonjour,

si je comprends bien la situation, ce problème n'est pas trop étonnant.
La commande ouvre s'applique aux fenêtres et pas aux tables....

Salutations

Mat
Publicité
Poster une réponse
Anonyme