Problème réseau

Le
Sani
--0-912991499-1267209093=:23374
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour à tous,
 
Je suis nouveau sous GNU/Linux Debian. Je viens d'installer Lenny en versio=
n stable - amd64 sur mon portable (dual bool avec Windows 7). J'ai un autre=
ordinateur sur lequel Windows XP est installé avec le partage de connexi=
on Internet activé.
 
Quand je démarre mon portable sous Windows 7, je n'ai aucun problème. J=
'accède au réseau et à Internet. Par contre, sous Debian, c'est beauc=
oup plus difficile. En fait, l'ordinateur ne reçoit pas d'adresse IP. Il =
ne découvre pas l'ordinateur XP qui fait office de serveur DHCP.
 
J'ai regardé dans la documentation. J'ai renseigné le fichier /etc/netw=
ork/interfaces comme suit :
auto eth0
iface eth0 inet dhcp
 
J'ai installé également le paquet resolvconf (quelque chose dans le gen=
re) qui résout apparemment les problèmes de DNS (si j'ai bien compris).
 
Comme cela ne fonctionnait toujours pas, j'ai renseigné le fichier /etc/n=
etwork/interfaces avec une adresse ip statique pour au moins "pinger" la ma=
chine XP. J'ai peut-être fait une erreur :
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
broadcast 192.168.0.255
network 192.168.0.0
gateway 192.168.0.1
 
J'ai ensuite désactivé le pare-feu de Windows XP pour être sûr que =
le protocole ICMP passe. Et rien à faire. Je n'arrive pas à "pinger" XP=
depuis Debian, ni Debian depuis XP en entrant directement les adresses IP.
 
Je m'excuse si je ne suis pas assez clair. I need help !!!
 
P.S.: Avec un CD-Live d'Ubuntu, cela fonctionne.
 
Merci beaucoup à tous.
 
Nicolas
--0-912991499-1267209093=:23374
Content-Type: text/html; charset=iso-8859-1
Content-Transfer-Encoding: quoted-printable

<table cellspacing="0" cellpadding="0" border="0" ><tr><td valign="=
top" style="font: inherit;"><DIV>Bonjour à tous,</DIV>
<DIV>&nbsp;</DIV>
<DIV>Je suis nouveau sous GNU/Linux Debian. Je viens d'installer Lenny en v=
ersion stable - amd64 sur mon portable (dual bool avec Windows 7). J'ai un =
autre ordinateur sur lequel Windows XP est installé avec le partage de co=
nnexion Internet activé.</DIV>
<DIV>&nbsp;</DIV>
<DIV>Quand je démarre mon portable sous Windows 7, je n'ai aucun problè=
me. J'accède au réseau et à Internet. Par contre, sous Debian, c'est =
beaucoup plus difficile. En fait, l'ordinateur ne reçoit pas d'adresse IP=
. Il ne découvre pas l'ordinateur XP qui fait office de serveur DHCP.</DI=
V>
<DIV>&nbsp;</DIV>
<DIV>J'ai regardé dans la documentation. J'ai renseigné le fichier /etc=
/network/interfaces comme suit :</DIV>
<DIV>auto eth0</DIV>
<DIV>iface eth0 inet dhcp</DIV>
<DIV>&nbsp;</DIV>
<DIV>J'ai installé également le paquet resolvconf (quelque chose dans l=
e genre) qui résout apparemment les problèmes de DNS (si j'ai bien comp=
ris).</DIV>
<DIV>&nbsp;</DIV>
<DIV>Comme cela ne fonctionnait toujours pas, j'ai renseigné le fichier /=
etc/network/interfaces avec une adresse ip statique pour au moins "pinger" =
la machine XP. J'ai peut-être fait une erreur :</DIV>
<DIV>auto eth0</DIV>
<DIV>iface eth0 inet static</DIV>
<DIV>address 192.168.0.2</DIV>
<DIV>netmask 255.255.255.0</DIV>
<DIV>broadcast 192.168.0.255</DIV>
<DIV>network 192.168.0.0</DIV>
<DIV>gateway 192.168.0.1</DIV>
<DIV>&nbsp;</DIV>
<DIV>J'ai ensuite désactivé le pare-feu de Windows XP pour être sûr=
que le protocole ICMP passe. Et rien à faire. Je n'arrive pas à "pinge=
r" XP depuis Debian, ni Debian depuis XP en entrant directement les adresse=
s IP.</DIV>
<DIV>&nbsp;</DIV>
<DIV>Je m'excuse si je ne suis pas assez clair. I need help !!!</DIV>
<DIV>&nbsp;</DIV>
<DIV>P.S.: Avec un CD-Live d'Ubuntu, cela fonctionne.</DIV>
<DIV>&nbsp;</DIV>
<DIV>Merci beaucoup à tous.</DIV>
<DIV>&nbsp;</DIV>
<DIV>Nicolas</DIV></td></tr></table><br>
--0-912991499-1267209093=:23374--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/216831.23374.qm@web23507.mail.ird.yahoo.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guillaume
Le #21274411
Sani a écrit :
Bonjour à tous,

Je suis nouveau sous GNU/Linux Debian. Je viens d'installer Lenny en version stable - amd64 sur mon portable (dual bool avec Windows 7). J'ai un autre ordinateur sur lequel Windows XP est installé avec le partage de connexion Internet activé.

Quand je démarre mon portable sous Windows 7, je n'ai aucun problème. J'accède au réseau et à Internet. Par contre, sous Debian, c'est beaucoup plus difficile. En fait, l'ordinateur ne reçoit pas d'adresse IP. Il ne découvre pas l'ordinateur XP qui fait office de serveur DHCP.

J'ai regardé dans la documentation. J'ai renseigné le fichier /etc/network/interfaces comme suit :
auto eth0
iface eth0 inet dhcp

J'ai installé également le paquet resolvconf (quelque chose dans le genre) qui résout apparemment les problèmes de DNS (si j'ai bien compris).

Comme cela ne fonctionnait toujours pas, j'ai renseigné le fichier /etc/network/interfaces avec une adresse ip statique pour au moins "pinger" la machine XP. J'ai peut-être fait une erreur :
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
broadcast 192.168.0.255
network 192.168.0.0
gateway 192.168.0.1

J'ai ensuite désactivé le pare-feu de Windows XP pour être sûr que le protocole ICMP passe. Et rien à faire. Je n'arrive pas à "pinger" XP depuis Debian, ni Debian depuis XP en entrant directement les adresses IP.

Je m'excuse si je ne suis pas assez clair. I need help !!!

P.S.: Avec un CD-Live d'Ubuntu, cela fonctionne.

Merci beaucoup à tous.

Nicolas






Quelle est l'adresse IP de la machine XP ?
Quelle est l'adresse IP de la BOX ?
Que donne un ifconfig (quand configuration en statique de l'adresse IP) ?

Il faut penser à renseigner les adresses IP des serveurs DNS (dans le
/etc/resolv.conf et/ou dans le /etc/network/interfaces).

GL

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Cornichon
Le #21274591
Le 26/02/2010 19:31, Sani a écrit :
Bonjour à tous,
Je suis nouveau sous GNU/Linux Debian. Je viens d'installer Lenny en
version stable - amd64 sur mon portable (dual bool avec Windows 7). J'ai
un autre ordinateur sur lequel Windows XP est installé avec le partage
de connexion Internet activé.
Quand je démarre mon portable sous Windows 7, je n'ai aucun problème.
J'accède au réseau et à Internet. Par contre, sous Debian, c'est
beaucoup plus difficile. En fait, l'ordinateur ne reçoit pas d'adresse
IP. Il ne découvre pas l'ordinateur XP qui fait office de serveur DHCP.
J'ai regardé dans la documentation. J'ai renseigné le fichier
/etc/network/interfaces comme suit :
auto eth0
iface eth0 inet dhcp
J'ai installé également le paquet resolvconf (quelque chose dans le
genre) qui résout apparemment les problèmes de DNS (si j'ai bien compris).
Comme cela ne fonctionnait toujours pas, j'ai renseigné le fichier
/etc/network/interfaces avec une adresse ip statique pour au moins
"pinger" la machine XP. J'ai peut-être fait une erreur :
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
broadcast 192.168.0.255
network 192.168.0.0
gateway 192.168.0.1
J'ai ensuite désactivé le pare-feu de Windows XP pour être sûr que le
protocole ICMP passe. Et rien à faire. Je n'arrive pas à "pinger" XP
depuis Debian, ni Debian depuis XP en entrant directement les adresses IP.
Je m'excuse si je ne suis pas assez clair. I need help !!!
P.S.: Avec un CD-Live d'Ubuntu, cela fonctionne.
Merci beaucoup à tous.
Nicolas





Salut, et bienvenue chez nous.

Tu devrais disposer du paquet dhclient sur ton portable. Il s'agit d'un
client dhcp.
Donc un : dhclient eth0
devrait fonctionner.

Si tu ne veux pas utiliser DHCP tu auras besoin de:
des info sur les interfaces: ifconfig
Pour attribuer une IP à une interface : ifconfig eth0 192.168.0.2
netmask 255.255.255.0
Pour la passerelle :
route add default gw 192.168.0.1
(man route, man ifconfig, etc pour plus d'info).


Je présume que tu vas vouloir utiliser DHCP, donc d'une manière générale
(sauf pour les machines à IP fixe), je te suggère de ne rien mettre dans
ton /etc/network/interfaces (juste la déclaration du loopback (lo)).
Ensuite, tu lances ton dhclient selon tes besoins.

Si tu as installés gnome/kde ou autres, ils existent des paquets comme
network-manager sous gnome qui s'occupe de gérer ça pour toi.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Papinux
Le #21276751
Le Fri, 26 Feb 2010 18:31:33 +0000 (GMT), Sani a écrit :

Bonjour à tous,
 
Je suis nouveau sous GNU/Linux Debian. Je viens d'installer Lenny en vers ion stable - amd64 sur mon portable (dual bool avec Windows 7). J'ai un aut re ordinateur sur lequel Windows XP est installé avec le partage de conne xion Internet activé.
 
Quand je démarre mon portable sous Windows 7, je n'ai aucun problème. J'accède au réseau et à Internet. Par contre, sous Debian, c'est bea ucoup plus difficile. En fait, l'ordinateur ne reçoit pas d'adresse IP. I l ne découvre pas l'ordinateur XP qui fait office de serveur DHCP.
 
J'ai regardé dans la documentation. J'ai renseigné le fichier /etc/ne twork/interfaces comme suit :
auto eth0
iface eth0 inet dhcp
 
J'ai installé également le paquet resolvconf (quelque chose dans le g enre) qui résout apparemment les problèmes de DNS (si j'ai bien compris ).
 
Comme cela ne fonctionnait toujours pas, j'ai renseigné le fichier /etc /network/interfaces avec une adresse ip statique pour au moins "pinger" la machine XP. J'ai peut-être fait une erreur :
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
broadcast 192.168.0.255
network 192.168.0.0
gateway 192.168.0.1



Salut,

Es-tu sûr que ta carte réseau (wifi ou filaire?) est bien reconnue par
l'OS?
Il y a souvent des pb sur les portables très récents, auquel cas il
faut installer un noyau très récent (c'est sans doute pour cela que
ça marche avec un Ubuntu 9.10)

Il faudrait nous donner un peu plus de détail:
- résultat de la commande ifconfig -a
- utilises-tu KDE ou GNOME? network-manager?

@+

--
Px

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme