Problème script dans règle udev et zenity

Le
fenark
Bonjour,

Voilà j'ai un script que je veux executer à partir d'une règle udev. Ce
script utilise zenity. Le script exécuté manuellement fonctionne
parfaitement. Lorsqu'il s'agit de le lancer à partir d'une règle udev,
le script ne fonctionne pas. J'ai validé mes règles udev à l'aide d'un
script minimum sans zenity, et fonctionne parfaitement.

Quelqu'un aurait une idée s'il vous plait ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yannick Fouquet
Le #19834811
Bonjour,

a écrit :
Voilà j'ai un script que je veux executer à partir d'une règle udev. Ce
script utilise zenity. Le script exécuté manuellement fonctionne
parfaitement. Lorsqu'il s'agit de le lancer à partir d'une règle udev,
le script ne fonctionne pas. J'ai validé mes règles udev à l'aide d'un
script minimum sans zenity, et fonctionne parfaitement.

Quelqu'un aurait une idée s'il vous plait ?



J'ai eu un problème qui me semble similaire.
J'ai élaboré un script utilisant zenity. Il marchait lorsqu'exécuté
manuellement mais ne semblait pas fonctionner lorsque lancé par cron.
En fait, il fonctionnait mais pas l'affichage de zenity notification.
Apparemment c'étaient les accents de l'affichage de zenity. Depuis, j'ai
viré tous les accents et ça marche.
Tu peux essayer de voir de ce côté là.

Hope this helps.
@+
Yannick.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
fenark
Le #19834921
Yannick Fouquet a écrit :
Bonjour,

J'ai eu un problème qui me semble similaire.
J'ai élaboré un script utilisant zenity. Il marchait lorsqu'exécuté
manuellement mais ne semblait pas fonctionner lorsque lancé par cron.
En fait, il fonctionnait mais pas l'affichage de zenity notification.
Apparemment c'étaient les accents de l'affichage de zenity. Depuis,
j'ai viré tous les accents et ça marche.
Tu peux essayer de voir de ce côté là.

Hope this helps.
@+
Yannick.





Même résultat, mon script s'éxécute, mais pas de fenêtre zenity.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme