Problème sur SommeProd

Le
ttcpp
Bonjour

Dans un tableau récap, j'ai besoin d'additionner 1 colonne sur 3 (sur une
plage qui en comporte plus d'une vingtaine) suivant 2 critères. J'ai essayé
une sommeprod, mais je n'arrive pas afficher le résultat escompté. Sje fais
une sommeprod classique, je n'ai pas assez de place pour écrire toutes mes
formules.
voilà ce que j'ai essayé
=SOMMEPROD(($B$2:$B$6="x")*($C$2:$C$6="z")*SOMMEPROD(($D$2:$P$6*(MOD(COLONNE($D$2:$P$6);3)=0))))
Est-ce qu'il y a une astuce pour remedier à mon probléme ?

Merci d'avance

Thierry
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21471531
Bonjour.
Un exemple qui sélectionne les colonnes A, D, G etc. :
=SOMMEPROD((MOD(COLONNE(A1:M1);3)=1)*(A2:M2=critère1)*(A3:M3=critère2)*A4:M4)
Cordialement.
Daniel

Bonjour

Dans un tableau récap, j'ai besoin d'additionner 1 colonne sur 3 (sur une
plage qui en comporte plus d'une vingtaine) suivant 2 critères. J'ai essayé
une sommeprod, mais je n'arrive pas afficher le résultat escompté. Sje fais
une sommeprod classique, je n'ai pas assez de place pour écrire toutes mes
formules.
voilà ce que j'ai essayé :
=SOMMEPROD(($B$2:$B$6="x")*($C$2:$C$6="z")*SOMMEPROD(($D$2:$P$6*(MOD(COLONNE($D$2:$P$6);3)=0))))
Est-ce qu'il y a une astuce pour remedier à mon probléme ?

Merci d'avance

Thierry
Modeste
Le #21471621
Bonsour®

"ttcpp"
Dans un tableau récap, j'ai besoin d'additionner 1 colonne sur 3 (sur une
plage qui en comporte plus d'une vingtaine) suivant 2 critères. J'ai
essayé
une sommeprod, mais je n'arrive pas afficher le résultat escompté. Sje
fais
une sommeprod classique, je n'ai pas assez de place pour écrire toutes mes
formules.
voilà ce que j'ai essayé :
=SOMMEPROD(($B$2:$B$6="x")*($C$2:$C$6="z")*SOMMEPROD(($D$2:$P$6*(MOD(COLONNE($D$2:$P$6);3)=0))))
Est-ce qu'il y a une astuce pour remedier à mon probléme ?



;o)) des astuces ...
- les plages utilisées dans la fonction sommeprod doivent etre de dimensions
identiques !!!!
- pour gagner de la place en terme de caractères : nommer les plages
exemple : =SOMMEPROD((ZoneB="x")*(ZoneC="z"))
- scinder le probleme pour identifier la partie de formule qui ne fonctionne
pas
exemple : =SOMMEPROD((ZoneDP*(MOD(COLONNE(ZoneDP);3)=0)))
- revoir le fonctionnement des fonctions matricielles :
http://xcell05.free.fr/pages/form/form_mat_2.htm
http://xcell05.free.fr/pages/form/form_mat.htm
Jacquouille
Le #21471781
"Modeste"
Bonsour®
;o)) des astuces ...
- les plages utilisées dans la fonction sommeprod doivent etre de
dimensions identiques !!!!



ON NE LE DIRA JAMAIS ASSEZ ! -))

Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.
Sam
Le #21472151
Bonjour,
en m'inspirant des réponses des autres contributeurs, j'obtiens ceci qui a
l'air de fonctionner
{=SOMME((B2:B6="x")*(C2:C6="z")*(MOD(COLONNE(D2:P6);3)=1)*(D2:P6))}
(j'en suis tout étonné!)

autrement il y a aussi
{=SOMME((B2:B6="x")*(C2:C6="z")*D2:D6;(B2:B6="x")*(C2:C6="z")*G2:G6;(B2:B6="x")*(C2:C6="z")*J2:J6;(B2:B6="x")*(C2:C6="z")*M2:M6;(B2:B6="x")*(C2:C6="z")*P2:P6)}

Ces 2 formules sont à valider par Ctrl - Maj - Entrée
Cordialement
Michel dit "Sam"

"ttcpp"
Bonjour

Dans un tableau récap, j'ai besoin d'additionner 1 colonne sur 3 (sur une
plage qui en comporte plus d'une vingtaine) suivant 2 critères. J'ai
essayé
une sommeprod, mais je n'arrive pas afficher le résultat escompté. Sje
fais
une sommeprod classique, je n'ai pas assez de place pour écrire toutes mes
formules.
voilà ce que j'ai essayé :
=SOMMEPROD(($B$2:$B$6="x")*($C$2:$C$6="z")*SOMMEPROD(($D$2:$P$6*(MOD(COLONNE($D$2:$P$6);3)=0))))
Est-ce qu'il y a une astuce pour remedier à mon probléme ?

Merci d'avance

Thierry
ttcpp
Le #21472141
Merci à Daniel.C et Modeste, j'ai pris la solution de Daniel.C qui me donne
exactement ce que je souhaitais (il fallait juste que je mette mod() en
premier et non en dernier)

"Modeste" wrote:

Bonsour®

"ttcpp"
> Dans un tableau récap, j'ai besoin d'additionner 1 colonne sur 3 (sur une
> plage qui en comporte plus d'une vingtaine) suivant 2 critères. J'ai
> essayé
> une sommeprod, mais je n'arrive pas afficher le résultat escompté. Sje
> fais
> une sommeprod classique, je n'ai pas assez de place pour écrire toutes mes
> formules.
> voilà ce que j'ai essayé :
> =SOMMEPROD(($B$2:$B$6="x")*($C$2:$C$6="z")*SOMMEPROD(($D$2:$P$6*(MOD(COLONNE($D$2:$P$6);3)=0))))
> Est-ce qu'il y a une astuce pour remedier à mon probléme ?

;o)) des astuces ...
- les plages utilisées dans la fonction sommeprod doivent etre de dimensions
identiques !!!!
- pour gagner de la place en terme de caractères : nommer les plages
exemple : =SOMMEPROD((ZoneB="x")*(ZoneC="z"))
- scinder le probleme pour identifier la partie de formule qui ne fonctionne
pas
exemple : =SOMMEPROD((ZoneDP*(MOD(COLONNE(ZoneDP);3)=0)))
- revoir le fonctionnement des fonctions matricielles :
http://xcell05.free.fr/pages/form/form_mat_2.htm
http://xcell05.free.fr/pages/form/form_mat.htm





.

Publicité
Poster une réponse
Anonyme