Problème sur Sommeprod

Le
Alex
Bonjour à tous,

Je rencontre une difficulté "textuelle" pour un sommeprod et m'en expliqu=
e.

Dans le cadre de statistique, je dois faire un sommeprod nombre de dossier =
avec une condition "type de dossier".

Habituellement, ma condition est une valeur texte fixe (Ex : Nouveau Dossie=
r), donc pas de problème pour faire le sommeprod.

Aujourd'hui, on m'a demandé d'ajouter le libellé "AUTRES" qui peut êt=
re complété par la personne, avec un libellé de son choix, mais le "A=
UTRES" reste le 1er mot du libéllé.

Savez vous comment je peux faire un sommeprod pour qu'il me compte mes doss=
iers avec un libellé contenant "AUTRES" ?

Merci par avance de votre aide.

Bien cordialement.
Alex
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
GL
Le #26110712
Le 02/05/2014 09:58, Alex a écrit :
Bonjour à tous,

Je rencontre une difficulté "textuelle" pour un sommeprod et m'en explique.

Dans le cadre de statistique, je dois faire un sommeprod nombre de dossier avec une condition "type de dossier".

Habituellement, ma condition est une valeur texte fixe (Ex : Nouveau Dossier), donc pas de problème pour faire le sommeprod.

Aujourd'hui, on m'a demandé d'ajouter le libellé "AUTRES" qui peut être complété par la personne, avec un libellé de son choix, mais le "AUTRES" reste le 1er mot du libéllé.

Savez vous comment je peux faire un sommeprod pour qu'il me compte mes dossiers avec un libellé contenant "AUTRES" ?

Merci par avance de votre aide.

Bien cordialement.
Alex



Je ne comprend pas bien : c'est quoi un "dossier" dans ce contexte ?
Vous pourriez poster votre formule actuelle pour ensuite nous permettre
de l'adapter...

Cordialement.
Alex
Le #26110822
Bonjour,

merci pour votre réponse.

voici mon sommeprod :

=SOMMEPROD(($B$5:$B$199="AT")*($I$5:$I$199="Défenseur"))

A la place de Défenseur, cela sera AUTRES. Mais "AUTRES" n'est pas fixe, puisque les utilisateurs peuvent compléter le "AUTRES".

Je souhaiterais faire un sommeprod contenant "AUTRES", afin de les comptabi lier.

Merci encore de votre aide.
Cordialement.
Alex
MichD
Le #26110812
Bonjour,

Si j'ai bien compris la question :

A1:A2 : La plage de cellules où sont les noms des dossiers

Calcule le nombre de cellules où "Autres" apparaît dans une cellule
de la plage comme étant les 6 premières lettres du dossier.

=SOMMEPROD((GAUCHE(A1:A2;6)="Autres")*1)
Jacquouille
Le #26110932
Bonjour Denis
Et, si, au lieu de "Autres", on mettait la condition¡.
L'utilisateur inscrirait son mot à chercher dans A1.
Voire faire une liste de choix en A1....

=SOMMEPROD(($B$5:$B$199="AT")*($I$5:$I$199¡)) ... avec A1= xyz

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
ljvr50$sea$

Bonjour,

Si j'ai bien compris la question :

A1:A2 : La plage de cellules où sont les noms des dossiers

Calcule le nombre de cellules où "Autres" apparaît dans une cellule
de la plage comme étant les 6 premières lettres du dossier.

=SOMMEPROD((GAUCHE(A1:A2;6)="Autres")*1)


---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com
MichD
Le #26111082
En utilisant l'exemple du demandeur :

=SOMMEPROD(($B$5:$B$199="AT")*($I$5:$I$199="Défenseur"))

Dans la plage $I$5:$I$199 on pourrait avoir : "Autres toto", "Autres titi",
etc.
il s'agit de compter le nombre d'occurrences de l'expression "Autres" soit
seul ou jumelée avec autres.

Alors la formule du demandeur deviendrait :

=SOMMEPROD(($B$5:$B$199="AT")*(Gauche($I$5:$I$199;6)="Autres"))
Jacquouille
Le #26111382
En effet, c'est AUTRE chose ... -))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
ljvv5k$725$

En utilisant l'exemple du demandeur :

=SOMMEPROD(($B$5:$B$199="AT")*($I$5:$I$199="Défenseur"))

Dans la plage $I$5:$I$199 on pourrait avoir : "Autres toto", "Autres titi",
etc.
il s'agit de compter le nombre d'occurrences de l'expression "Autres" soit
seul ou jumelée avec autres.

Alors la formule du demandeur deviendrait :

=SOMMEPROD(($B$5:$B$199="AT")*(Gauche($I$5:$I$199;6)="Autres"))


---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com
GL
Le #26112572
Le 02/05/2014 13:22, MichD a écrit :
En utilisant l'exemple du demandeur :

=SOMMEPROD(($B$5:$B$199="AT")*($I$5:$I$199="Défenseur"))

Dans la plage $I$5:$I$199 on pourrait avoir : "Autres toto", "Autres
titi", etc.
il s'agit de compter le nombre d'occurrences de l'expression "Autres"
soit seul ou jumelée avec autres.

Alors la formule du demandeur deviendrait :

=SOMMEPROD(($B$5:$B$199="AT")*(Gauche($I$5:$I$199;6)="Autres"))





Ceci si le contenu de la cellule commence par "Autres".

Dans le cas où le mot "Autre" (sans considération de casse)
se trouve n'importe où dans la cellule située en colonne I on peut
écrire :

{=SOMMEPROD(($B$5:$B$199="AT")*(SIERREUR(0+(CHERCHE("Autre";$I$5:$I$199)>0);0)))}

Validation matricielle.
CHERCHE n'est pas sensible à la casse, au contraire de TROUVE...

Bon weekend.
GL
Le #26112562
Le 02/05/2014 13:22, MichD a écrit :
En utilisant l'exemple du demandeur :

=SOMMEPROD(($B$5:$B$199="AT")*($I$5:$I$199="Défenseur"))

Dans la plage $I$5:$I$199 on pourrait avoir : "Autres toto", "Autres
titi", etc.
il s'agit de compter le nombre d'occurrences de l'expression "Autres"
soit seul ou jumelée avec autres.

Alors la formule du demandeur deviendrait :

=SOMMEPROD(($B$5:$B$199="AT")*(Gauche($I$5:$I$199;6)="Autres"))




Retour sur mon précédent message :

{=SOMMEPROD(($B$5:$B$199="AT")*(SIERREUR(0+(CHERCHE("Autre";$I$5:$I$199)>0);0)))}


On peut utiliser NB.SI.ENS plus simplement :

=NB.SI.ENS($B$5:$B$199;"AT";$I$5:$I$199;"*autre*")

On peut effectivement utiliser les caractères génériques dans NB.SI.ENS.
Ca me semble plus lisible...
GL
Le #26112582
Le 02/05/2014 12:07, Alex a écrit :
Bonjour,

merci pour votre réponse.

voici mon sommeprod :

=SOMMEPROD(($B$5:$B$199="AT")*($I$5:$I$199="Défenseur"))

A la place de Défenseur, cela sera AUTRES. Mais "AUTRES" n'est pas fixe, puisque les utilisateurs peuvent compléter le "AUTRES".

Je souhaiterais faire un sommeprod contenant "AUTRES", afin de les comptabilier.



Pour comptabiliser, plus simple d'utiliser NB.SI.ENS :

=NB.SI.ENS($B$5:$B$199;"AT";$I$5:$I$199;"Autre*")

"Autre*" signifie : commence par "Autre" (non sensible à la casse)

Bon weekend.
Alex
Le #26114392
Bonjour à tous,

Merci pour vos nombreuses solutions, cela m'a permis de solutionner mon pro blème.
Un grand merci.
Cordialement.
Alex
Publicité
Poster une réponse
Anonyme