Problème suite restauration

Le
Stephane (85)
Bonjour à tous

Voilà suite à un problème disque et parce que j'ai suivi les conseils
"de merde" du petit monsieur de chez HP, je me retrouver avec une erreur
2103 NTDS General : La restauration de la base de données Active
Directory s'est effectuée suivant une procé dure non prise en charge.
En fait il a fallu que je recréé le RAID et restaure avec BESR.
Notre archi est assez simple, on a 3 DC, un sur un site distant sous
2000, un qui fait aussi TSE, et le 3° qui a aussi tous les rôles. C'est
avec le 3° bien évidement que j'ai le probklème.
Apparement d'après le ternet je dois désinstaller l'AD, virer toutes
traces du serveur et le repromouvoir.

Par contre j'ai jamais fait ca et je suis pas spécialement à l'aise.
Y'en a t'ils qui ont déjà fait cà ici ?

Merci
Stephane - Je prends tous les conseils !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jonathan BISMUTH
Le #12839831
Bonjour Stéphane,

effectivement, la procédure TechNet est la meilleure, particulièrement dans
la mesure où tu as d'autres DC fonctionnels.
Je te rassure donc, tu peux être à l'aise avec ça, c'est relativement simple
:

- Débranche et formate ton ancien DC
- Récupère (seizing) les rôles sur l'un des serveurs fonctionnels :
http://support.microsoft.com/kb/255504
- Nettoie la base des metadonnées par ntdsutil :
http://support.microsoft.com/kb/216498/
- Vérifie qu'il n'en reste pas de trace dans DNS
- tu peux ensuite réinstaller ton serveur en DC3 (fais le bien sur pointer
sur le DNS de l'un des autres DC)

Au cas où, tu retrouve ça dans ma FAQ (Q2) :
http://blog.portail-mcse.net/index.php?pages/La-FAQ-de-PMNet-sur-les-domaines-Active-Directory

Cordialement,
--
Jonathan BISMUTH
MVP Windows Server - Directory Services
MCSE 2000, Transcript (ID: 691839, code: MCSE2000)
http://blog.portail-mcse.net
--
"Stephane (85)"
Bonjour à tous

Voilà suite à un problème disque et parce que j'ai suivi les conseils "de
merde" du petit monsieur de chez HP, je me retrouver avec une erreur 2103
NTDS General : La restauration de la base de données Active Directory
s'est effectuée suivant une procé dure non prise en charge.
En fait il a fallu que je recréé le RAID et restaure avec BESR.
Notre archi est assez simple, on a 3 DC, un sur un site distant sous 2000,
un qui fait aussi TSE, et le 3° qui a aussi tous les rôles. C'est avec le
3° bien évidement que j'ai le probklème.
Apparement d'après le ternet je dois désinstaller l'AD, virer toutes
traces du serveur et le repromouvoir.

Par contre j'ai jamais fait ca et je suis pas spécialement à l'aise.
Y'en a t'ils qui ont déjà fait cà ici ?

Merci
Stephane - Je prends tous les conseils !


Stephane (85)
Le #12841811
Jonathan BISMUTH a écrit :
Bonjour Stéphane,

effectivement, la procédure TechNet est la meilleure, particulièrement dans
la mesure où tu as d'autres DC fonctionnels.
Je te rassure donc, tu peux être à l'aise avec ça, c'est relativement simple
:

- Débranche et formate ton ancien DC
- Récupère (seizing) les rôles sur l'un des serveurs fonctionnels :
http://support.microsoft.com/kb/255504
- Nettoie la base des metadonnées par ntdsutil :
http://support.microsoft.com/kb/216498/
- Vérifie qu'il n'en reste pas de trace dans DNS
- tu peux ensuite réinstaller ton serveur en DC3 (fais le bien sur pointer
sur le DNS de l'un des autres DC)

Au cas où, tu retrouve ça dans ma FAQ (Q2) :
http://blog.portail-mcse.net/index.php?pages/La-FAQ-de-PMNet-sur-les-domaines-Active-Directory

Cordialement,




Bonjour Jonathan

Ce qui me gène dans ta procédure c'est le formatage, ce qui bien
évidement implique de tout réinstaller et alors on se demande à quoi ca
peut bien servir d'investir dans des logiciels de sauvegarde à 1000
brouzoufs qui sont soit disant magic et au final ca sert à rien.
Toutefois avant de faire tout ca je suis en train de me battre avec
Symantec et la SSII avec laquelle on bosse, dès fois que...

Je m'en vais parcourir tous les liens que tu as indiqués.

Merci
Stephane
Lognoul, Marc \(Private\)
Le #12843181
Bonjour,

Si vous ne désirez pas passer par le formatage complet qui est selon moi
l'option la plus clean (et j'adhère complètement aux conseils), vous pouvez
tester cette procédure au préalable:
http://support.microsoft.com/kb/332199/fr, sans garantie de résultat
positifs dans votre cas de figure.

En ce qui concerne la question de fond sur les techniques de backup/restore
d'AD, serveur, BESR etc, je me pose les questions suivantes:
Qu'est-ce qui vous a forcé à restaurer votre DC de cette manière? Les deux
disques étaient défectueux en même temps? Cela parait peu probable. En
général, et sur les serveur HP en particulier, le système peut vous tenir
informer des "predictive failure" qui permettent de prendre les actions à
temps et éviter ce type de réinstallation
Quelle procédure vous a été exactement recommandée par HP? Votre contact
était-il au courant que ce serveur était DC? Connaissait-il le
fonctionnement de BESR?
Aviez-vous déjà testé ce type de restauration avec BESR au préalable et
disposiez-vous d'une procédure adéquate? Bien que ce produit supporte la
restauration d'AD, cela se fait sous certaines conditions et avec la bonne
version. Soit, comme dit la sagesse populaire, une bonne procédure vaut
parfois mieux qu'un bon software :)

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]




"Stephane (85)" news:
Jonathan BISMUTH a écrit :
Bonjour Stéphane,

effectivement, la procédure TechNet est la meilleure, particulièrement
dans la mesure où tu as d'autres DC fonctionnels.
Je te rassure donc, tu peux être à l'aise avec ça, c'est relativement
simple :

- Débranche et formate ton ancien DC
- Récupère (seizing) les rôles sur l'un des serveurs fonctionnels :
http://support.microsoft.com/kb/255504
- Nettoie la base des metadonnées par ntdsutil :
http://support.microsoft.com/kb/216498/
- Vérifie qu'il n'en reste pas de trace dans DNS
- tu peux ensuite réinstaller ton serveur en DC3 (fais le bien sur
pointer sur le DNS de l'un des autres DC)

Au cas où, tu retrouve ça dans ma FAQ (Q2) :
http://blog.portail-mcse.net/index.php?pages/La-FAQ-de-PMNet-sur-les-domaines-Active-Directory

Cordialement,




Bonjour Jonathan

Ce qui me gène dans ta procédure c'est le formatage, ce qui bien évidement
implique de tout réinstaller et alors on se demande à quoi ca peut bien
servir d'investir dans des logiciels de sauvegarde à 1000 brouzoufs qui
sont soit disant magic et au final ca sert à rien.
Toutefois avant de faire tout ca je suis en train de me battre avec
Symantec et la SSII avec laquelle on bosse, dès fois que...

Je m'en vais parcourir tous les liens que tu as indiqués.

Merci
Stephane


Stephane (85)
Le #12844391
Lognoul, Marc (Private) a écrit :
Bonjour,

Si vous ne désirez pas passer par le formatage complet qui est selon moi
l'option la plus clean (et j'adhère complètement aux conseils), vous



Moi aussi je trouve ca plus clean, par contre après il va falloir que je
retransfère à nouveau tous les rôles sur ce serveur car il est fait pour
cà et par contre pas question de reformater le serveur qui aura eu les
rôles temporairement...

En ce qui concerne la question de fond sur les techniques de
backup/restore d'AD, serveur, BESR etc, je me pose les questions suivantes:
Qu'est-ce qui vous a forcé à restaurer votre DC de cette manière?



En fait le serveur est un DL140 G3 avec un controleur RAID intégré, la
carte mère a cramé elle a donc été changée. J'ai appelé HP pour savoir
comment reconstruire le RAID (pour avoir le bonne procédure :-)). Pour
eux la seule solution c'est de faire un ghost du serveur, recréer le
RAID et restaurer l'image ghost, pas super mais bon c'est un petit
serveur pas cher donc on va pas se plaindre. Comme j'utilise BESR je me
suis dit pas besoin de faire une image GHOST.
J'ai donc recréer le RAID et utiliser le BESR pour restaurer le serveur.
Tout s'est bien passé sauf que maintenant j'ai cette erreur.

était-il au courant que ce serveur était DC? Connaissait-il le
fonctionnement de BESR?



Non, j'ai pas du tout spécifié ca :-((

Aviez-vous déjà testé ce type de restauration avec BESR au préalable et
disposiez-vous d'une procédure adéquate?



Oui mais pas pour un serveur AD, effectivement.

Bien que ce produit supporte la


> restauration d'AD, cela se fait sous certaines conditions et avec la
bonne version. Soit, comme dit la sagesse populaire, une bonne procédure
vaut parfois mieux qu'un bon software :)



Oui tout à fait et j'espère sincèrement que j'ai loupé quelque chose
dans la procédure de restauration, plutôt que dans celle de sauvegarde.
Si t'es des infos ?

Merci
Stephane
Lognoul, Marc \(Private\)
Le #12847151
> Moi aussi je trouve ca plus clean, par contre après il va falloir que je
retransfère à nouveau tous les rôles sur ce serveur car il est fait pour
cà et par contre pas question de reformater le serveur qui aura eu les
rôles temporairement...


Il n'est pas du tout nécessaire de formater le serveur qui opérera les rôles
temporairement, soyez rassuré. Evidemment, ceci est conditionné par le fait
que le transfert vers le serveur final se fasse "proprement" (cad un
transfert et non un saisie

En fait le serveur est un DL140 G3 avec un controleur RAID intégré, la


Ce serveur est en effet équipé d'un contrôleur particulièrement basique
(SATA, rebuild offline...). Je me demande dans quelle mesure il n'est pas
possible de simplement reconnecter les deux disques originaux au nouveau
contrôleur et re-détecter l'array. Cela fonction avec d'autres modèles de
contrôleurs RAID SATA.

Si t'es des infos ?


Vous pouvez tjrs jeter un oil à la documentation en ligne fournie par
Symantec (http://seer.entsupport.symantec.com/docs/294260.htm) mais l'idéal
serait de passer par leur support pour leur adresser la question
directement.

Sauf support officiel du fabriquant de solution de backup, bannissez
systématiquement tout système de snapshot/imagerie/clonage sur les domain
controllers.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]
Stephane (85)
Le #12848141
Lognoul, Marc (Private) a écrit :
par le fait que le transfert vers le serveur final se fasse "proprement"
(cad un transfert et non un saisie



Ben oui c'est ca qui me chagrine..., est-ce possible de passer par un
serveur temporaire virtuel car j'ai un 2003 virtuel tout propre qui
n'attend que d'être utilisé ?

En fait le serveur est un DL140 G3 avec un controleur RAID intégré, la


Ce serveur est en effet équipé d'un contrôleur particulièrement basique
(SATA, rebuild offline...). Je me demande dans quelle mesure il n'est
pas possible de simplement reconnecter les deux disques originaux au
nouveau contrôleur et re-détecter l'array. Cela fonction avec d'autres
modèles de contrôleurs RAID SATA.



Moi aussi ça ma étonné mais il est vrai que la config du RAID est on ne
peut plus basique et limité. J'ai essayé tu penses bien de faire
redétecter le RAID, çà a marché sauf que 5s après le démarrage de 2003
serveur j'avais un beau BSOD :-((. J'ai réessayé et pareil donc là pas
le choix il me restait que la solution HP.

Si t'es des infos ?


Vous pouvez tjrs jeter un oil à la documentation en ligne fournie par
Symantec (http://seer.entsupport.symantec.com/docs/294260.htm) mais
l'idéal serait de passer par leur support pour leur adresser la question
directement.



C'est ce que je suis en train de faire mais c'est long alors pendant ce
temps je me renseigne un maximum pour éviter de rajouter une boulette :-))

Sauf support officiel du fabriquant de solution de backup, bannissez
systématiquement tout système de snapshot/imagerie/clonage sur les
domain controllers.



Ce qui est apparemment conseillé ce serait que je continue de faire un
clonage mais avec au préalable un ntbackup de l'état système. Et là ça
devrait aller. C'est la méthode conseillée pour windows 2000 server mais
je pense que je vais la faire pour 2003 même si selon la doc c'est
inutile...

Stephane - merci.com
Y.E.
Le #15348821
bonjour

je m'imitie dans la dsicussion, et je m'etonne effectivement que la
reconnexion des disques n'est pas focntionné.
aujourd'hui les Raids sont ecrit et sur les disque et sur les Carte pour
pouvoir changer en cas de panne. La seule explication au blue screen
provient de : soit la version de firmware employé sur les carte et disque
n'etait pas compatible, soit le drivers et l'ACU n'etait pas en bonne
version.

aviez vous essayer en mode sans echec ?

"Stephane (85)"
Lognoul, Marc (Private) a écrit :
par le fait que le transfert vers le serveur final se fasse "proprement"
(cad un transfert et non un saisie



Ben oui c'est ca qui me chagrine..., est-ce possible de passer par un
serveur temporaire virtuel car j'ai un 2003 virtuel tout propre qui
n'attend que d'être utilisé ?

En fait le serveur est un DL140 G3 avec un controleur RAID intégré, la


Ce serveur est en effet équipé d'un contrôleur particulièrement basique
(SATA, rebuild offline...). Je me demande dans quelle mesure il n'est pas
possible de simplement reconnecter les deux disques originaux au nouveau
contrôleur et re-détecter l'array. Cela fonction avec d'autres modèles de
contrôleurs RAID SATA.



Moi aussi ça ma étonné mais il est vrai que la config du RAID est on ne
peut plus basique et limité. J'ai essayé tu penses bien de faire
redétecter le RAID, çà a marché sauf que 5s après le démarrage de 2003
serveur j'avais un beau BSOD :-((. J'ai réessayé et pareil donc là pas le
choix il me restait que la solution HP.

Si t'es des infos ?


Vous pouvez tjrs jeter un oil à la documentation en ligne fournie par
Symantec (http://seer.entsupport.symantec.com/docs/294260.htm) mais
l'idéal serait de passer par leur support pour leur adresser la question
directement.



C'est ce que je suis en train de faire mais c'est long alors pendant ce
temps je me renseigne un maximum pour éviter de rajouter une boulette :-))

Sauf support officiel du fabriquant de solution de backup, bannissez
systématiquement tout système de snapshot/imagerie/clonage sur les domain
controllers.



Ce qui est apparemment conseillé ce serait que je continue de faire un
clonage mais avec au préalable un ntbackup de l'état système. Et là ça
devrait aller. C'est la méthode conseillée pour windows 2000 server mais
je pense que je vais la faire pour 2003 même si selon la doc c'est
inutile...

Stephane - merci.com


Stephane (85)
Le #15348801
Y.E. a écrit :
bonjour

je m'imitie dans la dsicussion, et je m'etonne effectivement que la
reconnexion des disques n'est pas focntionné.
aujourd'hui les Raids sont ecrit et sur les disque et sur les Carte pour
pouvoir changer en cas de panne. La seule explication au blue screen
provient de : soit la version de firmware employé sur les carte et disque
n'etait pas compatible, soit le drivers et l'ACU n'etait pas en bonne
version.

aviez vous essayer en mode sans echec ?



Ah non pas pensé à ca et comme le coco de chez HP m'avait dit que la
seule solution c'était de tout refaire j'ai pas insisté, j'aurais
peut-être dû...

Stephane
Stephane (85)
Le #16337061
Bonjour à tous

Juste un petit mail pour vous remercier. Tout est rétabli et
fonctionnel. J'ai suivi la procédure et ca se passe très bien et rapidement.

Sinon je suis passé au niveau 2 d'assistance chez Symantec pour qu'il
trouve ce qui n'a pas fonctionné chez nous.
Et comme l'a dit Marc, je veux qu'il me file Les Bonnes Procédures de
sauvegarde et restauration. Je vais pas les lâcher.

Merci

Stephane
Publicité
Poster une réponse
Anonyme