Problème syntaxe fstab

Le
ROBERT LEFEVRE
Bonjour,
La lecture des lignes qui défilent au démarrage (Debian Etch) m'apprend
que le "format" du fichier fstab n'est pas reconnu, en particulier la
ligne "LABEL=/racine". J'ai beau lire des docs et chercher pas mal, je
ne vois pas ce qui cloche.
J'utilise des labels parceque la détection du lecteur de carte mémoire
me jouait des tours au boot. A part ce message, tout est OK et le
système fonctinne à merveille J'aimerais comprendre, c'est tout.
Ci-dessous, le fichier fstab:
****************************************************
proc /proc proc defaults 0 0
LABEL=/racine / ext3 defaults,errors=remount-ro 0 1
/dev/sdc5 none swap sw 0 0
LABEL=/perso /home ext3 defaults 0 2
/dev/sdb1 /mnt/WinXP1 ntfs users,umask=0,noauto 0 0
/dev/sdd1 /mnt/WinXP2 ntfs users,umask=0,noauto 0 0
LABEL=/AUX /mnt/AUX ext3 defaults 0 3
/dev/hda /media/cdrom0 udf,iso9660 users,noauto 0 0
/dev/hdc /media/cdrom1 udf,iso9660 users,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,users,noauto 0 0
****************************************************
Merci pour votre aide, sincèrement
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Samuel Colin
Le #1912756
Dixit ROBERT LEFEVRE :
Bonjour,

Bonsoir,


J'utilise des labels parceque la détection du lecteur de carte mémoire
me jouait des tours au boot. A part ce message, tout est OK et le
système fonctinne à merveille... J'aimerais comprendre, c'est tout.
Ci-dessous, le fichier fstab:
****************************************************
proc /proc proc defaults 0 0
LABEL=/racine / ext3 defaults,errors=remount-ro 0 1
...
****************************************************

A priori il n'y a rien de trop bizarre. Tu avais bien donné à ta

partition racine le label "/racine" avec e2label ou un outil apparenté ?
Que dit exactement le message d'erreur ?

ROBERT LEFEVRE
Le #1912734
Dixit ROBERT LEFEVRE :
Bonjour,

Bonsoir,


J'utilise des labels parceque la détection du lecteur de carte mémoire
me jouait des tours au boot. A part ce message, tout est OK et le
système fonctinne à merveille... J'aimerais comprendre, c'est tout.
Ci-dessous, le fichier fstab:
****************************************************
proc /proc proc defaults 0 0
LABEL=/racine / ext3 defaults,errors=remount-ro 0 1
...
****************************************************

A priori il n'y a rien de trop bizarre. Tu avais bien donné à ta

partition racine le label "/racine" avec e2label ou un outil apparenté ?
Que dit exactement le message d'erreur ?

Qu'entends-tu par "trop bizarre" ?

Sinon, bien sûr, j'ai donné à mes trois partitions les labels
correspondants, avec e2label, et vérifié avant de modifier le fichier
fstab.
Le message d'erreur est le suivant:
"unrocogized file format" "fstab" "LABEL=/racine"
Je le cite de mémoire, parceque ce matin, pas de message.
Bizarre, non ?
Merci.


Samuel Colin
Le #1912723
Dixit ROBERT LEFEVRE :

A priori il n'y a rien de trop bizarre. Tu avais bien donné à ta

partition racine le label "/racine" avec e2label ou un outil apparenté ?
Que dit exactement le message d'erreur ?

Qu'entends-tu par "trop bizarre" ?


Je me suis mal exprimé, je voulais dire que la syntaxe correspond à ce

qui est préconisé dans la page de manuel.

Sinon, bien sûr, j'ai donné à mes trois partitions les labels
correspondants, avec e2label, et vérifié avant de modifier le fichier
fstab.

Avec les "/" ? A priori rien n'interdit de mettre un "/" dans un label

de périphérique (j'insiste sur le "a priori"), mais il est possible
qu'un script exploite la présence de slashs pour faire son analyse, ce
qui expliquerait le message d'erreur.

Le message d'erreur est le suivant:
"unrocogized file format" "fstab" "LABEL=/racine"
Je le cite de mémoire, parceque ce matin, pas de message.
Bizarre, non ?

Là je sèche...

Un coup d'oeil sur les scripts d'init de Etch montrent qu'il connaît le
format LABEL=truc (cf /etc/init.d/checkroot.sh). Je ne vois donc pas
d'où peut venir l'erreur. Le mieux que je puisse conseiller là est un
coup de google avec:
"unrecognized file format" fstab LABEL
et voir s'il y a moyen de trouver quelque chose.
Hors cela, je ne vois pas d'autre piste.



ROBERT LEFEVRE
Le #1912656
Dixit ROBERT LEFEVRE :
A priori il n'y a rien de trop bizarre. Tu avais bien donné à ta
partition racine le label "/racine" avec e2label ou un outil apparenté ?
Que dit exactement le message d'erreur ?

Qu'entends-tu par "trop bizarre" ?


Je me suis mal exprimé, je voulais dire que la syntaxe correspond à ce

qui est préconisé dans la page de manuel.

Sinon, bien sûr, j'ai donné à mes trois partitions les labels
correspondants, avec e2label, et vérifié avant de modifier le fichier
fstab.

Avec les "/" ? A priori rien n'interdit de mettre un "/" dans un label

de périphérique (j'insiste sur le "a priori"), mais il est possible
qu'un script exploite la présence de slashs pour faire son analyse, ce
qui expliquerait le message d'erreur.

Le message d'erreur est le suivant:
"unrocogized file format" "fstab" "LABEL=/racine"
Je le cite de mémoire, parceque ce matin, pas de message.
Bizarre, non ?

Là je sèche...

Un coup d'oeil sur les scripts d'init de Etch montrent qu'il connaît le
format LABEL=truc (cf /etc/init.d/checkroot.sh). Je ne vois donc pas
d'où peut venir l'erreur. Le mieux que je puisse conseiller là est un
coup de google avec:
"unrecognized file format" fstab LABEL
et voir s'il y a moyen de trouver quelque chose.
Hors cela, je ne vois pas d'autre piste.

J'ai lu quelque part que le slash était obligatoire, alors si c'est lui

qui est la cause de ce message d'erreur intempestif, je cale...
Merci quand même.



Publicité
Poster une réponse
Anonyme