Problème de syntaxe pour un résultat en heure

Le
Alain Lebayle
Bonjour,

Je souhaite faire apparaître dans ma cellule le résultat suivant en
heure, mais il me renvoie une valeur d'erreur
Je vous remercie
Alain

=SI(D2>10:30;D2-10:30)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #21033101
Bonjour,

Par exemple

=SI(D2>"10:30"*1;D2-"10:30";"")
Cellule au format heure

--
Salutations
JJ


"Alain Lebayle" news:
Bonjour,

Je souhaite faire apparaître dans ma cellule le résultat suivant en heure,
mais il me renvoie une valeur d'erreur
Je vous remercie
Alain

=SI(D2>10:30;D2-10:30)


michdenis
Le #21033261
Bonjour,

Il y aussi cette syntaxe :

=--SI(D2>"10:30";D2-"10:30")

Si le résultat devait être négatif, la cellule afficherait
une série de dièses. Le calendrier 1900 ne sait pas
afficher un résultat négatif bien qu'il sache effectuer
les opérations mathématiques. Pour afficher un
résultat négatif, tu dois passer au calendrier 1904
l'une des options d'Excel.
(Barre des menus / outils / options / onglet Calcul




"Alain Lebayle" discussion :
Bonjour,

Je souhaite faire apparaître dans ma cellule le résultat suivant en
heure, mais il me renvoie une valeur d'erreur
Je vous remercie
Alain

=SI(D2>10:30;D2-10:30)
Alain Lebayle
Le #21033661
Ok, c'est parfait, merci beaucoup à tous les 2
Bonne journée
Alain


michdenis a écrit :
Bonjour,

Il y aussi cette syntaxe :

=--SI(D2>"10:30";D2-"10:30")

Si le résultat devait être négatif, la cellule afficherait
une série de dièses. Le calendrier 1900 ne sait pas
afficher un résultat négatif bien qu'il sache effectuer
les opérations mathématiques. Pour afficher un
résultat négatif, tu dois passer au calendrier 1904
l'une des options d'Excel.
(Barre des menus / outils / options / onglet Calcul




"Alain Lebayle" discussion :
Bonjour,

Je souhaite faire apparaître dans ma cellule le résultat suivant en
heure, mais il me renvoie une valeur d'erreur
Je vous remercie
Alain

=SI(D2>10:30;D2-10:30)



FS
Le #21097631
Bonjour,

On peut aussi utiliser ce genre d'écriture des heures :

=SI(D2>(10,5/24);D2-(10,5/24))

ou encore

=SI(D2>TEMPS(10;30;);D2-TEMPS(10;30;))

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

Alain Lebayle a écrit :
Bonjour,

Je souhaite faire apparaître dans ma cellule le résultat suivant en
heure, mais il me renvoie une valeur d'erreur
Je vous remercie
Alain

=SI(D2>10:30;D2-10:30)


FS
Le #21097611
Bonjour Denis,

Chez moi, ton écriture ne "passe" pas, il faut +tôt présenter les choses
comme ceci :

=SI(D2>--"10:30";D2-"10:30")

Micro-climat, peut-être...

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

michdenis a écrit :
Bonjour,

Il y aussi cette syntaxe :

=--SI(D2>"10:30";D2-"10:30")

Si le résultat devait être négatif, la cellule afficherait
une série de dièses. Le calendrier 1900 ne sait pas
afficher un résultat négatif bien qu'il sache effectuer
les opérations mathématiques. Pour afficher un
résultat négatif, tu dois passer au calendrier 1904
l'une des options d'Excel.
(Barre des menus / outils / options / onglet Calcul




"Alain Lebayle" discussion :
Bonjour,

Je souhaite faire apparaître dans ma cellule le résultat suivant en
heure, mais il me renvoie une valeur d'erreur
Je vous remercie
Alain

=SI(D2>10:30;D2-10:30)



Publicité
Poster une réponse
Anonyme