Problème de tri numérique

Le
nico
Bonjour,

Ex: j'ai une colonne contenant
%mw200:x1
%mw200:x0
%mw200:x10
%mw200:x5


quand je fait tri avec la fonction A->Z
J'obtiens:

%mw200:x0
%mw200:x1
%mw200:x10
%mw200:x5

le tri est effectué comme les nom de fichiers dans l'explorateur, mais ce
n'est pas ce que je recherche.

Je voudrais en retour de mon tri:

%mw200:x0
%mw200:x1
%mw200:x5
%mw200:x10

Dans l'ordre quoi

Comment peux t'on faire

Merci par avance de vos réponses

--
nico
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #5065731
Bonjour,
Les données supposées commencer en a1, dans une colonne voisine cette
formule :

=SI(NBCAR(DROITE(A1;NBCAR(A1)-TROUVE("x";A1;1)))<2;"0";"")&DROITE(A1;NBCAR(A1)-TROUVE("x";A1;1))

que tu recopies vers le bas.

Tu effectues ensuite le tri en incluant cette colonne et en l'utilisant
comme critère (peut être fait avec la colonne masquée) ; au passage tu
coches le bouton radio du haut dans la boîte de dialogue qui te demande
comment traiter les nombres et le texte
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"nico" news:
Bonjour,

Ex: j'ai une colonne contenant
%mw200:x1
%mw200:x0
%mw200:x10
%mw200:x5
...

quand je fait tri avec la fonction A->Z
J'obtiens:

%mw200:x0
%mw200:x1
%mw200:x10
%mw200:x5
...
le tri est effectué comme les nom de fichiers dans l'explorateur, mais ce
n'est pas ce que je recherche.

Je voudrais en retour de mon tri:

%mw200:x0
%mw200:x1
%mw200:x5
%mw200:x10
...
Dans l'ordre quoi...

Comment peux t'on faire

Merci par avance de vos réponses

--
nico


FFO
Le #5065691
Salut à toi

Solution macro
Considérant la colonne A à traiter :

Columns("B:B").Value = Columns("A:A").Value
Columns("B:B").Replace What:="%mw200:x", Replacement:=""
Range("A1:B4").Sort Key1:=Range("B1"), Order1:=xlAscending
Columns("B:B").Clear

Attention elle utilise la colonne B de manière transitoire
Celle-ci doit donc être libre
Choisir une autre colonne dans le cas contraire dans les expressions :
Columns("B:B")
Range("A1:B4")
Range("B1")

Celà devrait faire


Bonjour,

Ex: j'ai une colonne contenant
%mw200:x1
%mw200:x0
%mw200:x10
%mw200:x5
...

quand je fait tri avec la fonction A->Z
J'obtiens:

%mw200:x0
%mw200:x1
%mw200:x10
%mw200:x5
...
le tri est effectué comme les nom de fichiers dans l'explorateur, mais ce
n'est pas ce que je recherche.

Je voudrais en retour de mon tri:

%mw200:x0
%mw200:x1
%mw200:x5
%mw200:x10
...
Dans l'ordre quoi...

Comment peux t'on faire

Merci par avance de vos réponses

--
nico


Publicité
Poster une réponse
Anonyme