problème update/upgrade : personne ?

Le
Patrice Desrues
Salut. J'ai une Debian-lenny, et à chaque update/upgrade j'ai un message
d'erreur concernant la mise à jour du paquet spasmass-milter :
--
Préparation du remplacement de spamass-milter 0.3.1-2 (en utilisant
/spamass-milter_0.3.1-8_i386.deb)
Stopping Sendmail milter plugin for SpamAssassin: No
/usr/sbin/spamass-milter found running; none killed.
invoke-rc.d: initscript spamass-milter, action "stop" failed.
dpkg : avertissement - ancien script pre-removal a retourné un code
d'erreur de sortie 1
dpkg - tentative d'exécution du script du nouveau paquet à la place
Stopping Sendmail milter plugin for SpamAssassin: No
/usr/sbin/spamass-milter found running; none killed.
invoke-rc.d: initscript spamass-milter, action "stop" failed.
dpkg : erreur de traitement de
/var/cache/apt/archives/spamass-milter_0.3.1-8_i386.deb (--unpack) :
le sous-processus nouveau script pre-removal a retourné une erreur de
sortie d'état 1
update-rc.d: warning: /etc/init.d/spamass-milter missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
Starting Sendmail milter plugin for SpamAssassin: /usr/sbin/spamass-milter
Traitement des actions différées (« triggers ») pour « man-db »
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/spamass-milter_0.3.1-8_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
RESULT0
-
Si quelqu'un a une idée j'ai bien entendu essayé de retirer ce
paquet, mais j'ai le même message ;o(
Merci pour les propositions.
Cordialement.

--
Patrice Desrues
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yves
Le #19014601
Patrice Desrues wrote:


no /usr/sbin/spamass-milter found running; none killed.
invoke-rc.d: initscript spamass-milter, action "stop" failed.
dpkg : erreur de traitement de
/var/cache/apt/archives/spamass-milter_0.3.1-8_i386.deb (--unpack) :
le sous-processus nouveau script pre-removal a retourné une erreur de
sortie d'état 1




ça ressemble à un bug (bug debian, de l'installeur). Le démon ne tourne
pas, le script de pre-removal devrait continuer à s'exécuter.
Pour supprimer le paquet :

Ceci devrait marcher :

# Essayer d'abord 0. ça ne résoud pas le bug, mais ça devrait détromper dpkg
# 0
invoke-rc.d spamass-milter start
aptitude install spamass-milter # pour effectuer la mise à jour.
# 1/ remplacer le script spamass-milter dans /etc/init.d par /bin/true
mv spamass-milter spamass-milter-bug
ln -s /bin/true/ spamass-milter
aptitude remove spamass-milter
# 2/ remettre le script en place :
mv spamass-milter-bug
aptitude purge spamass-milter

Puis tenter de le réinstaller (cela devrait passer, mais cela risque de
se reproduire lors d'une mise à jour.)

Si 0 et 1 échouent essayer
dpkg deinstallspamass-milter
et agir en fonction de la sortie.

Ensuite :
lancer aptitude *en peone*
pointer sur spamass-milter
taper B
décrire le bug (vérifier s'il n'est pas déjà reporté par quelqu'un d'autre)


Merci pour les propositions.
Cordialement.

--
Patrice Desrues




--
Certains hommes parlent pendant leur sommeil.
Les confxE9renciers parlent pendant le sommeil des autres.
-+- Albert Camus (1913-1960) -+-
Patrice Desrues
Le #19016241
Yves a écrit :
ça ressemble à un bug (bug debian, de l'installeur). Le démon ne tourne
pas, le script de pre-removal devrait continuer à s'exécuter.



Merci de la proposition. Je vais m'y mettre dès que j'aurais le temps.
@+

--
patrice Desrues
Patrice Desrues
Le #19020421
Yves a écrit :
ça ressemble à un bug (bug debian, de l'installeur). Le démon ne tourne
pas, le script de pre-removal devrait continuer à s'exécuter.
Pour supprimer le paquet :

Ceci devrait marcher :

# Essayer d'abord 0. ça ne résoud pas le bug, mais ça devrait détromper
dpkg
# 0
invoke-rc.d spamass-milter start
aptitude install spamass-milter # pour effectuer la mise à jour.
# 1/ remplacer le script spamass-milter dans /etc/init.d par /bin/true
mv spamass-milter spamass-milter-bug
ln -s /bin/true/ spamass-milter
aptitude remove spamass-milter
# 2/ remettre le script en place :
mv spamass-milter-bug
aptitude purge spamass-milter

Puis tenter de le réinstaller (cela devrait passer, mais cela risque de
se reproduire lors d'une mise à jour.)

Si 0 et 1 échouent essayer
dpkg deinstallspamass-milter
et agir en fonction de la sortie.

Ensuite :
lancer aptitude *en peone*
pointer sur spamass-milter
taper B
décrire le bug (vérifier s'il n'est pas déjà reporté par quelqu'un d'autre)



Salut. Le 0 n'a pas marché, mais le 1 m'a l'air d'avoir fonctionné,
j'ai la nouvelle version de spamass-milter en place.
Je verrai à la prochaine mise à jour de ce paquet si ça bug encore ou non.
Merci.

--
Patrice Desrues
Publicité
Poster une réponse
Anonyme