Problème avec Vista - Ouverture d'une base de données en réseau

Le
pierre.rivet
Bonjour à tous,

Je viens d'installer récemment Vista sur un de mes ordinateurs, et je
cherche à utiliser un de mes logiciels en réseau.

Voici l'instruction d'ouverture de la base:

'4 - Ouverture de la base de travail

Set CT = New ADODB.Connection

CT.Provider = "microsoft.jet.oledb.4.0"

CT.ConnectionString = CHEMINBASE

CT.Open

avec CHEMINBASE="\VideoLOCALOstéoRéseauOstéoRéseau.mdb"

(donc un chemin classique en réseau)

Quand je lance l'ordinateur, j'ai le message suivant:
=> Impossible d'utiliser "; fichier en cours d'utilisation

J'ajoute que ces instructions fonctionnent parfaitement sous Windows XP,
depuis longtemps.

Quelqu'un a-t-il une idée ?

Merci d'avance, en ce 1er mai particulièrement pluvieux,

Pierre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacques93
Le #15411001
Bonjour pierre.rivet,
pierre.rivet a écrit :
Bonjour à tous,

Je viens d'installer récemment Vista sur un de mes ordinateurs, et je
cherche à utiliser un de mes logiciels en réseau.

Voici l'instruction d'ouverture de la base:

'4 - Ouverture de la base de travail

Set CT = New ADODB.Connection

CT.Provider = "microsoft.jet.oledb.4.0"

CT.ConnectionString = CHEMINBASE

CT.Open

avec CHEMINBASE="\VideoLOCALOstéoRéseauOstéoRéseau.mdb"

(donc un chemin classique en réseau)

Quand je lance l'ordinateur, j'ai le message suivant:
=> Impossible d'utiliser "; fichier en cours d'utilisation

J'ajoute que ces instructions fonctionnent parfaitement sous Windows XP,
depuis longtemps.

Quelqu'un a-t-il une idée ?

Merci d'avance, en ce 1er mai particulièrement pluvieux,

Pierre



Quelques pistes :

As tu donné les autorisations nécessaires sur la machine hôte de la base
pour la session Vista ?

Peux tu ouvrir ta base à partir d'Access ?

--
Cordialement,

Jacques.
pierre.rivet
Le #15410981
Merci de ces pistes...

a) pour l'instant, je n'ai pas installé Access sur le poste équipé de Vista,
car je veux me mettre dans la même configuration que mes utilisateurs du
logiciel qui eux, n'ont pas Access.

b) en ce qui concerne les autorisations nécessaires sur la machine Vista,
que veux-tu dire par là ? Où dois-je aller ?

Merci encore,

Pierre



"Jacques93" a écrit dans le message de news:
%
Bonjour pierre.rivet,
pierre.rivet a écrit :
Bonjour à tous,

Je viens d'installer récemment Vista sur un de mes ordinateurs, et je
cherche à utiliser un de mes logiciels en réseau.

Voici l'instruction d'ouverture de la base:

'4 - Ouverture de la base de travail

Set CT = New ADODB.Connection

CT.Provider = "microsoft.jet.oledb.4.0"

CT.ConnectionString = CHEMINBASE

CT.Open

avec CHEMINBASE="\VideoLOCALOstéoRéseauOstéoRéseau.mdb"

(donc un chemin classique en réseau)

Quand je lance l'ordinateur, j'ai le message suivant:
=> Impossible d'utiliser "; fichier en cours d'utilisation

J'ajoute que ces instructions fonctionnent parfaitement sous Windows XP,
depuis longtemps.

Quelqu'un a-t-il une idée ?

Merci d'avance, en ce 1er mai particulièrement pluvieux,

Pierre



Quelques pistes :

As tu donné les autorisations nécessaires sur la machine hôte de la base
pour la session Vista ?

Peux tu ouvrir ta base à partir d'Access ?

--
Cordialement,

Jacques.


Jacques93
Le #15410971
pierre.rivet a écrit :
Merci de ces pistes...

a) pour l'instant, je n'ai pas installé Access sur le poste équipé de Vista,
car je veux me mettre dans la même configuration que mes utilisateurs du
logiciel qui eux, n'ont pas Access.



Peux tu simplement y accéder via l'explorateur ?

b) en ce qui concerne les autorisations nécessaires sur la machine Vista,
que veux-tu dire par là ? Où dois-je aller ?




C'est sur la machine ou se trouve la base qu'il faut indiquer les
autorisation d'accès, via l'explorateur => partage et sécurité (si la
machine est sous XP), et indiquer les comptes autorisés


--
Cordialement,

Jacques.
Publicité
Poster une réponse
Anonyme