Problème de wifi sous Windows après un test d'Ubuntu

Le
Antoine
Salut!
Sur un portable de marque Asus, et qui est actuellement sous Windows
Seven, j'ai fait tourner un live CD d'Ubuntu 10.04. Au retour sous
Windows, j'ai des problèmes avec le wifi: impossible de rejoindre mon
réseau. Est-ce que Linux aurait modifié quelque chose dans la carte
wifi, qui provoquerait ce problème?

Antoine
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #22897111
Le 07/12/2010 22:31, Antoine a écrit :
Salut!
Sur un portable de marque Asus, et qui est actuellement sous Windows
Seven, j'ai fait tourner un live CD d'Ubuntu 10.04. Au retour sous
Windows, j'ai des problèmes avec le wifi: impossible de rejoindre mon
réseau. Est-ce que Linux aurait modifié quelque chose dans la carte
wifi, qui provoquerait ce problème?



Quelle carte Wifi ?

J'ai eu ce genre de problème : Au reboot (soft), parfois je perds le wifi (quel que soit l'OS : Windows, Linux ou passage Windows
<-> Linux). Après une reboot hard (arrêt + redémarrage), c'est bon.

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Emmanuel Florac
Le #22897101
Le Tue, 07 Dec 2010 13:31:56 -0800, Antoine a écrit:

Est-ce que Linux aurait modifié quelque chose dans la carte wifi,
qui provoquerait ce problème?



On voit mal comment linux pourrait "modifier" la carte wifi. Tu as essayé
un arrêt complet, puis redémarrage?

--
L'Algérie était au bord du gouffre, aujourd'hui elle a fait un grand pas
en avant.
Kaid Ahmed.
Pascal Hambourg
Le #22897251
Salut,

Emmanuel Florac a écrit :
Le Tue, 07 Dec 2010 13:31:56 -0800, Antoine a écrit:

Est-ce que Linux aurait modifié quelque chose dans la carte wifi,
qui provoquerait ce problème?



On voit mal comment linux pourrait "modifier" la carte wifi.



Ce genre de problème s'est déjà vu : le pilote d'un OS laisse le
périphérique dans un état que le pilote de l'autre OS ne s'attend à
trouver au démarrage et ne réinitialise pas correctement.

Tu as essayé un arrêt complet, puis redémarrage?
grostophe
Le #22919901
Pascal Hambourg a tapoté sur son clavier:
Salut,

Emmanuel Florac a écrit :
Le Tue, 07 Dec 2010 13:31:56 -0800, Antoine a écrit:

Est-ce que Linux aurait modifié quelque chose dans la carte wifi,
qui provoquerait ce problème?


On voit mal comment linux pourrait "modifier" la carte wifi.



Ce genre de problème s'est déjà vu : le pilote d'un OS laisse le
périphérique dans un état que le pilote de l'autre OS ne s'attend à
trouver au démarrage et ne réinitialise pas correctement.



faux ! le périphérique (ici la carte wifi) ne peut pas garder en lui ce
qu'un pilote lui dit de faire. Là, il s'agit d'un live-cd linux, qui
n'agit en aucun cas sur le système présent dans l'ordi. de plus, quand
on quitte le live-cd, l'ordi redémarre sur l'autre système. aucune
inter-action entre les deux systèmes. perso, j'ai un dual boot sur mon
portable (winxp et xubuntu 8.04) et je peux passer de l'un à l'autre
sans souci aucun. je pencherais plutôt pour un problème du côté de la
box, surtout si cela arrive à chaque fois (peut-être est-il possible de
fixer une adresse ip sur la box avec l'adresse mac de la cate wifi ?)

Tu as essayé un arrêt complet, puis redémarrage?





bon courage

--
linux user #375006 sur http://counter.li.org
AbulEduLive (basée sur Xubuntu)

"La libre communication des pensées et des opinions est un des droits
les plus précieux de l'homme ; tout citoyen peut donc parler, écrire,
imprimer librement, sauf à répondre de l'abus de cette liberté dans les
cas déterminés par la loi."
article 11 de la déclaration de droits de l'homme et du citoyen du 26
août 1789.
jp willm
Le #22921041
Hello,

Le 08/12/2010 09:44, Pascal Hambourg a écrit :

Ce genre de problème s'est déjà vu : le pilote d'un OS laisse le
périphérique dans un état que le pilote de l'autre OS ne s'attend à
trouver au démarrage et ne réinitialise pas correctement.



J'ai également déjà vu cela.


Tu as essayé un arrêt complet, puis redémarrage?




C'est ce qui a fonctionné chez moi.


--
jp willm
http://perso.orange.fr/willms/index.html
Gigiair
Le #22921901
jp willm
Hello,

Le 08/12/2010 09:44, Pascal Hambourg a écrit :

Ce genre de problème s'est déjà vu : le pilote d'un OS laisse le
périphérique dans un état que le pilote de l'autre OS ne s'attend à
trouver au démarrage et ne réinitialise pas correctement.



J'ai également déjà vu cela.


Tu as essayé un arrêt complet, puis redémarrage?




C'est ce qui a fonctionné chez moi.



Un truc qui m'est arrivé : le wifi de mon eeepc ne fonctionnait pas bien
(débit très insuffisant, décrochements fréquents) sous Ubuntu (ath5k)
alors qu'il fonctionnait sous Xandros (ath_pci), et pas du tout sous
Ubuntu et ath_pci. J'ai réglé le problème en changeant le canal
wifi. J'ai deux voisins qui ont le même FAI que moi, et qui sont sur le
canal 11. Le problème de toute relation : il faut être deux pour en
établir une.

--
JJR.
Pascal Hambourg
Le #22921941
grostophe a écrit :
Pascal Hambourg a tapoté sur son clavier:
Ce genre de problème s'est déjà vu : le pilote d'un OS laisse le
périphérique dans un état que le pilote de l'autre OS ne s'attend à
trouver au démarrage et ne réinitialise pas correctement.



faux ! le périphérique (ici la carte wifi) ne peut pas garder en lui ce
qu'un pilote lui dit de faire.



Ben si. Les faits sont têtus.

Là, il s'agit d'un live-cd linux, qui
n'agit en aucun cas sur le système présent dans l'ordi.



Mais sur l'état des périphériques (registres de configuration,
toussa...), oui.

de plus, quand
on quitte le live-cd, l'ordi redémarre sur l'autre système.



Cela ne signifie pas que les périphériques sont réinitialisés dans un
état identique à celui après la mise sous tension ou un reset hard.

aucune inter-action entre les deux systèmes.



Ben si.
Tu crois qu'un OS remet à zéro toute la RAM avant de s'arrêter ou de se
lancer ?
Nicolas George
Le #22922081
Pascal Hambourg , dans le message écrit :
Ce genre de problème s'est déjà vu : le pilote d'un OS laisse le
périphérique dans un état que le pilote de l'autre OS ne s'attend à
trouver au démarrage et ne réinitialise pas correctement.


faux ! le périphérique (ici la carte wifi) ne peut pas garder en lui ce
qu'un pilote lui dit de faire.


Ben si. Les faits sont têtus.



Pour abonder dans ton sens : sur mon ancienne carte vidéo, au lancement
d'X11 après un reboot à chaud, je pouvais voir pendant une fraction de
seconde, avant le motif moiré, une grande partie ce qui était affiché à
l'écran avant le reboot. Preuve que l'essentiel de la mémoire vidéo était
simplement préservé.
Erwan David
Le #22922071
Nicolas George
Pascal Hambourg , dans le message écrit :
Ce genre de problème s'est déjà vu : le pilote d'un OS laisse le
périphérique dans un état que le pilote de l'autre OS ne s'attend à
trouver au démarrage et ne réinitialise pas correctement.


faux ! le périphérique (ici la carte wifi) ne peut pas garder en lui ce
qu'un pilote lui dit de faire.


Ben si. Les faits sont têtus.



Pour abonder dans ton sens : sur mon ancienne carte vidéo, au lancement
d'X11 après un reboot à chaud, je pouvais voir pendant une fraction de
seconde, avant le motif moiré, une grande partie ce qui était affiché à
l'écran avant le reboot. Preuve que l'essentiel de la mémoire vidéo était
simplement préservé.



idem au boulot avec le driver fglrx. C'est déformé mais je reconnais des
morceaux.

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Tonton Th
Le #22922231
On 12/13/2010 11:25 AM, grostophe wrote:

faux ! le périphérique (ici la carte wifi) ne peut pas garder en lui ce
qu'un pilote lui dit de faire. Là, il s'agit d'un live-cd linux, qui



peut parfaitement essayer d'utiliser un périphérique dont
le microcode n'est chargé _que_ par le driver sous MS-DOS
fourni avec la carte. Si le microcode n'est pas chargé, la
carte ne fonctionne pas.

--
Ma coiffeuse est formidable - http://sonia.buvette.org/
Publicité
Poster une réponse
Anonyme