problèmes après maj noyau

Le
arenevier
bonjour,
je viens de mettre à jour mon noyau: passage de 2.6.22 à 2.6.24 C'est un noyau
que je recompile moi même avec la commande
make-kpkg -us -uc --append-to-version "-custom" --initrd buildpackage
Auparavant, j'avais copié mon fichier de config (cp /boot/config-2.6.22custom
.config), et exécuté make oldconfig.
j'ai ensuite recompilé différents modèles avec module-assistant
mais j'ai plusieurs problèmes: tout d'abord, l'ordinateur se bloque pendant
environ 20 secondes au démarrage après avoir écrit ceci:

> ICH6: IDE controller (0x8086:0x266f rev 0x04) at PCI slot 0000:00:1f.1
> ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 20
> ICH6: not 100% native mode: will probe irqs later
> ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
> ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
> Probing IDE interface ide0

Juste après s'être débloqué, il écrit:

> Clocksource tsc unstable (delta = -19261976751 ns)
> Time: hpet clocksource has been installed.

Il y avait déjà ces messages avec l'ancien noyau, mais il y avait pas
l'attente.

Autre chose, lors du démarrage, j'ai plusieurs messages d'erreur:

modprobe: WARNING: Error inserting padlock_aes (/lib/modules/2.6.24-custom/kernel/drivers/crypto/padlock-aes.ko): No such device
(lors de /etc/init.d/cryptdisks-early)

FATAL: Error inserting speedstep_centrino (/lib/modules/2.6.24-custom/kernel/arch/x86/kernel/cpu/cpufreq/speedstep-centrino.ko): No such device
(lors de /etc/init.d/powersaved)

Lorsque j'essaye d'insérer ces modules à la main (avec insmod), j'ai le même
message d'erreur.

En ce qui concerne, cryptdisks, ce n'est pas très gênant (ma partition
chiffrée se monte bien). Par contre, en ce qui concerne speedstep-centrino,
j'ai l'impression que la modification de fréquence du cpu n'est plus
supportée: powersave -c me dit "Speedstepping is not supported."

D'autre part, en regardant dans les fichiers /boot/config*, je vois dans la
version 2.6.22 la ligne
CONFIG_X86_SPEEDSTEP_CENTRINO_ACPI=y
et cette option ne semble plus disponible dans la version 2.6.24

Est-ce une option qui a disparu ? Si oui, comment récupérer la même
fonctionnalité ? Est-ce moi qui ai mal configuré mon noyau ? Le problème de
lenteur au démarrage est-il lié ou s'agit il d'un autre problème ?

arno


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #9725281
, dimanche 3 février 2008, 10:29:37 CET

bonjour,



’jour,

je viens de mettre à jour mon noyau: passage de 2.6.22 à
2.6.24 C'est un noyau que je recompile moi même […]



Pourquoi le compiles-tu toi-même ?
As-tu essayé le paquet Debian ?
Si tu dois/veux le compiler, pourquoi ne pas essayer de partir
du noyau Debian ?

--
Sylvain Sauvage
arenevier
Le #9724991
Bonjour, et merci pour ta réponse.

Sylvain Sauvage
, dimanche 3 février 2008, 10:29:37 CET
je viens de mettre à jour mon noyau: passage de 2.6.22 à
2.6.24 C'est un noyau que je recompile moi même […]



Pourquoi le compiles-tu toi-même ?



Pour désactiver le clavier.
http://lists.debian.org/debian-user-french/2007/09/msg00957.html
Je n'ai pas réussi à le faire mécaniquement, alors je recompile le noyau pour
ça.

As-tu essayé le paquet Debian ?


Du coup, je viens d'essayer, et en fait, j'ai les même symptômes avec le noyau
debian.

a+
arno


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
arenevier
Le #9724871
wrote:
mais j'ai plusieurs problèmes: tout d'abord, l'ordinateur se bloque pendant
environ 20 secondes au démarrage après avoir écrit ceci:

ICH6: IDE controller (0x8086:0x266f rev 0x04) at PCI slot 0000:00:1f.1
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 20
ICH6: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
Probing IDE interface ide0...



Juste après s'être débloqué, il écrit:

Clocksource tsc unstable (delta = -19261976751 ns)
Time: hpet clocksource has been installed.



Il y avait déjà ces messages avec l'ancien noyau, mais il y avait pas
l'attente.

Autre chose, lors du démarrage, j'ai plusieurs messages d'erreur:

modprobe: WARNING: Error inserting padlock_aes (/lib/modules/2.6.24-custom/kernel/drivers/crypto/padlock-aes.ko): No such device
(lors de /etc/init.d/cryptdisks-early)

FATAL: Error inserting speedstep_centrino (/lib/modules/2.6.24-custom/kernel/arch/x86/kernel/cpu/cpufreq/speedstep-centrino.ko): No such device
(lors de /etc/init.d/powersaved)

Lorsque j'essaye d'insérer ces modules à la main (avec insmod), j'ai le même
message d'erreur.

En ce qui concerne, cryptdisks, ce n'est pas très gênant (ma partition
chiffrée se monte bien). Par contre, en ce qui concerne speedstep-centrino,
j'ai l'impression que la modification de fréquence du cpu n'est plus
supportée: powersave -c me dit "Speedstepping is not supported."



En ce qui concerne le bug de powersave, c'est parceque le module
speedstep_centrino était marqué comme deprecated et est maintenant
complètement désactivé dans le noyau. Par contre, powersaved est sensé charger
d'autres modules, mais ça ne marchait vu que j'utilise dash comme /bin/sh ;
j'ai ouvert le bug #463925 à ce sujet.

Je me pencherais plus tard sur le message d'erreur dans cryptdisks ainsi que
sur le ralentissement au démarrage.

a+
arno


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme