problemes dates

Le
Philippe
Bonjour

Sur les jours du mois je voudrais ne faire apparaitre que les week-end et
jours feriés. Cela est-il réalisable simplement ?
Merci de votre aide
Philippe D.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
AV
Le #4465961
Exemple avec une date en A1
Sélection cellule > Format > Mise en forme conditionnelle > la formule est :
Condition 1 :
=OU(ET(JOUR(A1)=1;MOIS(A1)=1);FRANC(DATE(ANNEE(A1);4;JOUR(MINUTE(ANNEE(A1)/38)/2+55))/7;)*7-6+1¡;ET(JOUR(A1)=1;MOIS(A1)=5);ET(JOUR(A1)=8;MOIS(A1)=5);FRANC(DATE(ANNEE(A1);4;JOUR(MINUTE(ANNEE(A1)/38)/2+55))/7;)*7-6+39¡)
couleur jaune
Condition 2 :


=OU(ET(JOUR(A1);MOIS(A1)=7);ET(JOUR(A1);MOIS(A1)=8);ET(JOUR(A1)=1;MOIS(A1));ET(JOUR(A1);MOIS(A1));ET(JOUR(A1)%;MOIS(A1)))
couleur jaune
Condition 3 :


=JOURSEM(A1;2)>5
couleur verte




Voir exemple là :
http://cjoint.com/?evjhxXJlXF

AV


JB
Le #4465931
Bonjour,

A1 contient la date de début
A2 contient la date de fin

=SI(ESTNUM(PETITE.VALEUR(SI((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));2)>=6)+
(ESTNUM(EQUIV(LIGNE(INDIRECT(A1&":"&A2));fériés;
0)));LIGNE(INDIRECT(A1&":"&A2)));LIGNE(INDIRECT("1:31"))));PETITE.VALEUR(SI ((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));
2)>=6)+(ESTNUM(EQUIV(LIGNE(INDIRECT(A1&":"&A2));fériés;
0)));LIGNE(INDIRECT(A1&":"&A2)));LIGNE(INDIRECT("1:31")));"")

Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?evjbiOfTrP

Cordialement JB


On 21 avr, 07:55, "Philippe"
Bonjour

Sur les jours du mois je voudrais ne faire apparaitre que les week-end et
jours feriés. Cela est-il réalisable simplement ?
Merci de votre aide
Philippe D.


Jac
Le #4465911
Bonjour Ph,

il suffit de mettre en place un formatage conditionnel comme sur
http://cjoint.com/?evjjacT6va

Jac

"Philippe" %23W%
Bonjour

Sur les jours du mois je voudrais ne faire apparaitre que les week-end et
jours feriés. Cela est-il réalisable simplement ?
Merci de votre aide
Philippe D.



Philippe
Le #4465361
Bonsoir JB
Je vous remercie pour la réponse car cela correspond à ce que je souhaite
mais j'aurais besoin que les dates soient sur des colonnes au lieu de lignes
Remerciement à tous
Cordialement
Philippe D.
"JB"
Bonjour,

A1 contient la date de début
A2 contient la date de fin

=SI(ESTNUM(PETITE.VALEUR(SI((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));2)>=6)+
(ESTNUM(EQUIV(LIGNE(INDIRECT(A1&":"&A2));fériés;
0)));LIGNE(INDIRECT(A1&":"&A2)));LIGNE(INDIRECT("1:31"))));PETITE.VALEUR(SI((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));
2)>=6)+(ESTNUM(EQUIV(LIGNE(INDIRECT(A1&":"&A2));fériés;
0)));LIGNE(INDIRECT(A1&":"&A2)));LIGNE(INDIRECT("1:31")));"")

Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?evjbiOfTrP

Cordialement JB


On 21 avr, 07:55, "Philippe"
Bonjour

Sur les jours du mois je voudrais ne faire apparaitre que les week-end et
jours feriés. Cela est-il réalisable simplement ?
Merci de votre aide
Philippe D.


Jac
Le #4465271
Pour ce qui est des jours fériés, il faudra faire une table des jours fériés
et dans le formatage conditionnel, regarder si le jour à traiter se trouve
dans la table des fériés. Avec une recherchev, ça marche sans problème.

"Jac" umJRyQ%
Bonjour Ph,

il suffit de mettre en place un formatage conditionnel comme sur
http://cjoint.com/?evjjacT6va

Jac

"Philippe" %23W%
Bonjour

Sur les jours du mois je voudrais ne faire apparaitre que les week-end et
jours feriés. Cela est-il réalisable simplement ?
Merci de votre aide
Philippe D.




JB
Le #4465241
Bonjour,

Liste des samedis-Dimanches +JF entre 2 dates
=SI(ESTNUM(PETITE.VALEUR(SI((JOURSEM(LIGNE(INDIRECT(B1&":"&B2));2)>=6)+
(ESTNUM(EQUIV(LIGNE(INDIRECT(B1&":"&B2));fériés;
0)));LIGNE(INDIRECT(B1&":"&B2)));COLONNE(INDIRECT("1:120"))));PETITE.VALEUR (SI((JOURSEM(LIGNE(INDIRECT(B1&":"&B2));
2)>=6)+(ESTNUM(EQUIV(LIGNE(INDIRECT(B1&":"&B2));fériés;
0)));LIGNE(INDIRECT(B1&":"&B2)));COLONNE(INDIRECT("1:120")));"")
Valider avec Maj+Ctrl+entrée

http://boisgontierjacques.free.fr/fichiers/Dates/ListeFeries2dates.xls

Cordialement JB

On 21 avr, 21:38, "Philippe"
Bonsoir JB
Je vous remercie pour la réponse car cela correspond à ce que je souh aite
mais j'aurais besoin que les dates soient sur des colonnes au lieu de lig nes
Remerciement à tous
Cordialement
Philippe D.
"JB"
Bonjour,

A1 contient la date de début
A2 contient la date de fin

=SI(ESTNUM(PETITE.VALEUR(SI((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));2)>=6 )+
(ESTNUM(EQUIV(LIGNE(INDIRECT(A1&":"&A2));fériés;
0)));LIGNE(INDIRECT(A1&":"&A2)));LIGNE(INDIRECT("1:31"))));PETITE.VALEUR( SI­((JOURSEM(LIGNE(INDIRECT(A1&":"&A2));
2)>=6)+(ESTNUM(EQUIV(LIGNE(INDIRECT(A1&":"&A2));fériés;
0)));LIGNE(INDIRECT(A1&":"&A2)));LIGNE(INDIRECT("1:31")));"")

Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?evjbiOfTrP

Cordialement JB

On 21 avr, 07:55, "Philippe"


Bonjour

Sur les jours du mois je voudrais ne faire apparaitre que les week-end et
jours feriés. Cela est-il réalisable simplement ?
Merci de votre aide
Philippe D.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme