Problèmes de dépendences & libc

Le
O.L.
Hello,

J'ai un portable sous Kubuntu, et il y a quelques jours j'ai installé
la version la plus récente possible des paquets libc6 (2.7-5ubuntu2) et
de libstdc++ (4.2.3-1ubuntu2), parce que je tentais d'installer un
logiciel nécessitant ces versions de ces paquets. D'ailleurs ce
logiciel n'a pas voulu fonctionner

Aujourd'hui je me demande si je n'ai pas fais une bêtise car quand
je veux faire quasiment n'importe quelle opération sur les paquets, que
ce soit via Adept ou apt-get (comme par exemple installer xchat ou
supprimer kmail), le gestionnaire de paquet affiche une liste
anormalement longue de paquets à supprimer, installer ou mettre à jour


Exemple de sortie d'apt-get :
http://cjoint.com/?csmTCSkFDg
(554 Mo d'espace disque libéré après avoir installé xchat : c'est
louche !)

Qu'en pensez vous ? :-/
Est ce que ça a bien un lien avec les précédents bidouillages de la
libc6, et comment faire pour revenir à une situation plus normale ?

Merci d'avance pour vos conseils,
Olivier

--
Olivier Ligny
www.virgal.net (mondes virtuels 3D)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Samuel Colin
Le #1918117
Dixit O.L :
Hello,

Bonsoir,


J'ai un portable sous Kubuntu, et il y a quelques jours j'ai installé
la version la plus récente possible des paquets libc6 (2.7-5ubuntu2) et
de libstdc++ (4.2.3-1ubuntu2), parce que je tentais d'installer un
logiciel nécessitant ces versions de ces paquets. D'ailleurs ce
logiciel n'a pas voulu fonctionner ...

Ben voilà, paf. On regarde d'abord s'il y a un backport, si ce n'est pas

le cas on peut voir à essayer d'en faire un. Et si c'est pas possible on
ne touche pas à la glibc sans savoir ce qu'on fait.
Bref.

Contenu de /etc/apt/sources.list ?
Contenu de /etc/apt/apt.conf s'il y en a un ?
Sortie de apt-cache policy xchat libc6 libstdc++ ?

L'idée étant de remettre libc6 et libstdc++ à la bonne version de
Kubuntu que tu utilisais (quelle était-elle ?)

Guillaume
Le #1918110
Samuel Colin a wroté :

[ Snip les trucs dangereux avec *libc* ]


L'idée étant de remettre libc6 et libstdc++ à la bonne version de
Kubuntu que tu utilisais (quelle était-elle ?)


Il a peut-être une toute petite chance de le découvrir, et du coup de
réinstaller la version précédente si les .deb correspondants se trouvent
encore dans /var/cache/apt/archives ... je n'ai jamais essayé, mais
c'est une suggestion qui en vaut une autre (à supposer qu'un dpkg -i sur
ces paquets soit bien accepté ensuite par le système.).

Bonne chance.

--
Guillaume

O.L.
Le #1917794
Samuel Colin a formulé ce lundi :
Dixit O.L :
Hello,

Bonsoir,


J'ai un portable sous Kubuntu, et il y a quelques jours j'ai installé
la version la plus récente possible des paquets libc6 (2.7-5ubuntu2) et
de libstdc++ (4.2.3-1ubuntu2), parce que je tentais d'installer un
logiciel nécessitant ces versions de ces paquets. D'ailleurs ce
logiciel n'a pas voulu fonctionner ...

Ben voilà, paf. On regarde d'abord s'il y a un backport, si ce n'est pas

le cas on peut voir à essayer d'en faire un. Et si c'est pas possible on
ne touche pas à la glibc sans savoir ce qu'on fait.
Bref.

Contenu de /etc/apt/sources.list ?
Contenu de /etc/apt/apt.conf s'il y en a un ?
Sortie de apt-cache policy xchat libc6 libstdc++ ?

L'idée étant de remettre libc6 et libstdc++ à la bonne version de
Kubuntu que tu utilisais (quelle était-elle ?)


Fallait que je me plante une première fois pour savoir que c'était pas
aussi simple que ça en avait l'air ;-)


Contenu de /etc/apt/sources.list ?


(mes excuses par avance, je sais que c'est le bazar, qu'il y en a
beaucoup trop et que j'ai sûrement fait des trucs qu'il fallait pas !
:-s)

deb http://altruistic.lbl.gov/mirrors/ubuntu/ hardy main
deb http://ubuntu.intergenia.de/releases/kubuntu/ gutsy main
deb http://security.ubuntu.com/ubuntu/ dapper main
deb http://security.ubuntu.com/ubuntu/ hardy main
deb http://mirror.x10.com/mirror/ubuntu/ dapper main

deb http://mirrors.kernel.org/ubuntu/ dapper main
deb http://public.planetmirror.com/pub/ubuntu/archive/ dapper main
deb ftp://ftp.free.fr/mirrors/ftp.ubuntu.com/ubuntu/ dapper main
deb http://ftp.crihan.fr/ubuntu/ dapper main


## Dépôts binaires officiels (les dépôts multiverse ne sont pas
supportés par Cannonical et doivent être utilisés à vos propres
risques)
deb http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted
universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-security main
restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main
restricted universe multiverse

## Dépôts source officiels (rarement utiles pour l'utilisateur final
-- supprimez les # pour les activer)
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted
universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-updates main
restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-security main
restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main
restricted universe multiverse
# deb-src http://archive.ubuntu.com/ubuntu dapper-backports main
universe multiverse restricted

## Dépôt PLF (ce dépôt n'est pas supporté par Cannonical et doit
être utilisé à vos propres risques)
#deb http://packages.freecontrib.org/ubuntu/plf/ dapper free non-free
#deb-src http://packages.freecontrib.org/ubuntu/plf/ dapper free
non-free

## Spécifiques à KDE
# KDE (ce dépôt fournit la dernière version de KDE)
deb http://kubuntu.org/packages/kde-latest dapper main

# KOffice (ce dépôt fournit la dernière version de KOffice)
deb http://kubuntu.org/packages/koffice-latest/ dapper main

# Amarok (ce dépôt fournit la dernière version de Amarok)
deb http://kubuntu.org/packages/amarok-latest dapper main

#deb http://dl.sourceforge.net/sourceforge/jedit ./
#deb-src http://dl.sourceforge.net/sourceforge/jedit ./


deb http://asher256-repository.tuxfamily.org dapper main dupdate french
deb http://asher256-repository.tuxfamily.org ubuntu main dupdate french


deb http://archive.ubuntu.com/ubuntu dapper main restricted universe
multiverse
deb-src http://archive.ubuntu.com/ubuntu dapper main restricted
universe multiverse

deb http://archive.canonical.com/ubuntu dapper-commercial main

deb http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted
universe multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main
restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
multiverse
deb-src http://security.ubuntu.com/ubuntu dapper-security universe
multiverse



deb http://kubuntu.org/packages/kde-354 dapper main


deb
http://www.qtopia.org.cn/ftp/mirror/ftp.kde.org/Attic/koffice-1.6.0/kubuntu/
dapper main #pool-dapper/koffice/
# deb ftp://ftp.kde.org/pub/kde/stable/koffice-latest/kubuntu/ dapper
main



Contenu de /etc/apt/apt.conf s'il y en a un ?


Acquire::http::Proxy "false";
APT::Cache-Limit 125829120;

Sortie de apt-cache policy xchat libc6 libstdc++ ?


xchat:
Installed: (none)
Candidate: 2.6.6-0ubuntu1~dapper1
Version table:
2.6.6-0ubuntu1~dapper1 0
500 http://fr.archive.ubuntu.com dapper-backports/universe
Packages
500 http://archive.ubuntu.com dapper-backports/universe
Packages
2.6.1-0ubuntu2 0
500 http://fr.archive.ubuntu.com dapper/universe Packages
500 http://archive.ubuntu.com dapper/universe Packages
libc6:
Installed: 2.7-5ubuntu2
Candidate: 2.7-5ubuntu2
Version table:
*** 2.7-5ubuntu2 0
500 http://security.ubuntu.com hardy/main Packages
100 /var/lib/dpkg/status
2.6.1-6ubuntu2 0
500 http://altruistic.lbl.gov hardy/main Packages
2.3.6-0ubuntu20.5 0
500 http://fr.archive.ubuntu.com dapper-updates/main Packages
2.3.6-0ubuntu20 0
500 http://security.ubuntu.com dapper/main Packages
500 http://mirror.x10.com dapper/main Packages
500 http://mirrors.kernel.org dapper/main Packages
500 ftp://ftp.free.fr dapper/main Packages
500 http://ftp.crihan.fr dapper/main Packages
500 http://fr.archive.ubuntu.com dapper/main Packages
500 http://archive.ubuntu.com dapper/main Packages
libstdc++6:
Installed: 4.2.3-1ubuntu2
Candidate: 4.2.3-1ubuntu2
Version table:
*** 4.2.3-1ubuntu2 0
500 http://security.ubuntu.com hardy/main Packages
100 /var/lib/dpkg/status
4.2.2-3ubuntu3 0
500 http://altruistic.lbl.gov hardy/main Packages
4.0.3-1ubuntu5 0
500 http://security.ubuntu.com dapper/main Packages
500 http://mirror.x10.com dapper/main Packages
500 http://mirrors.kernel.org dapper/main Packages
500 ftp://ftp.free.fr dapper/main Packages
500 http://ftp.crihan.fr dapper/main Packages
500 http://fr.archive.ubuntu.com dapper/main Packages
500 http://archive.ubuntu.com dapper/main Packages

--
Olivier Ligny
www.virgal.net (mondes virtuels 3D)


Samuel Colin
Le #1917787
Dixit O.L :

Contenu de /etc/apt/sources.list ?


(mes excuses par avance, je sais que c'est le bazar, qu'il y en a
beaucoup trop et que j'ai sûrement fait des trucs qu'il fallait pas !
:-s)

Effectivement, y'a un peu trop de trucs.


deb http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu dapper-commercial main

Voilà à peu près ce que tu devrais laisser.

Si tu veux un paquet récent, il est possible qu'il se retrouve dans
dapper-backports. S'il n'y est pas, c'est qu'il est trop difficile à
rétroporter et qu'il peut être plus simple pour toi de mettre à jour ton
système à une nouvelle version.

xchat:
Installed: (none)
Candidate: 2.6.6-0ubuntu1~dapper1
2.6.6-0ubuntu1~dapper1 0
500 http://fr.archive.ubuntu.com dapper-backports/universe
2.6.1-0ubuntu2 0
500 http://fr.archive.ubuntu.com dapper/universe Packages
libc6:
Installed: 2.7-5ubuntu2
Candidate: 2.7-5ubuntu2
*** 2.7-5ubuntu2 0
500 http://security.ubuntu.com hardy/main Packages
2.3.6-0ubuntu20.5 0
500 http://fr.archive.ubuntu.com dapper-updates/main Packages
2.3.6-0ubuntu20 0
500 http://fr.archive.ubuntu.com dapper/main Packages
libstdc++6:
Installed: 4.2.3-1ubuntu2
Candidate: 4.2.3-1ubuntu2
*** 4.2.3-1ubuntu2 0
500 http://security.ubuntu.com hardy/main Packages
4.0.3-1ubuntu5 0
500 http://fr.archive.ubuntu.com dapper/main Packages

Donc tu as installé des bouts cruciaux d'une version d'Ubuntu sur une

plus vieille (je suppose que tu es en Dapper). Fort du
/etc/apt/sources.list que je t'ai indiqué plus haut, tu feras d'abord un
"apt-get update"
Ensuite tenter un "apt-get -f install". Si le système n'est pas trop
confus il te proposera de réinstaller l'ancienne version de la libc6 et
de libstdc++6. Ce faisant il voudra peut-être enlever le logiciel que tu
tentais de faire fonctionner.
S'il suggère d'enlever plein de trucs et d'en remettre d'autres, il
faudra lui indiquer l'installation de la bonne version:
"apt-get install libc6=2.3.6-0ubuntu20.5 libstdc++6=4.0.3-1ubuntu5"
Une fois l'installation faite tu peux retenter un "apt-get -f install"
pour réparer ce qui peut être encore incohérent, et ça devrait aller.

Ensuite si tu veux vraiment avoir des versions récentes pour tes
logiciels, je te conseille de suivre les tutoriels de mises à jour
d'Ubuntu qu'on peut trouver via google.
Note que si tu veux aller jusqu'à la gutsy, il est préférable de passer
par toutes les étapes intermédiaires (dapper -> edgy -> feisty ->
gutsy). Il me semble que la hardy est encore en beta, donc 'vaut mieux
éviter pour le moment.


Fabien LE LEZ
Le #1917783
On Wed, 20 Feb 2008 18:25:30 +0100, Samuel Colin :

Note que si tu veux aller jusqu'à la gutsy, il est préférable de passer
par toutes les étapes intermédiaires (dapper -> edgy -> feisty ->
gutsy).


Ne serait-il pas plus simple et efficace d'installer un nouveau
système, quitte à sauvegarder d'abord la liste des paquets installés ?
(quoique... si cette liste est foireuse, c'est pas forcément une bonne
idée...)

Remettre à zéro le système de temps en temps, permet d'avoir la
dernière version des logiciels dont on a besoin et rien d'autre, et se
débarasser des vieux trucs bizarres dont on a oublié l'utilité.

Samuel Colin
Le #1917780
Dixit Fabien LE LEZ :
On Wed, 20 Feb 2008 18:25:30 +0100, Samuel Colin :

Note que si tu veux aller jusqu'à la gutsy, il est préférable de passer
par toutes les étapes intermédiaires (dapper -> edgy -> feisty ->
gutsy).


Ne serait-il pas plus simple et efficace d'installer un nouveau
système, quitte à sauvegarder d'abord la liste des paquets installés ?
(quoique... si cette liste est foireuse, c'est pas forcément une bonne
idée...)

Si, ça marche pas trop mal avec le tryptique dpkg --get-selections,

dpkg --set-selections, apt-get dselect-upgrade, et puisqu'il n'y a pas de
numéro de version sauvegardé, apt se débrouille comme un grand.

Remettre à zéro le système de temps en temps, permet d'avoir la
dernière version des logiciels dont on a besoin et rien d'autre, et se
débarasser des vieux trucs bizarres dont on a oublié l'utilité.

Oui, c'est juste que j'ai perdu depuis longtemps ce réflexe-là, ça

serait plus simple dans son cas. Au moins deux machines chez moi ont
comme base génétique l'une une Woody, l'autre une Potato.

Ma suggestion aurait l'attrait didactique de la mise à jour de système
complet et des réflexes à acquérir pour ce faire (regarder les pages de
conseils, découvrir que des logiciels ne sont plus packagés, etc).


Philippe Vessaire
Le #1917779
Fabien LE LEZ wrote:

On Wed, 20 Feb 2008 18:25:30 +0100, Samuel Colin :

Note que si tu veux aller jusqu'à la gutsy, il est préférable de
passer par toutes les étapes intermédiaires (dapper -> edgy -> feisty
-> gutsy).


Ne serait-il pas plus simple et efficace d'installer un nouveau
système, quitte à sauvegarder d'abord la liste des paquets installés ?
(quoique... si cette liste est foireuse, c'est pas forcément une bonne
idée...)

Remettre à zéro le système de temps en temps, permet d'avoir la
dernière version des logiciels dont on a besoin et rien d'autre, et se
débarasser des vieux trucs bizarres dont on a oublié l'utilité.


J'ai eu ici même deux lignes a utiliser dans un terminal
la première avant de tout réinstaller et la deuxièmes après
l'installation de base.
Je suppose que tu as une partition que tu conserves pour /home. C'est le
cas pour moi, c'est /home/philippe qui est mon répertoire perso.
Sinon, il faut passer par une disquette ou tout autre support.

en premier, avant de tout refaire
dpkg -l | grep ^ii | awk '{print $2}' > paquets.txt
Ça génère la liste de tous les paquets installés

ensuite
su root ou sudo -i
puis
for P in `cat /home/philippe/paquets.txt`; do apt-get -y install $P;
done

les deux lignes en une seule commande a modifier pour l'emplacement du
fichier paquets.txt ...

La nouvelle installation est alors à l'identique mais sans les
éventuelles scories qui ont pu s'accumuler.


a+
--
Volem rien foutre al païs!
Philippe Vessaire Ò¿Ó¬


Samuel Colin
Le #1917778
Dixit Philippe Vessaire :


en premier, avant de tout refaire
dpkg -l | grep ^ii | awk '{print $2}' > paquets.txt
Ça génère la liste de tous les paquets installés

dpkg --get-selections, presque, donc


ensuite
su root ou sudo -i
puis
for P in `cat /home/philippe/paquets.txt`; do apt-get -y install $P;
done

les deux lignes en une seule commande a modifier pour l'emplacement du
fichier paquets.txt ...

La nouvelle installation est alors à l'identique mais sans les
éventuelles scories qui ont pu s'accumuler.

Ton script relance apt-get pour chaque paquet, ce qui fait au moins autant

de lectures de la base de données de paquets installés.
Ma solution (cf mon autre message, à côté) ne lance apt-get qu'une seule
fois, ce qui ne fait lire la base des paquets qu'autant de fois que
nécessaire pour apt-get. C'est donc plus rapide et moins dur sur les
accès disques.

VgA
Le #1917770
Samuel Colin wrote:
Dixit O.L :
Contenu de /etc/apt/sources.list ?
(mes excuses par avance, je sais que c'est le bazar, qu'il y en a

beaucoup trop et que j'ai sûrement fait des trucs qu'il fallait pas !
:-s)

Effectivement, y'a un peu trop de trucs.


deb http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu dapper-commercial main

Voilà à peu près ce que tu devrais laisser.



Trop fort !
J'ai nettoyé mon fichier /etc/apt/sources.list en laissant juste ce que
tu m'as donné (en enlevant les # devant les deb-src), et miracle, plus
aucun problème :-)
Le <apt-get -f install> n'a plus rien trouvé d'incohérent, et le
<apt-get install xchat> s'est déroulé sans aucun soucis ni truc bizarre.

Merci beaucoup !

Ensuite si tu veux vraiment avoir des versions récentes pour tes
logiciels, je te conseille de suivre les tutoriels de mises à jour
d'Ubuntu qu'on peut trouver via google.


OK je vais potasser le sujet pour essayer de mieux comprendre comment ça
marche, afin de ne pas reproduire les mêmes erreurs.
Je ne savais pas qu'il était dangereux d'utiliser des paquets venant
d'une autre version d'Ubuntu (effectivement je suis en Dapper).



Samuel Colin
Le #1917769
Dixit VgA :

J'ai nettoyé mon fichier /etc/apt/sources.list en laissant juste ce que
tu m'as donné (en enlevant les # devant les deb-src), et miracle, plus
aucun problème :-)
Le <apt-get -f install> n'a plus rien trouvé d'incohérent, et le
<apt-get install xchat> s'est déroulé sans aucun soucis ni truc bizarre.

Certes, mais tu as toujours des versions très récentes de la libc6 et

d'autres choses, je pense. La rétrocompatibilité fait que ça marche
bien, mais tout problème un peu bizarre de fonctionnement pourra être
lié à ça.

Publicité
Poster une réponse
Anonyme