problèmes entre VLC et QuickTime

Le
paul.rimel
Bonjour à tous,
J'utilise VLC depuis pas mal de temps mais depuis 3 jours à chaque
fois que je lance un DVD ou un .avi ou un flux de ma freebox VLC
affiche un écran noir, le son est chaotique et quelque seconde après
il plante.
Quand j'édite le rapport de bug, il semble que cela vienne d'un
component de QuickTime.
Voici ce que dit le rapport (comme c'est très long, je n'en mets qu'un
extrait, j'espère qu'il est suffisant) :
Thread 12 Crashed:
0 ple.QuickTimeH264.component 0x8abf5614
JVTDecoComponentDispatch + 0x124
1 ple.QuickTimeH264.component 0x8abf560c
JVTDecoComponentDispatch + 0x11c
2 ple.CoreServices.CarbonCore 0x902b2054
CallComponentFunctionCommon + 0x414
3 ple.CoreServices.CarbonCore 0x902b0df0 CallComponent + 0x10c
4 ple.CoreServices.CarbonCore 0x902ca014 CallComponentClose +
0x28
5 ple.CoreServices.CarbonCore 0x902bcc0c
CloseComponentInternal(ComponentInstanceRecord*) + 0x6c
6 ple.CoreServices.CarbonCore 0x902c23ec CloseComponent + 0x30
7 ple.CoreServices.CarbonCore 0x902bb0c0 OpenAComponent + 0x248
8 ple.CoreServices.CarbonCore 0x902d9060 OpenComponent + 0x14
9 ple.CoreServices.CarbonCore 0x902b0e10 CallComponent + 0x12c
10 ple.CoreServices.CarbonCore 0x902f2b84
CallComponentGetPublicResource + 0x30
11 com.apple.QuickTime 0x94fcb5fc cchaMissing + 0x15c
12 ple.CoreServices.CarbonCore 0x902c2024
GetComponentPublicResourceList + 0x1b8
13 com.apple.QuickTime 0x94fcb2d8
startUsingCachedCodecCharacterizations + 0x138
14 com.apple.QuickTime 0x94fca9b0 FindBestChain + 0x30
15 com.apple.QuickTime 0x94fc9454 ICMSequenceGetChain +
0x1e4
16 com.apple.QuickTime 0x94fc2498 DoBandedDecompress +
0x1168
17 com.apple.QuickTime 0x9518ec18 ICMAction_aligned +
0x558
18 com.apple.QuickTime 0x94fc10fc ICMDeviceLoop + 0xdec
19 com.apple.QuickTime 0x94fc8ae4
DecompressSequenceFrameWhen + 0x364
20 org.videolan.vlc 0x000412ac DisplayVideo + 0xa8
21 org.videolan.v
lc 0x000ebd14 RunThread + 0x840
22 libSystem.B.
dylib 0x90024930 _pthread_body + 0x28

PPC Thread State:
srr0: 0x8abf5614 srr1: 0x0000d030 vrsave: 0x00000000
cr: 0x22824484 xer: 0x00000004 lr: 0x8abf560c ctr: 0x90001a04
r0: 0x8abf560c r1: 0xf05e9fc0 r2: 0xa00016b4 r3: 0x00000000
r4: 0x00000000 r5: 0x8abf55e0 r6: 0x00000000 r7: 0x000003f0
r8: 0x00000001 r9: 0x00000000 r10: 0xf05ea170 r11: 0xa000457c
r12: 0x90001a04 r13: 0x44822222 r14: 0x00000000 r15: 0x17d65000
r16: 0x00000000 r17: 0x00000000 r18: 0x02a36428 r19: 0xf05ea53c
r20: 0x00000001 r21: 0x63636861 r22: 0x00000001 r23: 0x000003f0
r24: 0x00000002 r25: 0x8abf55e0 r26: 0x17c24000 r27: 0x00000004
r28: 0x00000000 r29: 0xf05ea17c r30: 0x17c24000 r31: 0x8abf55f0


Qu'est-ce que je peux faire ?
J'ai réinstallé QuickTime, cela n'a servi à rien.

Est ce quelqu'un comprend ce qui ce passe ? et puisse me dire comment
me sortir de ce problème.
Je remercie toutes les personnes qui prendront la peine de me
répondre.
Paul
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
blanc
Le #3196891

J'utilise VLC depuis pas mal de temps mais depuis 3 jours à chaque
fois que je lance un DVD ou un .avi ou un flux de ma freebox VLC
affiche un écran noir, le son est chaotique et quelque seconde après
il plante.


Dans ton autre fil, tu dis que tu as réinstallé VLC :
j'ai jeté le VLC que j'avais, j'ai téléchargé une version 0.8.6f


Quelle était la version précédente ? Perso, je suis en 0.8.6e, et vu tes
pbs, pas envie de passer en f...


Quand j'édite le rapport de bug, il semble que cela vienne d'un
component de QuickTime.
Voici ce que dit le rapport (comme c'est très long, je n'en mets qu'un
extrait, j'espère qu'il est suffisant) :
Thread 12 Crashed:
0 ...ple.QuickTimeH264.component 0x8abf5614
JVTDecoComponentDispatch + 0x124
1 ...ple.QuickTimeH264.component 0x8abf560c
[snip...]

PPC Thread State:
srr0: 0x8abf5614 srr1: 0x0000d030 vrsave: 0x00000000
cr: 0x22824484 xer: 0x00000004 lr: 0x8abf560c ctr: 0x90001a04
r0: 0x8abf560c r1: 0xf05e9fc0 r2: 0xa00016b4 r3: 0x00000000
r4: 0x00000000 r5: 0x8abf55e0 r6: 0x00000000 r7: 0x000003f0
r8: 0x00000001 r9: 0x00000000 r10: 0xf05ea170 r11: 0xa000457c
r12: 0x90001a04 r13: 0x44822222 r14: 0x00000000 r15: 0x17d65000
r16: 0x00000000 r17: 0x00000000 r18: 0x02a36428 r19: 0xf05ea53c
r20: 0x00000001 r21: 0x63636861 r22: 0x00000001 r23: 0x000003f0
r24: 0x00000002 r25: 0x8abf55e0 r26: 0x17c24000 r27: 0x00000004
r28: 0x00000000 r29: 0xf05ea17c r30: 0x17c24000 r31: 0x8abf55f0


Vu les adresses, je serai tenté de dire pb au début du premier module
(QT H264) et la question que je me pose, c'est pourquoi ce module y
est-il deux fois ?
Sinon, si c'est au début du module, cela laisserait supposer que les
instructions de ce module sont absentes, mais je ne peux en dire plus
car je ne connais pas la structure du registre srr1 (qui est en fait la
copie du registre msr).

Autre question qui me vient à l'esprit alors :
Tu dis que ça ne marche plus depuis trois jours. Te souviens-tu avoir
installé qque chose (un codec ou un composant QT) ce jour là ?

Qu'est-ce que je peux faire ?
J'ai réinstallé QuickTime, cela n'a servi à rien.


Si tu as installé quelque chose, essayer de le désinstaller, et
éventuellement de le réinstaller. Sinon, peut-être essayer de
réinstaller une version plus ancienne de VLC...

--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE

Patrick Stadelmann
Le #3196781
In article (JiPaul) wrote:

Vu les adresses, je serai tenté de dire pb au début du premier module
(QT H264) et la question que je me pose, c'est pourquoi ce module y
est-il deux fois ?


C'est un backtrace, donc c'est normal qu'il y soit plusieurs fois. C'est
la liste des appels de fonctions qui ont conduit le programme à
l'endroit où il a planté. En l'occurrence, les deux derniers appels
avant le crash étaient dans le même module.

Patrick
--
Patrick Stadelmann
blanc
Le #3196691
Patrick Stadelmann
C'est un backtrace, donc c'est normal qu'il y soit plusieurs fois. C'est
la liste des appels de fonctions qui ont conduit le programme à
l'endroit où il a planté. En l'occurrence, les deux derniers appels
avant le crash étaient dans le même module.


OK je n'avais pas perçu ça :-)
Donc il reste à savoir quel problème il a trouvé à l'adresse
0x8abf5614...
--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE

Patrick Stadelmann
Le #3196651
In article (JiPaul) wrote:

Patrick Stadelmann
C'est un backtrace, donc c'est normal qu'il y soit plusieurs fois. C'est
la liste des appels de fonctions qui ont conduit le programme à
l'endroit où il a planté. En l'occurrence, les deux derniers appels
avant le crash étaient dans le même module.


OK je n'avais pas perçu ça :-)
Donc il reste à savoir quel problème il a trouvé à l'adresse
0x8abf5614...


Le type de problème est indiqué au début du log, sous "Exception".

Le truc étrange cependant c'est que VLC devrait il me semble décoder
tout seul le H.264 et ne pas pas passer par QT.

Patrick
--
Patrick Stadelmann

paul.rimel
Le #3196531
Bon, j'ai suivi les conseils, j'ai téléchargé VLC 0.8.5, mais j'ai le
même problème.
Dans le rapport de bug c'est toujours Qt H264 qui est en cause.
Je ne m'en sors vraiment pas.
Qu'est-ce que je pourrais faire ?
Merci de m'aider
Paul
blanc
Le #3196281

Bon, j'ai suivi les conseils, j'ai téléchargé VLC 0.8.5, mais j'ai le
même problème.


Et la question sur des trucs (codecs, composants QT, que sais-je...)
installés, tu n'as pas de réponses ?

Dans le rapport de bug c'est toujours Qt H264 qui est en cause.
Je ne m'en sors vraiment pas.


Et l'exception, indiquée au début du log, comme le dit Patrick, c'est
quoi ?

--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE

Publicité
Poster une réponse
Anonyme