Procédure stocké qui ne me renvoit pas la meme valeur qu'un sele ct

Le
Telynor
Bonjour,

j'ai un petit soucis avec une procédure stockée.

Voici mon code :

[code]
ALTER PROCEDURE [dbo].[GetNegociatePrice]
(
@ClientID NVARCHAR
)

AS

SELECT *
FROM NegociatePrice_View
WHERE ClientID = @ClientID[/code]

Si je fais

[code]
exec GetNegociatePrice '411ALFER'
[/code]

Ma procédure ne renvoit aucun résultat


Hors si je fais la requete suivante

[code]
SELECT *
FROM NegociatePrice_View
WHERE ClientID = '411ALFER'
[/code]

j'obtiens des résultats.

Il doit y avoir un truc qui m'echappe mais vraiment je ne vois pas quoi.

Si vous avez des idées qui peuvent m'aider n'hesitez pas.

D'avance merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe TROTIN [MS]
Le #11866811
Bonjour,

C'est l'entête de votre procédure qui doit pécher (vous n'avez pas spécifié
de taille pour votre paramètre NVARCHAR :

ALTER PROCEDURE [dbo].[GetNegociatePrice]
(
@ClientID NVARCHAR(100)
)



Cordialement
_______________________________

Philippe TROTIN
Microsoft Services France
_______________________________

"Telynor" groupe de discussion :
Bonjour,

j'ai un petit soucis avec une procédure stockée.

Voici mon code :

[code]
ALTER PROCEDURE [dbo].[GetNegociatePrice]
(
@ClientID NVARCHAR
)

AS

SELECT *
FROM NegociatePrice_View
WHERE ClientID = @ClientID[/code]

Si je fais

[code]
exec GetNegociatePrice '411ALFER'
[/code]

Ma procédure ne renvoit aucun résultat


Hors si je fais la requete suivante

[code]
SELECT *
FROM NegociatePrice_View
WHERE ClientID = '411ALFER'
[/code]

j'obtiens des résultats.

Il doit y avoir un truc qui m'echappe mais vraiment je ne vois pas quoi.

Si vous avez des idées qui peuvent m'aider n'hesitez pas.

D'avance merci


Telynor
Le #11866781
Bien vu !

Merci beaucoup



"Philippe TROTIN [MS]" a écrit :

Bonjour,

C'est l'entête de votre procédure qui doit pécher (vous n'avez pas spécifié
de taille pour votre paramètre NVARCHAR :

> ALTER PROCEDURE [dbo].[GetNegociatePrice]
> (
> @ClientID NVARCHAR(100)
> )

Cordialement
_______________________________

Philippe TROTIN
Microsoft Services France
_______________________________

"Telynor" groupe de discussion :
> Bonjour,
>
> j'ai un petit soucis avec une procédure stockée.
>
> Voici mon code :
>
> [code]
> ALTER PROCEDURE [dbo].[GetNegociatePrice]
> (
> @ClientID NVARCHAR
> )
>
> AS
>
> SELECT *
> FROM NegociatePrice_View
> WHERE ClientID = @ClientID[/code]
>
> Si je fais
>
> [code]
> exec GetNegociatePrice '411ALFER'
> [/code]
>
> Ma procédure ne renvoit aucun résultat
>
>
> Hors si je fais la requete suivante
>
> [code]
> SELECT *
> FROM NegociatePrice_View
> WHERE ClientID = '411ALFER'
> [/code]
>
> j'obtiens des résultats.
>
> Il doit y avoir un truc qui m'echappe mais vraiment je ne vois pas quoi.
>
> Si vous avez des idées qui peuvent m'aider n'hesitez pas.
>
> D'avance merci



Philippe TROTIN [MS]
Le #11866741
C'était avec plaisir :-)


Cordialement
_______________________________

Philippe TROTIN
Microsoft Services France
_______________________________

"Telynor" groupe de discussion :
Bien vu !

Merci beaucoup



"Philippe TROTIN [MS]" a écrit :

Bonjour,

C'est l'entête de votre procédure qui doit pécher (vous n'avez pas
spécifié
de taille pour votre paramètre NVARCHAR :

> ALTER PROCEDURE [dbo].[GetNegociatePrice]
> (
> @ClientID NVARCHAR(100)
> )

Cordialement
_______________________________

Philippe TROTIN
Microsoft Services France
_______________________________

"Telynor" groupe de discussion :

> Bonjour,
>
> j'ai un petit soucis avec une procédure stockée.
>
> Voici mon code :
>
> [code]
> ALTER PROCEDURE [dbo].[GetNegociatePrice]
> (
> @ClientID NVARCHAR
> )
>
> AS
>
> SELECT *
> FROM NegociatePrice_View
> WHERE ClientID = @ClientID[/code]
>
> Si je fais
>
> [code]
> exec GetNegociatePrice '411ALFER'
> [/code]
>
> Ma procédure ne renvoit aucun résultat
>
>
> Hors si je fais la requete suivante
>
> [code]
> SELECT *
> FROM NegociatePrice_View
> WHERE ClientID = '411ALFER'
> [/code]
>
> j'obtiens des résultats.
>
> Il doit y avoir un truc qui m'echappe mais vraiment je ne vois pas
> quoi.
>
> Si vous avez des idées qui peuvent m'aider n'hesitez pas.
>
> D'avance merci





Publicité
Poster une réponse
Anonyme