programmation d'une rechercheV

Le
lnh2o
Bonjour,
je cherche à mettre dans des cellules le résultat d'une recherche vreticale
où :
-la valeur à chercher
-la valeur de coloçnne dans laquelle récupérer le résultat de la recherche
dépendent de la ligne dans laquelle je mets le résultat de recherche.

ainsi, j'ai essayer :
Worksheets("tableau récapitulatif").Range("J" & m).Value = "=RECHERCHEV(B"
&m& ";$P$30:$AB$45;" &a& ")"

qui ne fonctionne pas
Je vous remercie d'avance pour votre aide !

PS : si en plus vous pouvez me dire comment programmer une recherche sans
avoir besoin de passer par les cellules du tableurs, mais en récupérant
directement le résultat dans une variable, ce serait encore mieux !!!!
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel
Le #4909821
Bonjour.
Worksheets("tableau récapitulatif").Range("J" & m).FormulaLocal = _
"=RECHERCHEV(B" & m & ";$P$30:$AB$45;" & a & ")"
ou directement :
Resultat = Application.VLookup(Cells(m, 2), _
Sheets("tableau récapitulatif").Range("P30:AB45"), a)
Cordialement.
Daniel
"lnh2o"
Bonjour,
je cherche à mettre dans des cellules le résultat d'une recherche
vreticale
où :
-la valeur à chercher
-la valeur de coloçnne dans laquelle récupérer le résultat de la recherche
dépendent de la ligne dans laquelle je mets le résultat de recherche.

ainsi, j'ai essayer :
Worksheets("tableau récapitulatif").Range("J" & m).Value = "=RECHERCHEV(B"
&m& ";$P$30:$AB$45;" &a& ")"

qui ne fonctionne pas...
Je vous remercie d'avance pour votre aide !

PS : si en plus vous pouvez me dire comment programmer une recherche sans
avoir besoin de passer par les cellules du tableurs, mais en récupérant
directement le résultat dans une variable, ce serait encore mieux !!!!




JP25
Le #4909781
Bonjour,
Essai cece
Sub b()
m = 1
a = 1
Sheets(1).Range("J" & m) = "=VLOOKUP(B" & m & ",$P$30:$AB$45," & a & ")"
End Sub
Le résultat de ta recherce se trouve dans la cellule de ta formule

--
Cordialement
JP25


"lnh2o"
Bonjour,
je cherche à mettre dans des cellules le résultat d'une recherche
vreticale
où :
-la valeur à chercher
-la valeur de coloçnne dans laquelle récupérer le résultat de la recherche
dépendent de la ligne dans laquelle je mets le résultat de recherche.

ainsi, j'ai essayer :
Worksheets("tableau récapitulatif").Range("J" & m).Value = "=RECHERCHEV(B"
&m& ";$P$30:$AB$45;" &a& ")"

qui ne fonctionne pas...
Je vous remercie d'avance pour votre aide !

PS : si en plus vous pouvez me dire comment programmer une recherche sans
avoir besoin de passer par les cellules du tableurs, mais en récupérant
directement le résultat dans une variable, ce serait encore mieux !!!!




Publicité
Poster une réponse
Anonyme