Publier une animation Flash

Le
malar1954
Bonjour,
Lorsque je test mon animation Flash, les URL que j'ai ins?r?es fonctionnent et
les liens se font. Mais si je publie mon animation, les URL ne fonctionnent
pas. Comment r?gler ce probl?me.
J'utilise Flash MX V.6
Merci:beer;
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Alain FORGERIT
Le #16919211
bonjour,

et quelles sont les urls que tu définis ?

bien à toi


"malar1954" f2cr3s$rl9$
Bonjour,
Lorsque je test mon animation Flash, les URL que j'ai ins?r?es
fonctionnent et
les liens se font. Mais si je publie mon animation, les URL ne
fonctionnent
pas. Comment r?gler ce probl?me.
J'utilise Flash MX V.6
Merci:beer;



Pierre Cassez
Le #16919181
Faire attention aux URL absolues et relatives.
Mieux vaut utiliser des url relatives. Relatives à quoi ? A la racine du
site.
Ce qui fonctionne en local, doit pouvoir fonctionner en production.
exemples:
url absolue :
1. http://www.domaine_public.com/chemin/fichier.htm
différent de
2. http://domaine_prive.en_local.net/chemin/fichier.htm

url relatives à la racine d'un site : "/chemin/fichier.htm" fonctionnera sur
1. et 2.

remarque, en PHP include_once() utilise le chemin complet du fichier sur le
serveur.
include_once('/chemin/fichier.php') ; ne fonctionne pas !
Il faut indiquer le chemin complet de la racine du site
La variable d'environnement $_SERVER['DOCUMENT_ROOT'] est en général
correcte (mais pas toujours)
Donc, c'est include_once($_SERVER['DOCUMENT_ROOT'] . '/chemin/fichier.php')
; qui fonctionnera.
Si cette commande ne fonctionne pas, le message d'erreur qui s'en suit vous
fournit une adresse de fichier qui contient tout le chemin physique du
répertoire racine de votre site. Vous pouvez donc redéfinir
$_SERVER['DOCUMENT_ROOT'] en fonction de l'environnement dans lequel tourne
votre script (en local et en production). Ce qui vous permet de programmer
des scripts fonctionnant tant d'un côté que de l'autre.


"malar1954" f2cr3s$rl9$
Bonjour,
Lorsque je test mon animation Flash, les URL que j'ai ins?r?es
fonctionnent et
les liens se font. Mais si je publie mon animation, les URL ne
fonctionnent
pas. Comment r?gler ce probl?me.
J'utilise Flash MX V.6
Merci:beer;



Publicité
Poster une réponse
Anonyme