Publipostage

Le
Pinson
Bonjour,
J'ai un problème avec mon publipostage. Je travaille avec la suite office
2003. Je vais chercher mes adresse dans Access. Quand je fais ma fusion, mes
adresses apparaissent correctement sauf le code postal dont il manque
l'espace après les 3 premiers caractères. J'ai vérifié dans ma base de
données Access et le code postal y est inscrit correctement. Je ne sais
vraiment plus où chercher.

Merci à l'avance de votre aide

Pinson
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tisane
Le #1658943
Bonjour Pinson,

J'ai un problème avec mon publipostage. Je travaille avec la suite office
2003. Je vais chercher mes adresse dans Access. Quand je fais ma fusion,
mes
adresses apparaissent correctement sauf le code postal dont il manque
l'espace après les 3 premiers caractères. J'ai vérifié dans ma base de
données Access et le code postal y est inscrit correctement. Je ne sais
vraiment plus où chercher.


Je suppose que tu parles plutôt de l'espace après les 2 premiers caractères
s'il s'agit d'un code postal français.
Si je peux me permettre, l'espace est déconseillé dans un code postal et
perturbe les tris automatiques.
"Rédaction des adresses"
http://laposte-portail.cvf.fr/particulier_envoyez_recevez_du_courrier_offres_conseils_pas_pas_redaction_adresses_334.html

Cela dit, pour répondre quand même à ta question, tu as 3 possibilités pour
résoudre ce problème :

1. Dans Word :
Ajouter au code de champ (que l'on affiche/masque avec <Alt><F9>) le
commutateur suivant :
{ MERGEFIELD TonChamp # "00 000" }

2. Impose le protocole DDE :
- menu Outils | Options, onglet [Général],
- coche "Confirmation des conversions lors de l'ouverture"
- resélectionne ta source de données
- choisis DDE (Échange dynamique de données)

3. Dans Access, crée une requête imposant le format voulu sur le champ
numérique :
CP: Format([TonChamp];"00 000")

--
Tisane

Anacoluthe
Le #1658942
Bonjour !

'Pinson' nous a écrit ...
J'ai un problème avec mon publipostage. Je travaille avec la suite office
2003. Je vais chercher mes adresse dans Access. Quand je fais ma fusion, mes
adresses apparaissent correctement sauf le code postal dont il manque
l'espace après les 3 premiers caractères.


Vous ne dites pas pour quel pays. En France, il n'y a pas d'espace
dans le code postal et le champ est numérique.
Québec sans doute : le champ est alphanumérique (avec des lettres).
Vérifiez le bon format textuel du code postal dans la source de données
et la nature des champs de fusion avec Alt+F9 dans votre document
principal Word.

Anacoluthe
« Mieux vaut aller à la poste hériter qu'à la postérité. »
- Alexandre BREFFORT

Pinson
Le #1658927
Bonjour Tisane

merci pour ta réponse. Seulement, je n'ai pas mentionné que c'était un code
postal du Québec. Alors, est ce que je peux utiliser tes informations et
mettre 3 zéros au lieu de deux? Nous c'est un code alphanumérique
Ex: G2L 1B8

Merci

Pinson


Bonjour Pinson,

J'ai un problème avec mon publipostage. Je travaille avec la suite office
2003. Je vais chercher mes adresse dans Access. Quand je fais ma fusion,
mes
adresses apparaissent correctement sauf le code postal dont il manque
l'espace après les 3 premiers caractères. J'ai vérifié dans ma base de
données Access et le code postal y est inscrit correctement. Je ne sais
vraiment plus où chercher.


Je suppose que tu parles plutôt de l'espace après les 2 premiers caractères
s'il s'agit d'un code postal français.
Si je peux me permettre, l'espace est déconseillé dans un code postal et
perturbe les tris automatiques.
"Rédaction des adresses"
http://laposte-portail.cvf.fr/particulier_envoyez_recevez_du_courrier_offres_conseils_pas_pas_redaction_adresses_334.html

Cela dit, pour répondre quand même à ta question, tu as 3 possibilités pour
résoudre ce problème :

1. Dans Word :
Ajouter au code de champ (que l'on affiche/masque avec <Alt><F9>) le
commutateur suivant :
{ MERGEFIELD TonChamp # "00 000" }

2. Impose le protocole DDE :
- menu Outils | Options, onglet [Général],
- coche "Confirmation des conversions lors de l'ouverture"
- resélectionne ta source de données
- choisis DDE (Échange dynamique de données)

3. Dans Access, crée une requête imposant le format voulu sur le champ
numérique :
CP: Format([TonChamp];"00 000")

--
Tisane





Pinson
Le #1658926
Bonjour Anacoluthe

Merci pour votre réponse. Je vais vérifier cela au bureau demain

by
Pinson


Bonjour !

'Pinson' nous a écrit ...
J'ai un problème avec mon publipostage. Je travaille avec la suite office
2003. Je vais chercher mes adresse dans Access. Quand je fais ma fusion, mes
adresses apparaissent correctement sauf le code postal dont il manque
l'espace après les 3 premiers caractères.


Vous ne dites pas pour quel pays. En France, il n'y a pas d'espace
dans le code postal et le champ est numérique.
Québec sans doute : le champ est alphanumérique (avec des lettres).
Vérifiez le bon format textuel du code postal dans la source de données
et la nature des champs de fusion avec Alt+F9 dans votre document
principal Word.

Anacoluthe
« Mieux vaut aller à la poste hériter qu'à la postérité. »
- Alexandre BREFFORT




Publicité
Poster une réponse
Anonyme