pygtk

Le
pierre
Bonjour,

J'utilise xubuntu 14.04 avec deux versions de python : 2.7 et 3.
La version 2.7 était native dans la distribution. J'ai ajouté ensuite
python 3.
Python 2.7 trouve la bibliothèque pygtk (paquet python-gtk2-dev.deb)
mais python3 ne le fait pas.
Comment puis-je gérer ce pb ?

Merci de vos réponse.

Pierre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas
Le #26392156
Bonjour,

Le 10/03/2016 15:06, pierre a écrit :
Bonjour,

J'utilise xubuntu 14.04 avec deux versions de python : 2.7 et 3.
La version 2.7 était native dans la distribution. J'ai ajouté ensuite
python 3.
Python 2.7 trouve la bibliothèque pygtk (paquet python-gtk2-dev.deb)
mais python3 ne le fait pas.
Comment puis-je gérer ce pb ?


En installant le package adapté à Python 3 ?

Ceci dit, il semblerait que le développement de PyGtk soit arrêté. Sur
le site officiel, la dernière version (2.24) date de 5 ans et il est
écrit que les utilisateurs sont encouragés à utiliser GTK+3 à travers
PyGObject.

Nicolas


Merci de vos réponse.

Pierre
Laurent Pointal
Le #26392168
Nicolas wrote:

Bonjour,

Le 10/03/2016 15:06, pierre a écrit :
Bonjour,

J'utilise xubuntu 14.04 avec deux versions de python : 2.7 et 3.
La version 2.7 était native dans la distribution. J'ai ajouté ensuite
python 3.
Python 2.7 trouve la bibliothèque pygtk (paquet python-gtk2-dev.deb)
mais python3 ne le fait pas.
Comment puis-je gérer ce pb ?


En installant le package adapté à Python 3 ?



Sous xUbuntu les packages pour Python 3 sont simplement nommés python3-xxxx.

Et en python3-gtk* je ne vois que python3-gtkspellcheck.

Ce qui semble confirmé par ce qu'écrit Nicolas ci-dessous.

Ceci dit, il semblerait que le développement de PyGtk soit arrêté. Sur
le site officiel, la dernière version (2.24) date de 5 ans et il est
écrit que les utilisateurs sont encouragés à utiliser GTK+3 à travers
PyGObject.



J'ai essayé via pip dans un virutalenv… pas une grande réussite:

:~$ mkvirtualenv -p /usr/bin/python3 testpygtk
Running virtualenv with interpreter /usr/bin/python3
Using base prefix '/usr'
New python executable in testpygtk/bin/python3
Also creating executable in testpygtk/bin/python
Installing setuptools, pip...done.
(testpygtk):~$ pip install pygtk
Downloading/unpacking pygtk
Downloading pygtk-2.24.0.tar.bz2 (2.4MB): 2.4MB downloaded
Running setup.py
(path:/home/laurent/.virtualenvs/testpygtk/build/pygtk/setup.py) egg_info
for package pygtk
********************************************************************
* Building PyGTK using distutils is only supported on windows. *
* To build PyGTK in a supported way, read the INSTALL file. *
********************************************************************
Complete output from command python setup.py egg_info:
********************************************************************

* Building PyGTK using distutils is only supported on windows. *

* To build PyGTK in a supported way, read the INSTALL file. *

********************************************************************

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in
/home/laurent/.virtualenvs/testpygtk/build/pygtk
Storing debug log for failure in /home/laurent/.pip/pip.log

A+
Laurent.
pierre
Le #26392275
Le 10/03/2016 18:35, Laurent Pointal a écrit :
Nicolas wrote:

Bonjour,

Le 10/03/2016 15:06, pierre a écrit :
Bonjour,

J'utilise xubuntu 14.04 avec deux versions de python : 2.7 et 3.
La version 2.7 était native dans la distribution. J'ai ajouté ensuite
python 3.
Python 2.7 trouve la bibliothèque pygtk (paquet python-gtk2-dev.deb)
mais python3 ne le fait pas.
Comment puis-je gérer ce pb ?


En installant le package adapté à Python 3 ?



Sous xUbuntu les packages pour Python 3 sont simplement nommés python3-xxxx.

Et en python3-gtk* je ne vois que python3-gtkspellcheck.

Ce qui semble confirmé par ce qu'écrit Nicolas ci-dessous.

Ceci dit, il semblerait que le développement de PyGtk soit arrêté. Sur
le site officiel, la dernière version (2.24) date de 5 ans et il est
écrit que les utilisateurs sont encouragés à utiliser GTK+3 à travers
PyGObject.





Merci pour cette réponse : tout fonctionne parfaitement : le paquet
s'appelle python3-gi.deb. Il est déjà installé et python3 le trouve sans
soucis.

Pierre

J'ai essayé via pip dans un virutalenv… pas une grande réussite:

:~$ mkvirtualenv -p /usr/bin/python3 testpygtk
Running virtualenv with interpreter /usr/bin/python3
Using base prefix '/usr'
New python executable in testpygtk/bin/python3
Also creating executable in testpygtk/bin/python
Installing setuptools, pip...done.
(testpygtk):~$ pip install pygtk
Downloading/unpacking pygtk
Downloading pygtk-2.24.0.tar.bz2 (2.4MB): 2.4MB downloaded
Running setup.py
(path:/home/laurent/.virtualenvs/testpygtk/build/pygtk/setup.py) egg_info
for package pygtk
********************************************************************
* Building PyGTK using distutils is only supported on windows. *
* To build PyGTK in a supported way, read the INSTALL file. *
********************************************************************
Complete output from command python setup.py egg_info:
********************************************************************

* Building PyGTK using distutils is only supported on windows. *

* To build PyGTK in a supported way, read the INSTALL file. *

********************************************************************

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in
/home/laurent/.virtualenvs/testpygtk/build/pygtk
Storing debug log for failure in /home/laurent/.pip/pip.log

A+
Laurent.

Publicité
Poster une réponse
Anonyme