[Q] Comment analyser l'activité du CPU ?

Le
raph
Salut à tou(te)s,

Ayant toujours une pause de 3 secondes (toutes les 40" environ) lorsque
je fais de l'acquisition vidéo (et uniquement pour cette tâche), je
cherche un moyen d'identifier le problème, qui n'existe que depuis le
passage à X.4.9. Quelles pistes pouvez-vous m'indiquer ?

Merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe Sainte-Marie
Le #2170531
Le 27-03-2007, Raph
Salut à tou(te)s,

Ayant toujours une pause de 3 secondes (toutes les 40" environ) lorsque
je fais de l'acquisition vidéo (et uniquement pour cette tâche), je
cherche un moyen d'identifier le problème, qui n'existe que depuis le
passage à X.4.9. Quelles pistes pouvez-vous m'indiquer ?



--
Philippe Sainte-Marie
Techos dans un CMAA breton

patpro ~ Patrick Proniewski
Le #2170521
In article (Raph) wrote:

Salut à tou(te)s,

Ayant toujours une pause de 3 secondes (toutes les 40" environ) lorsque
je fais de l'acquisition vidéo (et uniquement pour cette tâche), je
cherche un moyen d'identifier le problème, qui n'existe que depuis le
passage à X.4.9. Quelles pistes pouvez-vous m'indiquer ?


délestage de la RAM vers le disque dur ?
Tu devrais pouvoir vérifier ça facilement en enlevant de RAM pour voir
si le délai entre deux pauses est plus court.

patpro

--
http://www.patpro.net/

raph
Le #2239401
Philippe Sainte-Marie
Salut à tou(te)s,

Ayant toujours une pause de 3 secondes (toutes les 40" environ) lorsque
je fais de l'acquisition vidéo (et uniquement pour cette tâche), je
cherche un moyen d'identifier le problème, qui n'existe que depuis le
passage à X.4.9. Quelles pistes pouvez-vous m'indiquer ?




Ah, très intéressant, même si je n'utilise pas Final Cut mais Televio
(de Meilenstein). Sans doute une nouvelle version en tiendra compte.


raph
Le #2239391
patpro ~ Patrick Proniewski
In article (Raph) wrote:

Salut à tou(te)s,

Ayant toujours une pause de 3 secondes (toutes les 40" environ) lorsque
je fais de l'acquisition vidéo (et uniquement pour cette tâche), je
cherche un moyen d'identifier le problème, qui n'existe que depuis le
passage à X.4.9. Quelles pistes pouvez-vous m'indiquer ?


délestage de la RAM vers le disque dur ?


Y a un moyen de l'empêcher ?

Tu devrais pouvoir vérifier ça facilement en enlevant de RAM pour voir
si le délai entre deux pauses est plus court.


En fait, d'après mes nombreux essais, la pause survient dans une
fourchette comprise entre 20" et 1'10". C'est très variable... Et si
c'est très fréquent, ce n'est pas systématique : une fois (seulement),
je n'ai pas eu de pause.
Embêtant...


Eric Levenez
Le #2239371
Le 27/03/07 19:14, dans « Raph »
patpro ~ Patrick Proniewski
délestage de la RAM vers le disque dur ?



Lance le Moniteur d'activité, onglet Mémoire système et regarde si le
nombre, après le slash sur la ligne Flux de pages, bouge.

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.


raph
Le #2239341
Eric Levenez
Le 27/03/07 19:14, dans
patpro ~ Patrick Proniewski
délestage de la RAM vers le disque dur ?



Lance le Moniteur d'activité, onglet Mémoire système et regarde si le
nombre, après le slash sur la ligne Flux de pages, bouge.


J'ai lancé Moniteur et en même temps j'ai enregistré via Televio, en
laissant ouvertes plusieurs autres applis, exprès (classement des 3
premières en % proc : Televio 40%/Firefox 30%/Safari 13%).

Le nombre en question, aux alentours de 80000 (le premier étant 84475)
est resté le même pendant presque 2', avant d'augmenter à plusieurs
reprises, jusqu'à 86000. Étrangement, la pause intempestive n'est
apparue que tardivement, et j'ai eu le temps de voir que le nombre
n'avait pas évolué à cet instant-là, mais un peu après.
Je ne sais pas si ça te dit quelque chose. J'ai remarqué aussi que la
mémoire disponible variait à la hausse et à la baisse, de 14 Mo env. à
30 Mo.
Autres données :
Taille MV : 7,98 à 8 Go
et :
Résidente : 130,9 Mo
Active : 649,9 Mo
Inactive : 479,72 Mo
Utilisée : 1,23 Go

2e essai, dans les mêmes conditions :
flux de pages :
début : 84489/86195
après 4'45" d'enregistrement : 84530/86195
(aucune pause constatée, ni augmentation du nombre)

3e essai :
début : 84562/86195
après 2'09" d'enregistrement : 84580/86264, après être passé de 86232 à
86262 en moins de 10 secondes.
Dans cet essai, une pause de 2" à 1'4", puis une pause de 3" à 2'08",
après laquelle j'ai arrêté l'enregistrement.

Hope this help :)



Eric Levenez
Le #2239321
Le 27/03/07 21:42, dans
J'ai lancé Moniteur et en même temps j'ai enregistré via Televio, en
laissant ouvertes plusieurs autres applis, exprès (classement des 3
premières en % proc : Televio 40%/Firefox 30%/Safari 13%).


Tu fais de l'acquisition en chargeant ta machine avec Firefox et Safari ?
Refais un essais avec le minium de programme pour voir si cela vient de la
mise à jour Mac OS X 10.4.9 ou si c'est "juste" parce que ta machine est
trop chargée pour ce que tu lui demandes.

Le nombre en question, aux alentours de 80000 (le premier étant 84475)
est resté le même pendant presque 2'


Pour les temps, on écrit s pour seconde et min pour minute.

, avant d'augmenter à plusieurs
reprises, jusqu'à 86000. Étrangement, la pause intempestive n'est
apparue que tardivement,


Pourquoi étrangement ? Si il n'y a pas un lien direct, c'est que c'est un
hasard.

et j'ai eu le temps de voir que le nombre
n'avait pas évolué à cet instant-là, mais un peu après.
Je ne sais pas si ça te dit quelque chose. J'ai remarqué aussi que la
mémoire disponible variait à la hausse et à la baisse, de 14 Mo env. à
30 Mo.


Comme tu swappes beaucoup, la mémoire disponible est au minium, ce qui est
normal vues les circonstances. Dès qu'il reste quelques Mo, le système
swappe pour libérer de la mémoire.

Autres données :
Taille MV : 7,98 à 8 Go
et :
Résidente : 130,9 Mo
Active : 649,9 Mo
Inactive : 479,72 Mo
Utilisée : 1,23 Go

2e essai, dans les mêmes conditions :
flux de pages :
début : 84489/86195
après 4'45" d'enregistrement : 84530/86195


Après 4 min 45 s tu n'avais pas swappé (86195 est constant).

(aucune pause constatée, ni augmentation du nombre)

3e essai :
début : 84562/86195
après 2'09" d'enregistrement : 84580/86264, après être passé de 86232 à
86262 en moins de 10 secondes.


Cela fait 32 pages de 4 ko écrites dans le swap, soit 128 ko, ce qui est
négligeable pour des disques qui savent écrire à plusieurs dizaines de Mo à
la seconde.

Dans cet essai, une pause de 2" à 1'4", puis une pause de 3" à 2'08",


Je sais que certains vont trouver que je pinailles, mais je n'arrive
vraiment pas à lire cette notation de mesure d'angle pour les temps.


après laquelle j'ai arrêté l'enregistrement.


Je ne pense pas que le swap soit la cause de ton ralentissement, même si je
trouve que tu swappes beaucoup.

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.

blanc
Le #2239261
Eric Levenez
Je sais que certains vont trouver que je pinailles,


Oui ;-) et pourtant je suis d'accord, mais c'est commode.

JPaul.
--
/==/==\- Jean-Paul BLANC
/ /--/--//\ quelque-part (somewhere)
|/| L |\ en (in)
/|| = |||\ FRANCE

Eric Levenez
Le #2239151
Le 28/03/07 0:06, dans
Eric Levenez
Je sais que certains vont trouver que je pinailles,


Oui ;-) et pourtant je suis d'accord, mais c'est commode.


Ce n'est pas commode, c'est illisible et faux.

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.


raph
Le #2174801
Eric Levenez
Le 27/03/07 21:42, dans
J'ai lancé Moniteur et en même temps j'ai enregistré via Televio, en
laissant ouvertes plusieurs autres applis, exprès (classement des 3
premières en % proc : Televio 40%/Firefox 30%/Safari 13%).


Tu fais de l'acquisition en chargeant ta machine avec Firefox et Safari ?
Refais un essais avec le minium de programme pour voir si cela vient de la
mise à jour Mac OS X 10.4.9 ou si c'est "juste" parce que ta machine est
trop chargée pour ce que tu lui demandes.


Disons que j'ai voulu me mettre dans les mêmes conditions que sous
X.4.8, où tout allait bien.

- Je viens de réessayer sans Safari ni Firefox : aucun swap, mais de
nouveau cette pause...

- Aucune appli hormis Televio et Moniteur d'activité (ah, et URL Manager
Pro, j'ai oublié de le fermer) : flux de page 21000/0 pendant 2min10s
puis hausse à 21000/220 et 21000/232. La pause survient ensuite, vers
2min40s.

Le nombre en question, aux alentours de 80000 (le premier étant 84475)
est resté le même pendant presque 2'


Pour les temps, on écrit s pour seconde et min pour minute.


Pan sur les doigts :)
Amusant, car je ne le sais que trop bien : j'ai fait pas mal de stats
avec des durées. Mais là, c'est pour aller plus vite.

, avant d'augmenter à plusieurs
reprises, jusqu'à 86000. Étrangement, la pause intempestive n'est
apparue que tardivement,


Pourquoi étrangement ? Si il n'y a pas un lien direct, c'est que c'est un
hasard.


Certes. Étrangement, relativement à la dizaine d'essais précédents, dans
lesquels la pause survenait bien plus tôt.

et j'ai eu le temps de voir que le nombre
n'avait pas évolué à cet instant-là, mais un peu après.
Je ne sais pas si ça te dit quelque chose. J'ai remarqué aussi que la
mémoire disponible variait à la hausse et à la baisse, de 14 Mo env. à
30 Mo.


Comme tu swappes beaucoup, la mémoire disponible est au minium, ce qui est
normal vues les circonstances. Dès qu'il reste quelques Mo, le système
swappe pour libérer de la mémoire.


Je comprends. Mais apparemment ce n'est pas la cause du problème.

snip pas swap

Cela fait 32 pages de 4 ko écrites dans le swap, soit 128 ko, ce qui est
négligeable pour des disques qui savent écrire à plusieurs dizaines de Mo à
la seconde.

Dans cet essai, une pause de 2" à 1'4", puis une pause de 3" à 2'08",


Je sais que certains vont trouver que je pinailles,


En tant que pinailleur moi-même également, je ne pinaillerai pas sur ton
"s" en trop ;)

Je ne pense pas que le swap soit la cause de ton ralentissement, même si je
trouve que tu swappes beaucoup.


Oui... Je suis désemparé. Merci quand même pour ton aide.


Publicité
Poster une réponse
Anonyme