[Q] Problème avec DiskWarrior

Le
yapersonne
Bonjour,
Depuis qq temps (mois!) j'ai un problème agaçant avec DW 3.03 sur mon
iMac G3 sous 10.3.9. DW se lance bien, fait le boulot demandé puis
affiche le message de bonne fin "xxx directory has been successfully
replaced" et là il plante et quitte.
J'ai essayé de virer tout ce qui de près ou de loin ressemble à DW ou
Alsoft soit peu de chose :

-com.Alsoft.DiskWarrior.prefs
-et DiskWarrior lui même

et de le ré-installer, sans succès.
Le crash log est comme tj incompréhensible mais semble parler d'un
"DiskWarriorDaemon" qui se trouve dans DW :

OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: DiskWarriorDaemon
Path:
/Applications/Utilities/DiskWarrior.app/Contents/MacOS/DiskWarriorDaemon
Version: ??? (???)
PID: 408
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000038

Thread 0 Crashed:
0 DiskWarriorDaemon 0x0000ca48 0x1000 + 0xba48
1 libSystem.B.dylib 0x900252f0 _sigtramp + 0x68
2 DiskWarriorDaemon 0x00011f6c 0x1000 + 0x10f6c
3 DiskWarriorDaemon 0x00002b88 0x1000 + 0x1b88
4 DiskWarriorDaemon 0x00002768 0x1000 + 0x1768
5 DiskWarriorDaemon 0x000025e8 0x1000 + 0x15e8


Y aurait-il qqch de pas net dans mon système plutôt que dans DW ?
Mais je n'ai aucun autre problème sur cette machine, TechTool Pro 4 est
très heureux, de même que les tests de préférences (Onyx, Preferential
Treatment).
Une dylib manquante.?
Quelqu'un a-t-il une idée ?
Merci
HC
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles
Le #2258941
Bonjour,
Depuis qq temps (mois!) j'ai un problème agaçant avec DW 3.03 sur mon
iMac G3 sous 10.3.9. DW se lance bien, fait le boulot demandé puis
affiche le message de bonne fin "xxx directory has been successfully
replaced" et là... il plante et quitte.


Il me semble que la version 3.03 soit faites pour 10.4, non ?

Donc soir revenir a 3.02, soit la version 4, soit passer a Panther

langmc
Le #2258851
Henri
Bonjour,
Depuis qq temps (mois!) j'ai un problème agaçant avec DW 3.03 sur mon
iMac G3 sous 10.3.9. DW se lance bien, fait le boulot demandé puis
affiche le message de bonne fin "xxx directory has been successfully
replaced" et là... il plante et quitte.
J'ai essayé de virer tout ce qui de près ou de loin ressemble à DW ou
Alsoft soit peu de chose :

-com.Alsoft.DiskWarrior.prefs
-et DiskWarrior lui même

et de le ré-installer, sans succès.
Le crash log est comme tj incompréhensible mais semble parler d'un
"DiskWarriorDaemon" qui se trouve dans DW :
=================================== > OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: DiskWarriorDaemon
Path:
/Applications/Utilities/DiskWarrior.app/Contents/MacOS/DiskWarriorDaemon
Version: ??? (???)
PID: 408
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000038

Thread 0 Crashed:
0 DiskWarriorDaemon 0x0000ca48 0x1000 + 0xba48
1 libSystem.B.dylib 0x900252f0 _sigtramp + 0x68
2 DiskWarriorDaemon 0x00011f6c 0x1000 + 0x10f6c
3 DiskWarriorDaemon 0x00002b88 0x1000 + 0x1b88
4 DiskWarriorDaemon 0x00002768 0x1000 + 0x1768
5 DiskWarriorDaemon 0x000025e8 0x1000 + 0x15e8
=================================== >
Y aurait-il qqch de pas net dans mon système plutôt que dans DW ?
Mais je n'ai aucun autre problème sur cette machine, TechTool Pro 4 est
très heureux, de même que les tests de préférences (Onyx, Preferential
Treatment).
Une dylib manquante....?
Quelqu'un a-t-il une idée ?
Merci
HC


Envoi ça à alsoft


--
Le sage montre la lune, l'imbécile regarde le doigt.

jperrocheau
Le #2258731
Mac Larinett
Depuis qq temps (mois!) j'ai un problème agaçant avec DW 3.03 sur mon
iMac G3 sous 10.3.9. DW se lance bien, fait le boulot demandé puis
affiche le message de bonne fin "xxx directory has been successfully
replaced" et là... il plante et quitte.


J'avais le même problème, je suis passé à la version 4


Oui, problème connu, juste une incompatibilité d'un fichier de son de
DiskWarrior 3.0.3 depuis une certaine version de QuickTime. Cela n'a pas
de conséquance sur la réparation du catalogue, juste la possibilité de
sauvegarder les rapports.

Voirci la réponse d'Alsoft en date du 09/06/2006:
---
DiskWarrior conflict with QuickTime still not resolved

A bug that causes DiskWarrior to unexpectedly quit at step 10 in the
rebuild process due to the presence of QuickTime has yet to be resolved
with the latest QuickTime releases or an update from Alsoft
(DiskWarrior's developer).

This issue was created with the installation of QuickTime 7.0.4 and
continues with QuickTime 7.1 and 7.1.1.

In the meantime, this issue can still be resolved via our previously
published workaround, as follows:
1. Quit DiskWarrior 3.0.3
2. Control click on DiskWarrior 3.0.3 and from the
contextual menu select "Show Package Contents"
3. Locate the "Complete.aiff" sound file - the path is: -
DiskWarrior 3.0.3.app -> Contents -> Resources -> Complete.aiff
4. Rename the "Complete.aiff" sound file "Alert
Complete.aiff" - then close ALL windows"

An Alsoft technical support representative states:

"We're disappointed that the issue wasn't fixed with the update to
QuickTime 7.1. We will have to work around this in a future version of
DiskWarrior.

"However, the actual DiskWarrior rebuild process is completed and the
crash will do no harm to your data. Thus, you could simply leave
DiskWarrior as is, and re-launch the software if you need to rebuild
another drive.'

For further coverage of this issue, see our DiskWarrior product page.
----


--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:


jperrocheau
Le #2258721
Gilles
Depuis qq temps (mois!) j'ai un problème agaçant avec DW 3.03 sur mon
iMac G3 sous 10.3.9. DW se lance bien, fait le boulot demandé puis
affiche le message de bonne fin "xxx directory has been successfully
replaced" et là... il plante et quitte.


Il me semble que la version 3.03 soit faites pour 10.4, non ?

Donc soir revenir a 3.02,


Non.

soit la version 4,


Oui.

soit passer a Panther


?? Voir mon post ci-dessus.


--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:


yaperson
Le #2258561
Jacques Perrocheau
Depuis qq temps (mois!) j'ai un problème agaçant avec DW 3.03



Oui, problème connu, juste une incompatibilité d'un fichier de son de
DiskWarrior 3.0.3 depuis une certaine version de QuickTime.


Ah, mais que voilà une excellente réponse!
Je n'ai pas eu l'idée de chercher chez Alsoft, plus ou moins persuadé
que j'étais que le pb était dans une mise à jour Apple (plutôt de
sécurité d'ailleurs car QT, fallait vraiment y penser!). Et chez Apple
je n'ai rien vu.
Je ne me faisais pas trop de soucis car DW faisait son boulot, mais on
ne sait jamais si ce n'est pas le début d'une voie d'eau.

Merci pour cette réponse
HC



Publicité
Poster une réponse
Anonyme