[Q] [ssh] connexion lente

Le
blanc
Bonjour à tous,

Je suis sous Tiger 10.4.11.

Je constate depuis quelque temps des connexions ssh (vers un mac mini,
par exemple) qui mettent plus d'une minute à s'établir. Ensuite une fois
la connexion établie, tout marche comme sur des roulettes.
Ce n'est pas un probleme de DNS, car host et ping me répondent eux
illico presto.
Je précise que je passe pour les vacances par une connexion wifi par
chez mon voisin (merci à lui) par l'intermédiaire de deux relai wifi, et
qu'il est possible que l'augmentation de délai date de la même époque.
Mais je ne vois pas bien la relation entre les deux.

En mettant l'option -v dans ma commande ssh, j'obtiens le log caché plus
bas (j'ai rajouté après *** des temps d'attente que j'ai chronométrés à
peu près. Les autres lignes sont affichées presque instantanément).

J'ai fait une recherche sur Google et fait des essais (désactivation de
ipV6 dans ssh_config ainsi que par l'option -4, désactivation de gssapi
par option -k, mais apparemment tout ceci est ignoré et j'obtiens
sensiblement la même chose.

Si quelqu'un

OpenSSH_5.1p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to xxxxx.dyndns.org [XX.XX.XX.XX] port 22.
debug1: Connection established.
debug1: identity file /Users/jpb/.ssh/id_rsa type -1
debug1: identity file /Users/jpb/.ssh/id_dsa type 2
debug1: Remote protocol version 1.99, remote software version
OpenSSH_5.1
debug1: match: OpenSSH_5.1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1
*** attente 15 secondes
debug1: Miscellaneous failure
No credentials cache found *** attente 15 secondes

debug1: Miscellaneous failure
No credentials cache found

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'xxxxx.dyndns.org' is known and matches the RSA host key.
debug1: Found key in /Users/jpb/.ssh/known_hosts:5
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue:
publickey,gssapi-keyex,gssapi-with-mic,password,keyboard-interactive
debug1: Next authentication method: gssapi-keyex
debug1: No valid Key exchange context
debug1: Next authentication method: gssapi-with-mic
*** attente 16 secondes
debug1: Miscellaneous failure
No credentials cache found
*** attente 18 secondes
debug1: Miscellaneous failure
No credentials cache found

debug1: Next authentication method: publickey
debug1: Offering public key: /Users/jpb/.ssh/id_dsa
debug1: Server accepts key: pkalg ssh-dss blen 433
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.


--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
blanc
Le #19981211
JiPaul
Si quelqu'un



Oups ! Oublié de finir ma phrase ;-)

Si quelqu'un a une idée de comment résoudre ce problème, je le
remercierai chaleureusement.

--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE
blanc
Le #20108761
JiPaul
Je constate depuis quelque temps des connexions ssh (vers un mac mini,
par exemple) qui mettent plus d'une minute à s'établir. Ensuite une fois
la connexion établie, tout marche comme sur des roulettes.
Ce n'est pas un probleme de DNS, car host et ping me répondent eux
illico presto.
Je précise que je passe pour les vacances par une connexion wifi par
chez mon voisin (merci à lui) par l'intermédiaire de deux relai wifi, et
qu'il est possible que l'augmentation de délai date de la même époque.
Mais je ne vois pas bien la relation entre les deux.

En mettant l'option -v dans ma commande ssh, j'obtiens le log caché plus
bas (j'ai rajouté après *** des temps d'attente que j'ai chronométrés à
peu près. Les autres lignes sont affichées presque instantanément).

J'ai fait une recherche sur Google et fait des essais (désactivation de
ipV6 dans ssh_config ainsi que par l'option -4, désactivation de gssapi
par option -k, mais apparemment tout ceci est ignoré et j'obtiens
sensiblement la même chose.



Alors ? aucune idée ?

--
JiPaul.
/ /--/--//\ Jean-Paul Blanc
|/| L |\ quelquepart en (somewhere in)
/|| = |||\ FRANCE
Publicité
Poster une réponse
Anonyme