QEMU et émulation de carte VGA standard

Le
Samy Mezani
Bonjour,

Je viens d'installer une Sid (amd64).

En testant Qemu, je me suis rendu compte que l'option "-vga std", pour
émuler une carte VGA standard, pose problème dans mon système invité.
Celui-ci (Win XP) ne semble pas reconnaître cette carte et reste
coincé dans une résolution 800x600x4 ! Avec la carte Cirrus émulée
(option -vga cirrus), j'obtiens une résolution normale pour cette carte
de 1024x768. Bon, en même temps, c'est pas gravissime, mais pas pratique
pour moi.

Ce problème ne se pose pas avec la même option sur Ubuntu Jaunty (x86)
par exemple, ou là j'obtiens avec "-vga std" une résolution 1280x800x24
sur mon système invité, idéale pour mon portable.

Un bug dans le paquet vgabios 0.6c-1 ? Je ne trouve pas grand chose à ce
sujet, à part chez Fedora
(https://bugzilla.redhat.com/show_bug.cgi?idI9060)

Si quelqu'un a des infos supplémentaires, merci d'avance.

Samy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Huhardeaux
Le #20124651
Samy Mezani a écrit :
Bonjour,


Bonjour

Je viens d'installer une Sid (amd64).

En testant Qemu, je me suis rendu compte que l'option "-vga std", pour
émuler une carte VGA standard, pose problème dans mon système invité.
Celui-ci (Win XP...) ne semble pas reconnaître cette carte et reste
coincé dans une résolution 800x600x4 ! Avec la carte Cirrus émulée
(option -vga cirrus), j'obtiens une résolution normale pour cette
carte de 1024x768. Bon, en même temps, c'est pas gravissime, mais pas
pratique pour moi.

Ce problème ne se pose pas avec la même option sur Ubuntu Jaunty (x86)
par exemple, ou là j'obtiens avec "-vga std" une résolution
1280x800x24 sur mon système invité, idéale pour mon portable.


Au démarrage en VGA standard le pilote VGA n'est pas trouvé, l'OS
virtualisé se règle en 800x600. A partir de là, en cliquant sur
propriété, je peux mettre la définition que je veux jusqu'à 2560x1600

Je suis en SID Amd64 également. Le problème doit être autre. Vgabios est
en 0.6c-1 comme vous.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Samy Mezani
Le #20135101
le 12/09/2009 10:57, Daniel Huhardeaux a écrit:

Samy Mezani a écrit :
Bonjour,


Bonjour

Je viens d'installer une Sid (amd64).

En testant Qemu, je me suis rendu compte que l'option "-vga std", pour
émuler une carte VGA standard, pose problème dans mon système invité.
Celui-ci (Win XP...) ne semble pas reconnaître cette carte et reste
coincé dans une résolution 800x600x4 ! Avec la carte Cirrus émulée
(option -vga cirrus), j'obtiens une résolution normale pour cette
carte de 1024x768. Bon, en même temps, c'est pas gravissime, mais pas
pratique pour moi.

Ce problème ne se pose pas avec la même option sur Ubuntu Jaunty (x86)
par exemple, ou là j'obtiens avec "-vga std" une résolution
1280x800x24 sur mon système invité, idéale pour mon portable.


Au démarrage en VGA standard le pilote VGA n'est pas trouvé, l'OS
virtualisé se règle en 800x600. A partir de là, en cliquant sur
propriété, je peux mettre la définition que je veux jusqu'à 2560x1600

Je suis en SID Amd64 également. Le problème doit être autre. Vgabios est
en 0.6c-1 comme vous.




Bonjour,
Merci mais j'avais déjà essayé de régler la résolution dans le système
invité mais :
- avec la version vgabios 0.6c-1 de Sid, blocage en 640x480x4 sans
possibilité de modif, carte non reconnue
- avec la version 0.6b-1 d'Ubuntu Jaunty, copiée pour voir dans
/usr/share/qemu, possibilité de choisir une résolution plus élevée mais
impossible de l'appliquer, le système invité reste en 640x480x4.
J'en déduis que ce paquet être peut-être responsable, mais pour
l'instant je sèche sur la solution.
Samy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Daniel Huhardeaux
Le #20135391
Samy Mezani a écrit :
[...]
Merci mais j'avais déjà essayé de régler la résolution dans le système
invité mais :
- avec la version vgabios 0.6c-1 de Sid, blocage en 640x480x4 sans
possibilité de modif, carte non reconnue
- avec la version 0.6b-1 d'Ubuntu Jaunty, copiée pour voir dans
/usr/share/qemu, possibilité de choisir une résolution plus élevée
mais impossible de l'appliquer, le système invité reste en 640x480x4.
J'en déduis que ce paquet être peut-être responsable, mais pour
l'instant je sèche sur la solution.


Oui, j'ai bien compris. Mais étant moi même dans la même version que
vous je doute que le paquet soit reponsable. J'utilise kvm et non qemu,
peut être que ...
--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Samy Mezani
Le #20135471
le 13/09/2009 21:05, Daniel Huhardeaux a écrit:

Samy Mezani a écrit :
[...]
Merci mais j'avais déjà essayé de régler la résolution dans le système
invité mais :
- avec la version vgabios 0.6c-1 de Sid, blocage en 640x480x4 sans
possibilité de modif, carte non reconnue
- avec la version 0.6b-1 d'Ubuntu Jaunty, copiée pour voir dans
/usr/share/qemu, possibilité de choisir une résolution plus élevée
mais impossible de l'appliquer, le système invité reste en 640x480x4.
J'en déduis que ce paquet être peut-être responsable, mais pour
l'instant je sèche sur la solution.


Oui, j'ai bien compris. Mais étant moi même dans la même version que
vous je doute que le paquet soit reponsable. J'utilise kvm et non qemu,
peut être que ...



J'ai répondu un peu vite, désolé. Le paquet vgabios ne peut être
responsable puisqu'avec celui d'Ubuntu le problème reste entier.
Sans doute voir du côté de Qemu effectivement. Dommage que mon
processeur ne me permette pas d'utiliser kvm...
Merci
Samy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Samy Mezani
Le #20135701
le 13/09/2009 21:12, Samy Mezani a écrit:

le 13/09/2009 21:05, Daniel Huhardeaux a écrit:

Samy Mezani a écrit :
[...]
Merci mais j'avais déjà essayé de régler la résolution dans le
système invité mais :
- avec la version vgabios 0.6c-1 de Sid, blocage en 640x480x4 sans
possibilité de modif, carte non reconnue
- avec la version 0.6b-1 d'Ubuntu Jaunty, copiée pour voir dans
/usr/share/qemu, possibilité de choisir une résolution plus élevée
mais impossible de l'appliquer, le système invité reste en 640x480x4.
J'en déduis que ce paquet être peut-être responsable, mais pour
l'instant je sèche sur la solution.


Oui, j'ai bien compris. Mais étant moi même dans la même version que
vous je doute que le paquet soit reponsable. J'utilise kvm et non
qemu, peut être que ...



J'ai répondu un peu vite, désolé. Le paquet vgabios ne peut être
responsable puisqu'avec celui d'Ubuntu le problème reste entier.
Sans doute voir du côté de Qemu effectivement. Dommage que mon
processeur ne me permette pas d'utiliser kvm...
Merci
Samy





J'ai trouvé une solution pas très propre qui règle le problème
temporairement.
J'ai récupéré de ma Ubuntu, /usr/share/bochs/BIOS-qemu-latest issu du
paquet bochsbios.
Ça marche impeccable.
Donc un problème dû au paquet bochsbios sans aucun doute !
Samy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme