Question sur le contage d'un caractère

Le
Nistan
Bonjour,

1) Comment faire pour recherche et conter le nombre fois qu'apparait un
caractère dans une cellule ?

2) Comment faire pour savoir s'il est des Majuscules dans une une cellule ?

Par avance merci de votre aide.
Cordialement.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Caetera
Le #19354321
> 1) Comment faire pour recherche et conter le nombre fois qu'apparait un
caractère dans une cellule ?



Pour compter le nombre de "X" (respect de la casse) en A1
=NBCAR(A1)-NBCAR(SUBSTITUE(A1;"M";""))

2) Comment faire pour savoir s'il est des Majuscules dans une une cellule ?



Nombre de majuscules en A1 :
=SOMMEPROD(1*((CODE(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1))>64)+(CODE(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1))<91)=2))

Matricielle (ctrl+maj+entrée)

Etc
JB
Le #19354311
Bonjour,

Nombre de virgules dans A1

=NBCAR(A1)-NBCAR(SUBSTITUE(A1;",";""))

http://boisgontierjacques.free.fr/pages_site/chaines.htm#SUBSTITUE

JB

On 17 mai, 17:48, Nistan
Bonjour,

1) Comment faire pour recherche et conter le nombre fois qu'apparait un
caractère dans une cellule ?

2) Comment faire pour savoir s'il est des Majuscules dans une une cellule ?

Par avance merci de votre aide.
Cordialement.


Caetera
Le #19354301
> Pour compter le nombre de "X" (respect de la casse) en A1
=NBCAR(A1)-NBCAR(SUBSTITUE(A1;"X";""))


Caetera
Le #19354291
> Nombre de majuscules en A1 :

=SOMMEPROD(1*((CODE(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1))>64)+(CODE(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1))<91)=2))



Validation simple

Etc
MichDenis
Le #19354411
Bonjour Nistan,

Une autre façon de faire pour le plaisir :

Le nombre de "o" en I7
Validation matricielle : Maj + ctrl + enter
insensible à la casse
=SOMME(SI(STXT(I7;LIGNE(INDIRECT("1:"&NBCAR(I7)));1)="o";1))

Compter le nombre de majuscules en I7
(j'ai supposé qu'il n'y avait que des caractères de l'alphabet...
Validation matricielle : Maj + ctrl + enter
=SOMME(SI(CODE(STXT(I7;LIGNE(INDIRECT("1:"&NBCAR(I7)));1))<;1))


"Nistan" discussion :
Bonjour,

1) Comment faire pour recherche et conter le nombre fois qu'apparait un
caractère dans une cellule ?

2) Comment faire pour savoir s'il est des Majuscules dans une une cellule ?

Par avance merci de votre aide.
Cordialement.
JB
Le #19354401
Nbre de caractères en A1

=SOMMEPROD(--EXACT(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1);MAJUSCULE
(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));1))))
ou
=SOMMEPROD(--EXACT(STXT(A1;LIGNE($1:255);1);MAJUSCULE(STXT(A1;LIGNE
($1:$255);1))))+NBCAR(A1)-255

JB

On 17 mai, 18:00, JB
Bonjour,

Nombre de virgules dans A1

=NBCAR(A1)-NBCAR(SUBSTITUE(A1;",";""))

http://boisgontierjacques.free.fr/pages_site/chaines.htm#SUBSTITUE

JB

On 17 mai, 17:48, Nistan


> Bonjour,

> 1) Comment faire pour recherche et conter le nombre fois qu'apparait un
> caractère dans une cellule ?

> 2) Comment faire pour savoir s'il est des Majuscules dans une une cellu le ?

> Par avance merci de votre aide.
> Cordialement.- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Caetera
Le #19354491
Pour compter le nombre de majuscules dans une cellule, faire des tests avec le
contenu suivant en A1 :

12345 azerty AZERTY

...........
Etc
Publicité
Poster une réponse
Anonyme