Question débile et sans importance sur Safari 3.x

Le
Jacques Perrocheau
Bonjour,

J'ai une question débile et de peu d'importance sur Safari 3.x ;-)

Quelqu'un sait-il pourquoi le paramètre "CFBundleShortVersionString"
dans"/Applications/Safari.app/Contents/version.plist" et
"/Applications/Safari.app/Contents/Info.plist" est bloqué à 3.0.4 dans
les versions (installations, mises à jour) pour Mac OS X 10.4.11 alors
que pour les versions pour Mac OS X 10.5.x, ce paramètres est en
concordance avec le numéro de version "CFBundleGetInfoString" ?

C'est peut-être une particularité sur mes machines

--
Jacques PERROCHEAU
CNRS UMR 6226
Université de Rennes 1, Campus de Beaulieu, 35042 RENNES Cedex, France
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
danrob
Le #19347181
Jacques Perrocheau
Quelqu'un sait-il pourquoi le paramètre "CFBundleShortVersionString"
dans"/Applications/Safari.app/Contents/version.plist" et
"/Applications/Safari.app/Contents/Info.plist" est bloqué à 3.0.4 dans
les versions (installations, mises à jour) pour Mac OS X 10.4.11 alors
que pour les versions pour Mac OS X 10.5.x, ce paramètres est en
concordance avec le numéro de version "CFBundleGetInfoString" ?

C'est peut-être une particularité sur mes machines...



Bienvenue au club.
Même constat : Safari 3.2.1 (10.4.11 PPC)
Jacques Perrocheau
Le #19358821
In article (Daniel Robillard) wrote:

> C'est peut-être une particularité sur mes machines...

Bienvenue au club.
Même constat : Safari 3.2.1 (10.4.11 PPC)



Visiblement on ne passionne pas les foules avec cette question
cosmétique. ;-)

--
Jacques PERROCHEAU
CNRS UMR 6226
Université de Rennes 1, Campus de Beaulieu, 35042 RENNES Cedex, France
danrob
Le #19363521
Jacques Perrocheau
Visiblement on ne passionne pas les foules avec cette question
cosmétique. ;-)



A partir de combien commence une foule ?
Deux, c'est un bon début ;-)
Jacques Perrocheau
Le #19422761
In article Jacques Perrocheau
Quelqu'un sait-il pourquoi le paramètre "CFBundleShortVersionString"
dans"/Applications/Safari.app/Contents/version.plist" et
"/Applications/Safari.app/Contents/Info.plist" est bloqué à 3.0.4 dans
les versions (installations, mises à jour) pour Mac OS X 10.4.11 alors
que pour les versions pour Mac OS X 10.5.x, ce paramètres est en
concordance avec le numéro de version "CFBundleGetInfoString" ?

C'est peut-être une particularité sur mes machines...



Puisque la question n'a intéressé personne, je vais me faire une réponse
;-).


J'ai eu la curiosité de télécharger l'installateur autonome
Safari3.2.3Ti.dmg. En regardant avec Pacifist dans les entrailles de
l'Archive.pax.gz et en extrayant "à la main" les fichiers:

"/Applications/Safari.app/Contents/Info.plist" et
"/Applications/Safari.app/Contents/version.plist"

je m'aperçois que les numéros de version dans les dits fichiers sont
tous à 3.2.3. Bon j'en conclue hâtivement que l'installateur de la mise
à jour automatique n'était pas sec. Je réinstalle avec ce dernier
installateur "par dessus" mon actuel Safari 3.2.3 et quelle n'est pas ma
surprise de constater que dans le fichier
"/Applications/Safari.app/Contents/Info.plist"
CFBundleShortVersionString est toujours à 3.0.4 (???).

De guerre lasse, j'ai fini pas mettre 3.2.3 à la main.

Une explication à mes déboires esthétiques ?

--
Jacques PERROCHEAU
CNRS UMR 6226
Université de Rennes 1, Campus de Beaulieu, 35042 RENNES Cedex, France
Publicité
Poster une réponse
Anonyme