Question d'encodage

Le
lionmarron
Bonjour,

Pour la seconde je reprends un source contenant :

usepackage[ansinew]{inputenc}

que je remplace par : usepackage[utf8]{inputenc}.

La fois précédente cela a eu pour effet de modifier le source : les
lettres accentuées ont été remplacées par un antislash suivit d'un
nombre à trois chiffre. Après quoi j'ai remplacé tout ça par les lettres
accentuées du clavier et les choses sont rentrées dans l'ordre.

Cette fois Emacs ne mange plus de ce pain là : les lettres accentuées
sont toujours dans le source, mais à la compilation elles disparaissent
en faisant disparaître quelques lettres suivantes. Je peux m'en sortir
en remplaçant par exemple é par 'e, mais je si j'utilise les lettres
accentuées du clavier la situation ne s'améliore pas.


Je suppose que la question risque de paraître bien naïve. Le fait que
j'ai souvent procédé par tâtonnement et, même en faisant ça depuis
longtemps, ce n'est peut-être pas toujours la bonne façon d'apprendre.

Inutile de dire que j'ignore également une modification du même type
n’entraînait pas de conséquence sous WinEdt. On pouvait remplacer
inputenc ceci par inputenc cela entraîner modification du source ni
erreur de compilation.

--
lionmarron
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
lionmarron
Le #23983281
Le 19/11/2011 22:07, lionmarron a écrit :

Inutile de dire que j'ignore également une modification du même type
n’entraînait pas de conséquence sous WinEdt. On pouvait remplacer
inputenc ceci par inputenc cela entraîner modification du source ni
erreur de compilation.

Inutile de dire que j'ignore également POURQUOI une modification du


même type
n’entraînait pas de conséquence sous WinEdt. On pouvait remplacer
inputenc ceci par inputenc SANS entraîner modification du source ni
erreur de compilation.



--
lionmarron
lionmarron
Le #23983271
Le 19/11/2011 22:07, lionmarron a écrit :

Inutile de dire que j'ignore également une modification du même type
n’entraînait pas de conséquence sous WinEdt. On pouvait remplacer
inputenc ceci par inputenc cela entraîner modification du source ni
erreur de compilation.



Bon j'y arriverai pas :

Inutile de dire que j'ignore également POURQUOI une modification du


même type
n’entraînait pas de conséquence sous WinEdt. On pouvait remplacer
inputenc ceci par inputenc cela SANS entraîner modification du source ni
erreur de compilation.
Pascal J. Bourguignon
Le #23984011
lionmarron
Pour la seconde je reprends un source contenant :

usepackage[ansinew]{inputenc}

que je remplace par : usepackage[utf8]{inputenc}.



Mettre un commentaire sur la première ligne:

+--- Je ne sais pas comment on fait un commentaire en latex.
|
v
?? -*- coding:utf-8 -*-

usepackage[utf8]{inputenc}.


--
__Pascal Bourguignon__ http://www.informatimago.com/
A bad day in () is better than a good day in {}.
lionmarron
Le #23984731
Le 20/11/2011 06:30, Pascal J. Bourguignon a écrit :
lionmarron
Pour la seconde je reprends un source contenant :

usepackage[ansinew]{inputenc}

que je remplace par : usepackage[utf8]{inputenc}.



Mettre un commentaire sur la première ligne:

+--- Je ne sais pas comment on fait un commentaire en latex.
|
v
?? -*- coding:utf-8 -*-

usepackage[utf8]{inputenc}.




Mirobolant ! Et merci pour cette réponse.

On fait un commentaire avec %

Comme cela a déclenché un message d'erreur, j'ai plutôt essayé :

% -*- coding:utf8 -*-

Et non seulement le problème est résolu, mais il n'y a pas besoin de
retaper les accents.

--
lionmarron
lionmarron
Le #23984781
Le 20/11/2011 10:57, lionmarron a écrit :

Comme cela a déclenché un message d'erreur, j'ai plutôt essayé :

% -*- coding:utf8 -*-



Bon finalement c'était bien : % -*- coding:utf-8 -*-

--
lionmarron
Publicité
Poster une réponse
Anonyme